Initial import of seccure-0.4 into the Packages Collection.
The seccure toolset implements a selection of asymmetric algorithms based on elliptic curve cryptography (ECC). In particular it offers public key encryption / decryption, signature generation / verification and key establishment. ECC schemes offer a much better key size to security ratio than classical systems (RSA, DSA). Keys are short enough to make direct specification of keys on the command line possible (sometimes this is more convenient than the management of PGP-like key rings). seccure builds on this feature and therefore is the tool of choice whenever lightweight asymmetric cryptography -- independent of key servers, revocation certificates, the Web of Trust or even configuration files -- is required.
This commit is contained in:
parent
05f983ffcb
commit
4becb70c17
5 changed files with 84 additions and 0 deletions
13
security/seccure/DESCR
Normal file
13
security/seccure/DESCR
Normal file
|
@ -0,0 +1,13 @@
|
|||
The seccure toolset implements a selection of asymmetric algorithms
|
||||
based on elliptic curve cryptography (ECC). In particular it offers
|
||||
public key encryption / decryption, signature generation /
|
||||
verification and key establishment.
|
||||
|
||||
ECC schemes offer a much better key size to security ratio than
|
||||
classical systems (RSA, DSA). Keys are short enough to make direct
|
||||
specification of keys on the command line possible (sometimes this is
|
||||
more convenient than the management of PGP-like key rings). seccure
|
||||
builds on this feature and therefore is the tool of choice whenever
|
||||
lightweight asymmetric cryptography -- independent of key servers,
|
||||
revocation certificates, the Web of Trust or even configuration files
|
||||
-- is required.
|
17
security/seccure/Makefile
Normal file
17
security/seccure/Makefile
Normal file
|
@ -0,0 +1,17 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2009/12/14 08:00:05 agc Exp $
|
||||
|
||||
DISTNAME= seccure-0.4
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://point-at-infinity.org/seccure/
|
||||
|
||||
MAINTAINER= agc@NetBSD.org
|
||||
HOMEPAGE= http://point-at-infinity.org/seccure/
|
||||
COMMENT= SECCURE Elliptic Curve Crypto Utility for Reliable Encryption
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1
|
||||
|
||||
.include "../../security/libgcrypt/buildlink3.mk"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
10
security/seccure/PLIST
Normal file
10
security/seccure/PLIST
Normal file
|
@ -0,0 +1,10 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/12/14 08:00:05 agc Exp $
|
||||
bin/seccure-decrypt
|
||||
bin/seccure-dh
|
||||
bin/seccure-encrypt
|
||||
bin/seccure-key
|
||||
bin/seccure-sign
|
||||
bin/seccure-signcrypt
|
||||
bin/seccure-veridec
|
||||
bin/seccure-verify
|
||||
${PKGMANDIR}/man1/seccure.1
|
6
security/seccure/distinfo
Normal file
6
security/seccure/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/12/14 08:00:05 agc Exp $
|
||||
|
||||
SHA1 (seccure-0.4.tar.gz) = 883e335f58cc36279c33493ab219f4940a46dab8
|
||||
RMD160 (seccure-0.4.tar.gz) = fc35fdf69372c39b20a67c5341b1e36ce6bf8e9f
|
||||
Size (seccure-0.4.tar.gz) = 31881 bytes
|
||||
SHA1 (patch-aa) = 1a83424f90b94e38ccbb4c1d0fa210032c4aab65
|
38
security/seccure/patches/patch-aa
Normal file
38
security/seccure/patches/patch-aa
Normal file
|
@ -0,0 +1,38 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2009/12/14 08:00:05 agc Exp $
|
||||
|
||||
--- Makefile 2009/12/07 22:32:10 1.1
|
||||
+++ Makefile 2009/12/07 22:37:20
|
||||
@@ -1,6 +1,9 @@
|
||||
CFLAGS = -O2 -Wall # -D NOBEEP
|
||||
|
||||
-default: binaries # doc
|
||||
+BINDIR=${DESTDIR}${PREFIX}/bin
|
||||
+MANDIR=${DESTDIR}${PREFIX}/${PKGMANDIR}
|
||||
+
|
||||
+default all build: binaries # doc
|
||||
|
||||
binaries: seccure-key seccure-encrypt seccure-decrypt seccure-sign \
|
||||
seccure-verify seccure-signcrypt seccure-veridec seccure-dh
|
||||
@@ -8,15 +11,13 @@
|
||||
doc: seccure.1 seccure.1.html
|
||||
|
||||
install: default
|
||||
- install -m0755 seccure-key $(DESTDIR)/usr/bin
|
||||
- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-encrypt
|
||||
- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-decrypt
|
||||
- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-sign
|
||||
- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-verify
|
||||
- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-signcrypt
|
||||
- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-veridec
|
||||
- ln -f $(DESTDIR)/usr/bin/seccure-key $(DESTDIR)/usr/bin/seccure-dh
|
||||
- install -m0644 seccure.1 $(DESTDIR)/usr/share/man/man1
|
||||
+ ${BSD_INSTALL_PROGRAM} seccure-key ${BINDIR}
|
||||
+ for f in encrypt decrypt sign verify signcrypt veridec dh; do \
|
||||
+ rm -f ${BINDIR}/seccure-$$f; \
|
||||
+ ln ${BINDIR}/seccure-key ${BINDIR}/seccure-$$f; \
|
||||
+ ls -l ${BINDIR}/seccure-$$f; \
|
||||
+ done
|
||||
+ ${BSD_INSTALL_MAN} seccure.1 ${MANDIR}/man1
|
||||
|
||||
clean:
|
||||
rm -f *.o *~ seccure-key seccure-encrypt seccure-decrypt seccure-sign \
|
Loading…
Reference in a new issue