Update bochs to 1.3. Version 1.3 clearly performs better, and is more
stable than, version 1.1.2. Extensive changes include a new text-based configuration menu (which starts at launch and upon pressing the config button), LBA support for hard disks, better error handling for "hard disk" configuration errors, and a new VGABIOS (optional). Plus, bochs can now simulate an SMP machine! [The last is not tested on NetBSD, and is not enabled by default in the package.]
This commit is contained in:
parent
300b830afe
commit
4c5c9e6203
6 changed files with 92 additions and 66 deletions
|
@ -1,16 +1,19 @@
|
|||
# $NetBSD: Makefile,v 1.15 2001/05/25 23:01:30 kei Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2001/12/13 18:03:52 fredb Exp $
|
||||
|
||||
DISTNAME= bochs-1.1.2
|
||||
DISTNAME= bochs-1.3
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=bochs/}
|
||||
|
||||
MAINTAINER= root@garbled.net
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://bochs.sourceforge.net/
|
||||
COMMENT= I386 machine emulator capable of running dos/windows
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
#CONFIGURE_ARGS= --enable-debugger --enable-disasm
|
||||
# These options are not enabled by default because they can adversely impact
|
||||
# performance. The number of processors can be either 1 (default), 2, or 4.
|
||||
#CONFIGURE_ARGS+= --enable-debugger --enable-disasm
|
||||
#CONFIGURE_ARGS+= --enable-processors=2
|
||||
USE_X11= yes
|
||||
|
||||
BOCHS_MAINDIR= ${PREFIX}/share/bochs
|
||||
|
@ -27,9 +30,13 @@ post-configure:
|
|||
|
||||
do-install:
|
||||
${INSTALL_DATA_DIR} ${BOCHS_BIOSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/bios/BIOS-bochs-990925a ${BOCHS_BIOSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/bios/BIOS-bochs-2-processors ${BOCHS_BIOSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/bios/BIOS-bochs-4-processors ${BOCHS_BIOSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/bios/BIOS-bochs-latest ${BOCHS_BIOSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/bios/VGABIOS-elpin-2.40 ${BOCHS_BIOSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/bios/VGABIOS-elpin-LICENSE ${BOCHS_BIOSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/bios/VGABIOS-cbothamy-0.2a ${BOCHS_BIOSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/bios/VGABIOS-cbothamy-0.2a-README ${BOCHS_BIOSDIR}
|
||||
${INSTALL_DATA_DIR} ${BOCHS_DOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/docs-html/00README ${BOCHS_DOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/docs-html/*.gif ${BOCHS_DOCDIR}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2001/10/31 23:52:15 zuntum Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2001/12/13 18:03:52 fredb Exp $
|
||||
bin/bochs
|
||||
share/doc/html/bochs/00README
|
||||
share/doc/html/bochs/3rdparty.license.html
|
||||
|
@ -21,12 +21,18 @@ share/doc/html/bochs/guestNT.html
|
|||
share/doc/html/bochs/index.html
|
||||
share/doc/html/bochs/install.html
|
||||
share/doc/html/bochs/instrumentation.html
|
||||
share/doc/html/bochs/iodebug.html
|
||||
share/doc/html/bochs/mtools.html
|
||||
share/doc/html/bochs/smp-simulation.html
|
||||
share/doc/html/bochs/sound.html
|
||||
share/doc/html/bochs/undercon.gif
|
||||
share/doc/html/bochs/whatisbochs.html
|
||||
share/doc/html/bochs/win32.html
|
||||
share/bochs/bios/BIOS-bochs-990925a
|
||||
share/bochs/bios/BIOS-bochs-2-processors
|
||||
share/bochs/bios/BIOS-bochs-4-processors
|
||||
share/bochs/bios/BIOS-bochs-latest
|
||||
share/bochs/bios/VGABIOS-cbothamy-0.2a
|
||||
share/bochs/bios/VGABIOS-cbothamy-0.2a-README
|
||||
share/bochs/bios/VGABIOS-elpin-2.40
|
||||
share/bochs/bios/VGABIOS-elpin-LICENSE
|
||||
share/bochs/xfonts/fonts.dir
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.4 2001/05/25 23:01:31 kei Exp $
|
||||
$NetBSD: distinfo,v 1.5 2001/12/13 18:03:52 fredb Exp $
|
||||
|
||||
SHA1 (bochs-1.1.2.tar.gz) = 61b57a87e1103ad5d7c3b620b90113b03dea0893
|
||||
Size (bochs-1.1.2.tar.gz) = 770209 bytes
|
||||
SHA1 (patch-aa) = d070edc574e3c658e720740cbab5bcadc86c9c83
|
||||
SHA1 (bochs-1.3.tar.gz) = cbec3868d6f99d0813c3d82344967647d498339f
|
||||
Size (bochs-1.3.tar.gz) = 1147490 bytes
|
||||
SHA1 (patch-aa) = d97c2b6e814d876e9cf164b5977ee4608bed4305
|
||||
SHA1 (patch-ab) = 340261dc14c65626b44abd2f7665cf2a87b233b4
|
||||
SHA1 (patch-ac) = f6fd1486756c3d29d37215aa9909059083637843
|
||||
SHA1 (patch-ae) = 8ff913377fbc95cb1c2edc133e625d48a47f6900
|
||||
SHA1 (patch-ac) = 1dab10b3236022a41e529a9244bd23943094df56
|
||||
SHA1 (patch-ae) = 05b4d7663735594f427a236428d6cea9510c080e
|
||||
|
|
|
@ -1,44 +1,57 @@
|
|||
$NetBSD: patch-aa,v 1.4 2001/05/25 23:01:31 kei Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2001/12/13 18:03:53 fredb Exp $
|
||||
|
||||
--- .bochsrc.orig Wed May 16 15:25:21 2001
|
||||
+++ .bochsrc Fri May 25 15:45:28 2001
|
||||
@@ -2,8 +2,8 @@
|
||||
megs: 32
|
||||
#megs: 16
|
||||
#megs: 8
|
||||
-boot: c
|
||||
--- .bochsrc.orig Mon Nov 19 08:36:26 2001
|
||||
+++ .bochsrc
|
||||
@@ -9,10 +9,11 @@
|
||||
# directory, named BIOS-bochs-yymmdd. Use the latest one in there.
|
||||
#=======================================================================
|
||||
#romimage: bios/BIOS-bochs-970717a
|
||||
-romimage: file=bios/BIOS-bochs-latest, address=0xf0000
|
||||
+#romimage: file=bios/BIOS-bochs-latest, address=0xf0000
|
||||
#romimage: file=bios/BIOS-bochs-2-processors, address=0xf0000
|
||||
#romimage: file=bios/BIOS-bochs-4-processors, address=0xf0000
|
||||
#romimage: file=bios/rombios.bin, address=0xf0000
|
||||
+romimage: file=XXXPREFIXXXX/share/bochs/bios/BIOS-bochs-latest, address=0xf0000
|
||||
|
||||
#=======================================================================
|
||||
# MEGS
|
||||
@@ -33,7 +34,8 @@
|
||||
# You now need to load a VGA ROM BIOS into C0000.
|
||||
#=======================================================================
|
||||
#vgaromimage: bios/VGABIOS-cbothamy-0.2a
|
||||
-vgaromimage: bios/VGABIOS-elpin-2.40
|
||||
+boot: a
|
||||
+#vgaromimage: bios/VGABIOS-elpin-2.40
|
||||
+vgaromimage: XXXPREFIXXXX/share/bochs/bios/VGABIOS-elpin-2.40
|
||||
|
||||
# You many now use double quotes around pathnames, in case
|
||||
# your pathname includes spaces.
|
||||
@@ -33,7 +33,7 @@
|
||||
#diskc: file=../528M, cyl=1024, heads=16, spt=63
|
||||
|
||||
#diskc: file=../62M.980115, cyl=940, heads=8, spt=17
|
||||
-diskc: file="../10M.vga", cyl=306, heads=4, spt=17
|
||||
+#diskc: file="../10M.vga", cyl=306, heads=4, spt=17
|
||||
#diskc: file=../10M.dos622, cyl=306, heads=4, spt=17
|
||||
#diskc: file=../30M.freebsd, cyl=615, heads=6, spt=17
|
||||
#diskc: file=../126M.freeBSD_2.2.8, cyl=256, heads=16, spt=63
|
||||
@@ -58,7 +58,9 @@
|
||||
#floppya: 1_44=../1.44.freebsd, status=inserted
|
||||
#floppya: 720k=../720k.dos33, status=inserted
|
||||
|
||||
-floppya: 1_44=../1.44a, status=inserted
|
||||
#=======================================================================
|
||||
# FLOPPYA:
|
||||
@@ -57,7 +59,8 @@
|
||||
#floppya: file=../1.44, status=ejected
|
||||
#floppya: 1_44=/dev/fd0H1440, status=ejected
|
||||
#floppya: 1_2=../1_2, status=ejected
|
||||
-floppya: 1_44=a.img, status=inserted
|
||||
+#floppya: 1_44=a.img, status=inserted
|
||||
+floppya: 1_44=/dev/rfd0a, status=inserted
|
||||
+
|
||||
+#floppya: 1_44=../1.44a, status=inserted
|
||||
#floppyb: 1_44=../1.44b, status=inserted
|
||||
#floppya: 1_44=/dev/fd0, status=inserted
|
||||
#floppyb: 1_44=../1.44b, status=inserted
|
||||
@@ -68,7 +70,7 @@
|
||||
#floppya: 1_2=../1.2
|
||||
#floppyb: 1_44=../1.680
|
||||
|
||||
-romimage: file=bios/BIOS-bochs-990925a, address=0xf0000
|
||||
+romimage: file=XXXPREFIXXXX/share/bochs/bios/BIOS-bochs-990925a, address=0xf0000
|
||||
#=======================================================================
|
||||
# FLOPPYB:
|
||||
@@ -78,7 +81,7 @@
|
||||
# diskc: file=112M.sample, cyl=900, heads=15, spt=17
|
||||
# diskc: file=483M.sample, cyl=1024, heads=15, spt=63
|
||||
#=======================================================================
|
||||
-diskc: file="30M.sample", cyl=615, heads=6, spt=17
|
||||
+#diskc: file="30M.sample", cyl=615, heads=6, spt=17
|
||||
|
||||
#romimage: file=bios/rombios.bin, address=0xf0000
|
||||
#romimage: file=../cbios961203
|
||||
#=======================================================================
|
||||
# DISKD:
|
||||
@@ -109,8 +112,8 @@
|
||||
# boot: c
|
||||
# boot: a
|
||||
#=======================================================================
|
||||
-#boot: a
|
||||
-boot: c
|
||||
+boot: a
|
||||
+#boot: c
|
||||
|
||||
#=======================================================================
|
||||
# LOG:
|
||||
|
|
|
@ -1,16 +1,16 @@
|
|||
$NetBSD: patch-ac,v 1.2 2001/05/25 23:01:31 kei Exp $
|
||||
$NetBSD: patch-ac,v 1.3 2001/12/13 18:03:53 fredb Exp $
|
||||
|
||||
--- iodev/keyboard.cc.orig Wed May 16 15:54:39 2001
|
||||
+++ iodev/keyboard.cc Fri May 25 15:50:39 2001
|
||||
@@ -954,6 +954,11 @@
|
||||
--- iodev/keyboard.cc.orig Sat Dec 8 08:02:57 2001
|
||||
+++ iodev/keyboard.cc
|
||||
@@ -973,6 +973,11 @@
|
||||
kbd_enQ(0xEE); // return same byte (EEh) as echo diagnostic
|
||||
return;
|
||||
break;
|
||||
|
||||
+
|
||||
+ case 0xf0: // set scancode - let OS time out
|
||||
+ bx_printf("KBD: set scancode command received\n");
|
||||
+ //bx_printf("KBD: set scancode command received\n");
|
||||
+ return;
|
||||
+ break;
|
||||
+
|
||||
|
||||
case 0xf2: // identify keyboard
|
||||
bx_printf("KBD: identify keyboard command received\n");
|
||||
kbd_enQ(0xFA); // AT sends ACK, MFII sends ACK+ABh+41h
|
||||
BX_INFO(("identify keyboard command received"));
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.1 2000/01/31 21:18:44 drochner Exp $
|
||||
$NetBSD: patch-ae,v 1.2 2001/12/13 18:03:53 fredb Exp $
|
||||
|
||||
--- debug/lexer.c.orig Sat Jan 29 22:02:47 2000
|
||||
+++ debug/lexer.c Sat Jan 29 22:03:16 2000
|
||||
@@ -1272,7 +1272,7 @@
|
||||
case 92:
|
||||
--- debug/lexer.c.orig Wed Nov 28 12:40:02 2001
|
||||
+++ debug/lexer.c
|
||||
@@ -1368,7 +1368,7 @@
|
||||
case 109:
|
||||
YY_RULE_SETUP
|
||||
#line 108 "lexer.l"
|
||||
#line 129 "lexer.l"
|
||||
-{ bxlval.ulval = strtoull(bxtext, NULL, 10); return(BX_TOKEN_LONG_NUMERIC); }
|
||||
+{ bxlval.ulval = strtouq(bxtext, NULL, 10); return(BX_TOKEN_LONG_NUMERIC); }
|
||||
YY_BREAK
|
||||
case 93:
|
||||
case 110:
|
||||
YY_RULE_SETUP
|
||||
|
|
Loading…
Reference in a new issue