xclock: update to 1.1.0.
Alan Coopersmith (5): Fix build on Solaris Fix spelling/wording issues gitlab CI: add a basic build test Build xz tarballs instead of bzip2 xclock 1.1.0 Keith Packard (1): Update hands smoothly in Render mode rees4905 (2): re-indent Clock.c man: Indicate that -twelve & -twentyfour only affect brief display
This commit is contained in:
parent
7f57a247ca
commit
4c99bf8069
3 changed files with 24 additions and 8 deletions
|
@ -1,10 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.11 2020/08/17 20:20:14 leot Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2022/04/03 22:13:17 wiz Exp $
|
||||
|
||||
DISTNAME= xclock-1.0.9
|
||||
PKGREVISION= 1
|
||||
DISTNAME= xclock-1.1.0
|
||||
CATEGORIES= time x11
|
||||
MASTER_SITES= ${MASTER_SITE_XORG:=app/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
|
||||
MAINTAINER= joerg@NetBSD.org
|
||||
HOMEPAGE= https://xorg.freedesktop.org/
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.7 2021/10/26 11:24:46 nia Exp $
|
||||
$NetBSD: distinfo,v 1.8 2022/04/03 22:13:17 wiz Exp $
|
||||
|
||||
BLAKE2s (xclock-1.0.9.tar.bz2) = c948921864d0de00f3927eeb0eaf57384f88af6e1ef9a756d5da45f3bd38e220
|
||||
SHA512 (xclock-1.0.9.tar.bz2) = fcbac0b4ab1cea4ae0751ce1c0c6302048e5d98d459873c7580e4ca786ec49fa27f73e5831bdfe135abb5cfeabe886456276e9d01351ea7905c606f40f84522d
|
||||
Size (xclock-1.0.9.tar.bz2) = 175372 bytes
|
||||
BLAKE2s (xclock-1.1.0.tar.xz) = 5421c4cf2f4e46dd6399e3f95ec64e8f4c050e044c3c978d41e35ecb70fa7cb9
|
||||
SHA512 (xclock-1.1.0.tar.xz) = 9456ed43cb8afce4a1f1c4edcb87bfb86f61fb54d1892f26812ed10662c9b8f8c28854934ce4eb981090d500fec0f295ba96df9867dd1685dc5f31202729a1a0
|
||||
Size (xclock-1.1.0.tar.xz) = 158984 bytes
|
||||
SHA1 (patch-Clock.c) = 3cea7082fc86b696cde8de0d5c6d6badd979cd2c
|
||||
|
|
16
time/xclock/patches/patch-Clock.c
Normal file
16
time/xclock/patches/patch-Clock.c
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-Clock.c,v 1.1 2022/04/03 22:13:17 wiz Exp $
|
||||
|
||||
NetBSD does not provide sincos().
|
||||
|
||||
--- Clock.c.orig 2022-04-03 21:23:33.000000000 +0000
|
||||
+++ Clock.c
|
||||
@@ -1734,7 +1734,8 @@ erase_hands(ClockWidget w, struct tm *tm
|
||||
static void
|
||||
ClockAngle(double tick_units, double *sinp, double *cosp)
|
||||
{
|
||||
- sincos(tick_units * (M_PI / 180 / 10.0), sinp, cosp);
|
||||
+ *sinp = sin(tick_units * (M_PI / 180 / 10.0));
|
||||
+ *cosp = cos(tick_units * (M_PI / 180 / 10.0));
|
||||
}
|
||||
|
||||
/*
|
Loading…
Reference in a new issue