Update multitail to 2.0
- you can now also tail external commands with MultiTail. - negating regular expressions did not work.
This commit is contained in:
parent
9e936f06a8
commit
4cbc43834e
4 changed files with 32 additions and 35 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/04/18 08:44:16 mjl Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2003/04/23 11:56:33 mjl Exp $
|
||||
#
|
||||
|
||||
DISTNAME= multitail-1.8
|
||||
DISTNAME= multitail-2.0
|
||||
CATEGORIES= misc sysutils
|
||||
MASTER_SITES= http://www.vanheusden.com/multitail/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -10,6 +10,9 @@ MAINTAINER= packages@netbsd.org
|
|||
HOMEPAGE= http://www.vanheusden.com/multitail/
|
||||
COMMENT= view one or multiple files
|
||||
|
||||
CFLAGS+= -DUSE_CURSES=1 -DKEY_RESIZE=-1
|
||||
LDFLAGS+= -lutil
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/multitail ${PREFIX}/bin/
|
||||
${INSTALL_MAN} ${WRKSRC}/multitail.1 ${PREFIX}/man/man1/
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/04/18 08:44:16 mjl Exp $
|
||||
$NetBSD: distinfo,v 1.2 2003/04/23 11:56:33 mjl Exp $
|
||||
|
||||
SHA1 (multitail-1.8.tgz) = 70c039d6f33d6342694ac8423c0bb1cf636adce4
|
||||
Size (multitail-1.8.tgz) = 14484 bytes
|
||||
SHA1 (patch-aa) = 9d410326341d93cde7798624e0ddfd1a1c6cb8af
|
||||
SHA1 (patch-ab) = c539e3ba0722f0daefba802b9a0eed1de15ecb91
|
||||
SHA1 (multitail-2.0.tgz) = e83251af642072aeff48e414e113ae8e0652bcfa
|
||||
Size (multitail-2.0.tgz) = 15727 bytes
|
||||
SHA1 (patch-aa) = 4fe2321d04a09f36dfb4b0cccefe2a31e794ae0c
|
||||
SHA1 (patch-ab) = 2beacedc3279f386480bbe22b7c61a87795bdda1
|
||||
|
|
|
@ -1,24 +1,12 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2003/04/18 08:44:16 mjl Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2003/04/23 11:56:33 mjl Exp $
|
||||
|
||||
--- Makefile.orig 2003-04-17 19:37:46.000000000 +0200
|
||||
+++ Makefile 2003-04-18 10:36:37.000000000 +0200
|
||||
@@ -2,8 +2,8 @@
|
||||
|
||||
CC=gcc
|
||||
|
||||
--- Makefile.orig Tue Apr 22 18:47:56 2003
|
||||
+++ Makefile Wed Apr 23 13:48:18 2003
|
||||
@@ -5,2 +5,2 @@
|
||||
-CFLAGS=-O2 -Wall
|
||||
-LDFLAGS=-lncurses
|
||||
+CFLAGS=-O2 -Wall -DKEY_RESIZE=KEY_REFRESH
|
||||
+LDFLAGS=-lcurses
|
||||
VERSION=1.8
|
||||
|
||||
OBJS=mt.o
|
||||
@@ -12,7 +12,7 @@
|
||||
|
||||
multitail: $(OBJS)
|
||||
$(CC) -Wall -W $(OBJS) $(LDFLAGS) -o multitail
|
||||
-LDFLAGS=-lncurses -lutil
|
||||
+CFLAGS+=-O2 -Wall -DKEY_RESIZE=-1
|
||||
+LDFLAGS+=-lcurses
|
||||
@@ -15 +15 @@
|
||||
- strip multitail
|
||||
+ # strip multitail
|
||||
|
||||
install: multitail
|
||||
cp multitail /usr/local/bin
|
||||
|
|
|
@ -1,13 +1,19 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2003/04/18 08:44:16 mjl Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2003/04/23 11:56:33 mjl Exp $
|
||||
|
||||
--- mt.c.orig 2003-04-18 10:27:59.000000000 +0200
|
||||
+++ mt.c 2003-04-18 10:28:07.000000000 +0200
|
||||
@@ -5,7 +5,7 @@
|
||||
--- mt.c.orig Tue Apr 22 18:47:56 2003
|
||||
+++ mt.c Wed Apr 23 13:44:55 2003
|
||||
@@ -5,9 +5,13 @@
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
#include <limits.h>
|
||||
-#include <ncurses.h>
|
||||
+#if defined(USE_CURSES)
|
||||
+#include <curses.h>
|
||||
#include <regex.h>
|
||||
#include <sched.h>
|
||||
#include <signal.h>
|
||||
+#else
|
||||
#include <ncurses.h>
|
||||
+#endif
|
||||
|
||||
-#ifdef __OpenBSD__
|
||||
+#if defined(__OpenBSD__) || defined(__NetBSD__)
|
||||
#include <util.h>
|
||||
#endif
|
||||
#ifdef linux
|
||||
|
|
Loading…
Reference in a new issue