Update to version 1.0.0

Changes:

--- 2010.12.27 ---

Request #237:
Add timeout to route calculation
Request #238:
Add order to selected waypoints to create a route
Request #239:
Add Garmin BirdsEye support (display only)



--- 2010.12.06 ---

Request #231:
Make anti-aliasing an option
Bug     #232:
Photos in the south eastern hemisphere are referenced badly
Request #233:
Make tracks and routes semi-transparent
Request #234:
Add legend for Garmin maps
Request #235:
Fixes and improvements for NMEA support
Request #236:
Move map with Alt+mouse move



--- 2010.11.15 ---

Request #218:
Add "description" as additional field to waypoints.
Request #219:
Make routing language a selection
Bug     #220:
Fixed: Garmin Custom Maps fail on maps with lon/lat projection
Bug     #221:
Fixed: Crash when exporting maps with bad or missing mdr file
Request #222:
Make baudrate selectable for NMEA device.
Request #223:
Update Spanish translation
Request #224:
Update italian transaltion
Request #225:
Update dutch translation
Request #226:
Add location search via OpenRouteService
Request #227:
Add most important web links to help menu
Bug     #228:
Fixed: Add big endian fixes for OS X
Request #229:
Distance over time graph
Bug     #230:
Fixed: Strings for 20bit type polylines and polygons are decoded badly



--- 2010.11.02 ---

Bug     #217:
Forgot to do a commit before the release



--- 2010.11.02 ---

Request #210:
Make UI fit for GNOME
Request #211:
Add tooltip (optional) for items below cursor on Garmin maps
Request #212:
Make zoom level and track maxima labels optional
Request #213:
Prepare route object for autorouting information
Request #214:
Add autorouting via openroute service
Request #215:
Use secondary (autorouted) route for gpx export
Request #216:
Use secondary (autorouted) route for garmin device upload



--- 2010.09.26 ---

Request #170:
Show extended data of tracks
Bug     #202:
Various user supplied bugfixes.
Request #203:
Pimp up map canvas
Request #204:
Add min/max elevation markers to highlighted track
Bug     #205:
File dialog for screenshot, save track stat plot and save canvas behaves strange.
Request #206:
GeoDB: add summary about item as tooltip rather than the real comment.
Request #208:
Add track profile preview on canvas
Request #209:
Make scale and wind rose optional



--- 2010.09.11 ---

Request #195:
Export raster maps to KMZ
Request #196:
Export raster maps as Garmin Custom Map tiles
Request #197:
Make folder system of geo database a bit more flexible
Bug     #198:
Optimize geo database access and fix many glitches.
Bug     #199:
Some tiles on OSM maps are not selectable
Bug     #200:
Fix glitches in track profile/ edit/ toolview interaction
Request #201:
Enhance guideline and snap algorithm for drawing distance polylines



--- 2010.08.15 ---

Bug     #192:
Fixed Garmin map: Small vertical or horizontal lines are not drawn
Request #193:
Use SQLite database for user data
Request #194:
Add project explorer for the database



--- 2010.07.28 ---

Request #184:
Detect proxy from environment variable
Request #185:
Get elevation data for artificial tracks from www.geonames.org
Request #186:
Improove snap to line for distance polyline
Bug     #187:
Fix: endian bugs in Garmin label decoding
Request #188:
Split track in segements of size N
Request #189:
Sort tracks by name and time
Request #190:
Copy-n-paste for distance polyline.
Request #191:
Combine several distance polyline overlays



--- 2010.07.04 ---

Request #177:
Keep on adding points when adding points to start or end of distance polyline
Bug     #178:
Fix: End points are deleted when moving around is aborted.
Request #179:
Add speed and estimated time to distance polyline
Request #180:
Select items for export/upload
Bug     #181:
Fix: Proximity circles are not drawn if waypoint leaves viewport
Request #182:
Make distance polyline follow lines in vector map
Bug     #183:
Change shortcut description from Del to Ctrl + Del in left hand tool widgets



--- 2010.06.06 ---

Bug     #172:
Fixed: typ file not working on device.
Request #173:
Sort waypoints by name, icon or position
Request #174:
Make track bubbles an option
Request #175:
Fine tune reference offset for raster maps
Bug     #176:
Fix performance stall when loading large quantity (>2000) of waypoints



--- 2010.05.10 ---

Request #167:
Dutch translation
Request #168:
Add gpsd support
Request #169:
Optimize map rendering for Garmin maps
Request #171:
Add selection for typ file if there are several



--- 2010.04.03 ---

Bug     #157:
Fixed: Bad zoom factor for "zoom to fit"
Request #158:
Sort list entries in tool views
Request #159:
Accept more formats for waypoint coords and related.
Bug     #160:
Fixed: Typ file is not used in gmapsupp.img
Request #161:
Code map set name into gmapsupp.img
Request #162:
Allow use of *.hgt files to import elevation data
Bug     #163:
Fixed: GDAL tools not found on OS X port
Bug     #164:
Fixed: Endless loop on profile over time for tracks with no timestamp.
Request #165:
Revert track
Request #166:
Speed up loading of Garmin tiles.
This commit is contained in:
jkunz 2011-01-13 22:55:20 +00:00
parent f5b7672735
commit 4cbc5f696c
4 changed files with 24 additions and 10 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.7 2011/01/13 13:37:55 wiz Exp $
# $NetBSD: Makefile,v 1.8 2011/01/13 22:55:20 jkunz Exp $
#
DISTNAME= qlandkartegt-0.18.0
PKGREVISION= 4
DISTNAME= qlandkartegt-1.0.0
CATEGORIES= geography
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=qlandkartegt/}
@ -13,16 +12,17 @@ LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir
WRKSRC= ${WRKDIR}/qlandkartegt-0.18.0
USE_LANGUAGES= c c++
USE_CMAKE= yes
DEPENDS+= qlandkartegt-garmindev>=0.3:../../geography/qlandkartegt-garmindev
.include "../../devel/cmake/buildlink3.mk"
.include "../../geography/gpsd/buildlink3.mk"
.include "../../geography/gdal-lib/buildlink3.mk"
.include "../../geography/proj/buildlink3.mk"
.include "../../graphics/libexif/buildlink3.mk"
.include "../../x11/qt4-libs/buildlink3.mk"
.include "../../x11/qt4-tools/buildlink3.mk"
.include "../../x11/qt4-qdbus/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2010/03/19 21:58:04 jkunz Exp $
@comment $NetBSD: PLIST,v 1.4 2011/01/13 22:55:20 jkunz Exp $
bin/qlandkartegt
share/qlandkartegt/translations/qlandkartegt_de_DE.qm
share/qlandkartegt/translations/qlandkartegt_es_ES.qm
@ -7,5 +7,5 @@ share/qlandkartegt/translations/qlandkartegt_it_IT.qm
share/qlandkartegt/translations/qlandkartegt_nl_NL.qm
share/qlandkartegt/translations/qlandkartegt_ru_RU.qm
share/applications/qlandkartegt.desktop
share/man/man1/qlandkartegt.1
man/man1/qlandkartegt.1
share/pixmaps/qlandkartegt.png

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.2 2010/03/08 22:00:01 jkunz Exp $
$NetBSD: distinfo,v 1.3 2011/01/13 22:55:20 jkunz Exp $
SHA1 (qlandkartegt-0.18.0.tar.gz) = d370b25961a9241d960f1a8660f75c39415774fc
RMD160 (qlandkartegt-0.18.0.tar.gz) = 87fbd2a9a426e3db1a69ac4480790b282eb9018d
Size (qlandkartegt-0.18.0.tar.gz) = 3643310 bytes
SHA1 (qlandkartegt-1.0.0.tar.gz) = 1152383dcec41b3f698897bc4cd1f8cf0b5cbfe9
RMD160 (qlandkartegt-1.0.0.tar.gz) = 373924997ca707007daa024e394c8e033df42f9e
Size (qlandkartegt-1.0.0.tar.gz) = 3799397 bytes
SHA1 (patch-aa) = 961ede37ca9ec3bd4e1e7ea061aff38c127ca4e9

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1 2011/01/13 22:55:20 jkunz Exp $
--- cmake/Modules/DefineInstallationPaths.cmake.orig 2010-12-27 12:52:18.000000000 +0000
+++ cmake/Modules/DefineInstallationPaths.cmake
@@ -101,7 +101,7 @@ if (UNIX)
FORCE
)
SET(MAN_INSTALL_DIR
- "${SHARE_INSTALL_PREFIX}/man"
+ "${CMAKE_INSTALL_PREFIX}/man"
CACHE PATH "The ${_APPLICATION_NAME} man install dir (default prefix/man)"
FORCE
)