Use _NSGetEnviron() instead of environ on Darwin. Should fix PR
pkg/31913. Reported in GNOME Bugzilla #330350.
This commit is contained in:
parent
670aeeb7ed
commit
4cd43b7a19
2 changed files with 21 additions and 1 deletions
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.17 2006/02/07 21:31:04 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.18 2006/02/08 05:47:48 minskim Exp $
|
||||
|
||||
SHA1 (libgnomeui-2.12.1.tar.bz2) = e542ed58909d9a9e9b6c08e4c1fc016e996ffa73
|
||||
RMD160 (libgnomeui-2.12.1.tar.bz2) = be9feadd71d2e1d9be1dee1b6fbb661ca222c160
|
||||
Size (libgnomeui-2.12.1.tar.bz2) = 1852044 bytes
|
||||
SHA1 (patch-aa) = 5dd82f0e510d0035b55da63b1e200d0c38fa0b5a
|
||||
|
|
19
devel/libgnomeui/patches/patch-aa
Normal file
19
devel/libgnomeui/patches/patch-aa
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-aa,v 1.5 2006/02/08 05:47:48 minskim Exp $
|
||||
|
||||
May be removed when GNOME Bugzilla #330350 is resolved.
|
||||
|
||||
--- file-chooser/sucky-desktop-item.c.orig 2005-07-11 13:04:12.000000000 -0700
|
||||
+++ file-chooser/sucky-desktop-item.c
|
||||
@@ -67,7 +67,12 @@
|
||||
|
||||
#define sure_string(s) ((s)!=NULL?(s):"")
|
||||
|
||||
+#if defined(__APPLE__) && defined(HAVE_NSGETENVIRON) && defined(HAVE_CRT_EXTERNS_H)
|
||||
+ #include <crt_externs.h>
|
||||
+ #define environ (*_NSGetEnviron())
|
||||
+#else
|
||||
extern char **environ;
|
||||
+#endif
|
||||
|
||||
struct _SuckyDesktopItem {
|
||||
int refcount;
|
Loading…
Reference in a new issue