- allow firefox and xulrunner to share some infrastructure

- install headers for plugin and liveconnect (needed by openjdk7-icedtea-plugin)
- bump revision for both packages
This commit is contained in:
tnn 2009-10-11 10:49:56 +00:00
parent b682c86f96
commit 4d1ae4854f
16 changed files with 139 additions and 315 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.23 2009/09/27 17:52:22 tnn Exp $
# $NetBSD: Makefile,v 1.24 2009/10/11 10:49:56 tnn Exp $
#
DISTNAME= firefox-${FIREFOX_VER}.source
PKGNAME= ${DISTNAME:S/firefox/xulrunner/:S/3.5/1.9.1/:S/.source//}
FIREFOX_VER= 3.5.3
PKGREVISION= 5
PKGREVISION= 6
CATEGORIES= devel www
MASTER_SITES= ${MASTER_SITE_MOZILLA:=firefox/releases/${FIREFOX_VER}/source/}
EXTRACT_SUFX= .tar.bz2
@ -14,14 +14,7 @@ HOMEPAGE= http://developer.mozilla.org/en/docs/XULRunner
COMMENT= XML User Interface Language runtime environment
WRKSRC= ${WRKDIR}/mozilla-1.9.1
GNU_CONFIGURE= yes
USE_TOOLS+= pkg-config perl gmake autoconf213
USE_LANGUAGES= c c++
BUILD_DEPENDS+= zip>=2.3:../../archivers/zip
PKG_DESTDIR_SUPPORT= user-destdir
CHECK_PORTABILITY_SKIP= security/nss/tests/libpkix/libpkix.sh
MOZILLA_DIR= # empty
PKGCONFIG_OVERRIDE+= xulrunner/installer/libxul-embedding-unstable.pc.in
PKGCONFIG_OVERRIDE+= xulrunner/installer/libxul-embedding.pc.in
@ -34,62 +27,20 @@ PKGCONFIG_OVERRIDE+= xulrunner/installer/mozilla-nspr.pc.in
PKGCONFIG_OVERRIDE+= xulrunner/installer/mozilla-nss.pc.in
PKGCONFIG_OVERRIDE+= xulrunner/installer/mozilla-plugin.pc.in
PRIVILEGED_STAGES= clean
CONFIG_GUESS_OVERRIDE= build/autoconf/config.guess
CONFIG_GUESS_OVERRIDE+= js/src/build/autoconf/config.guess
CONFIG_GUESS_OVERRIDE+= nsprpub/build/autoconf/config.guess
CONFIG_SUB_OVERRIDE= build/autoconf/config.sub
CONFIG_SUB_OVERRIDE+= js/src/build/autoconf/config.sub
CONFIG_SUB_OVERRIDE+= nsprpub/build/autoconf/config.sub
CONFIGURE_ARGS+= --enable-application=xulrunner
CONFIGURE_ARGS+= --enable-libxul
CONFIGURE_ARGS+= --disable-tests --disable-pedantic
CONFIGURE_ARGS+= --enable-crypto
CONFIGURE_ARGS+= --enable-optimize=-O2 --with-pthreads
CONFIGURE_ARGS+= --disable-javaxpcom
CONFIGURE_ARGS+= --enable-default-toolkit=cairo-gtk2
CONFIGURE_ARGS+= --enable-svg --enable-mathml
CONFIGURE_ARGS+= --enable-system-cairo
CONFIGURE_ARGS+= --with-system-jpeg
CONFIGURE_ARGS+= --with-system-zlib --with-system-bz2
CONFIGURE_ARGS+= --enable-system-sqlite
CONFIGURE_ARGS+= --disable-crashreporter
ALL_ENV+= MOZILLA_PKG_NAME=xulrunner
SUBST_CLASSES+= fix-paths
SUBST_STAGE.fix-paths= pre-configure
SUBST_MESSAGE.fix-paths= Fixing absolute paths.
SUBST_FILES.fix-paths= xpcom/build/nsXPCOMPrivate.h
SUBST_FILES.fix-paths+= xulrunner/app/nsRegisterGREUnix.cpp
SUBST_FILES.fix-paths+= xulrunner/installer/Makefile.in
SUBST_FILES.fix-paths+= extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java
SUBST_FILES.fix-paths+= xpcom/io/nsAppFileLocationProvider.cpp
SUBST_SED.fix-paths= -e 's,/etc/gre.d,${PREFIX}/lib/xulrunner/gre.d,g'
SUBST_SED.fix-paths+= -e 's,/usr/lib/mozilla/plugins,${PREFIX}/lib/netscape/plugins,g'
PYTHON_FOR_BUILD_ONLY= yes
.include "../../lang/python/application.mk"
CONFIGURE_ENV+= PYTHON=${PYTHONBIN:Q}
.include "options.mk"
.include "../../mk/bsd.prefs.mk"
.include "mozilla-common.mk"
.include "options.mk"
pre-configure:
cd ${WRKSRC} && autoconf
cd ${WRKSRC}/js/src && autoconf
cd ${WRKSRC}/nsprpub && autoconf
# Makefiles sometimes call "rm -f" without more arguments. Kludge around ...
.PHONY: create-rm-wrapper
pre-configure: create-rm-wrapper
create-rm-wrapper:
printf '#!/bin/sh\n[ "$$*" = "-f" ] && exit 0\nexec /bin/rm $$@\n' > \
${WRAPPER_DIR}/bin/rm
chmod +x ${WRAPPER_DIR}/bin/rm
INCLUDE_SUBDIRS=\
caps chardet commandhandler content cookie docshell dom \
downloads embedcomponents exthandler fastfind find gfx \
@ -97,34 +48,29 @@ INCLUDE_SUBDIRS=\
locale loginmgr mimetype necko nkcache nspr oji pipboot pipnss \
places pref profdirserviceprovider rdf shistory spellchecker \
string thebes toolkitcomps uconv uriloader webbrowserpersist \
webbrwsr webshell widget windowwatcher xpcom xpconnect xulapp
webbrwsr webshell widget windowwatcher xpcom xpconnect xulapp \
plugin liveconnect
post-install:
# XXX fix the pkg-config files instead
rm -f ${DESTDIR}${PREFIX}/lib/xulrunner/libxpcomglue.a
ln -s ${PREFIX}/lib/xulrunner-sdk/sdk/lib/libxpcomglue.a \
ln -s ${PREFIX}/lib/xulrunner-sdk/sdk/lib/libxpcomglue.a \
${DESTDIR}${PREFIX}/lib/xulrunner/libxpcomglue.a
rm -f ${DESTDIR}${PREFIX}/lib/xulrunner/libxpcomglue_s.a
ln -s ${PREFIX}/lib/xulrunner-sdk/sdk/lib/libxpcomglue_s.a \
ln -s ${PREFIX}/lib/xulrunner-sdk/sdk/lib/libxpcomglue_s.a \
${DESTDIR}${PREFIX}/lib/xulrunner/libxpcomglue_s.a
${INSTALL_LIB} ${WRKSRC}/dist/lib/libunicharutil_external_s.a \
${INSTALL_LIB} ${WRKSRC}/dist/lib/libunicharutil_external_s.a \
${DESTDIR}${PREFIX}/lib/xulrunner
cd ${WRKSRC}/dist/include && \
${INSTALL_DATA} `find ${INCLUDE_SUBDIRS} -name "*.h" -print` \
.for dir in ${INCLUDE_SUBDIRS}
cd ${WRKSRC}/dist/include && \
${INSTALL_DATA} `find ${dir} -name "*.h" -print` \
${DESTDIR}${PREFIX}/include/xulrunner/unstable
.endfor
cd ${WRKSRC}/dist/include && ${INSTALL_DATA} \
js/jsproto.tbl mozilla-config.h gtkembedmoz/gtkmozembed_glue.cpp \
${DESTDIR}${PREFIX}/include/xulrunner/unstable
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/include/xulrunner/unstable/obsolete
cd ${WRKSRC}/dist/include/nspr/obsolete && ${INSTALL_DATA} protypes.h \
${DESTDIR}${PREFIX}/include/xulrunner/unstable/obsolete
.if ${OPSYS} == "Linux"
.include "../../audio/alsa-lib/buildlink3.mk"
.endif
.include "../../archivers/bzip2/buildlink3.mk"
BUILDLINK_API_DEPENDS.sqlite3+= sqlite3>=3.6.10
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../net/libIDL/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.16 2009/10/06 15:46:32 tnn Exp $
@comment $NetBSD: PLIST,v 1.17 2009/10/11 10:49:56 tnn Exp $
bin/xulrunner
include/xulrunner/stable/base64.h
include/xulrunner/stable/blapit.h
@ -572,6 +572,7 @@ include/xulrunner/unstable/jsgc.h
include/xulrunner/unstable/jshash.h
include/xulrunner/unstable/jsinterp.h
include/xulrunner/unstable/jsiter.h
include/xulrunner/unstable/jsjava.h
include/xulrunner/unstable/jslock.h
include/xulrunner/unstable/jslong.h
include/xulrunner/unstable/jsmath.h
@ -619,6 +620,12 @@ include/xulrunner/unstable/mozilla-config.h
${PLIST.jit}include/xulrunner/unstable/nanojit.h
include/xulrunner/unstable/necko-config.h
include/xulrunner/unstable/netCore.h
include/xulrunner/unstable/netscape_javascript_JSException.h
include/xulrunner/unstable/netscape_javascript_JSObject.h
include/xulrunner/unstable/npapi.h
include/xulrunner/unstable/npfunctions.h
include/xulrunner/unstable/npruntime.h
include/xulrunner/unstable/nptypes.h
include/xulrunner/unstable/nsASocketHandler.h
include/xulrunner/unstable/nsAString.h
include/xulrunner/unstable/nsAXPCNativeCallContext.h
@ -717,6 +724,7 @@ include/xulrunner/unstable/nsDataHashtable.h
include/xulrunner/unstable/nsDateTimeFormatCID.h
include/xulrunner/unstable/nsDebug.h
include/xulrunner/unstable/nsDebugImpl.h
include/xulrunner/unstable/nsDefaultPlugin.h
include/xulrunner/unstable/nsDependentString.h
include/xulrunner/unstable/nsDependentSubstring.h
include/xulrunner/unstable/nsDeque.h
@ -872,6 +880,7 @@ include/xulrunner/unstable/nsIChromeRegistry.h
include/xulrunner/unstable/nsICipherInfo.h
include/xulrunner/unstable/nsIClassInfo.h
include/xulrunner/unstable/nsIClassInfoImpl.h
include/xulrunner/unstable/nsIClassicPluginFactory.h
include/xulrunner/unstable/nsIClientAuthDialogs.h
include/xulrunner/unstable/nsIClipboard.h
include/xulrunner/unstable/nsIClipboardCommands.h
@ -924,6 +933,7 @@ include/xulrunner/unstable/nsICookieManager2.h
include/xulrunner/unstable/nsICookiePermission.h
include/xulrunner/unstable/nsICookiePromptService.h
include/xulrunner/unstable/nsICookieService.h
include/xulrunner/unstable/nsICookieStorage.h
include/xulrunner/unstable/nsICryptoFIPSInfo.h
include/xulrunner/unstable/nsICryptoHMAC.h
include/xulrunner/unstable/nsICryptoHash.h
@ -1345,6 +1355,7 @@ include/xulrunner/unstable/nsIEntropyCollector.h
include/xulrunner/unstable/nsIEnumerator.h
include/xulrunner/unstable/nsIEnvironment.h
include/xulrunner/unstable/nsIErrorService.h
include/xulrunner/unstable/nsIEventHandler.h
include/xulrunner/unstable/nsIEventListener.h
include/xulrunner/unstable/nsIEventListenerManager.h
include/xulrunner/unstable/nsIEventStateManager.h
@ -1369,6 +1380,7 @@ include/xulrunner/unstable/nsIFilePicker.h
include/xulrunner/unstable/nsIFileProtocolHandler.h
include/xulrunner/unstable/nsIFileStreams.h
include/xulrunner/unstable/nsIFileURL.h
include/xulrunner/unstable/nsIFileUtilities.h
include/xulrunner/unstable/nsIFind.h
include/xulrunner/unstable/nsIFocusController.h
include/xulrunner/unstable/nsIFocusEventSuppressor.h
@ -1405,6 +1417,7 @@ include/xulrunner/unstable/nsIHTMLCollection.h
include/xulrunner/unstable/nsIHTMLContentSink.h
include/xulrunner/unstable/nsIHTMLDocument.h
include/xulrunner/unstable/nsIHTMLToTextSink.h
include/xulrunner/unstable/nsIHTTPHeaderListener.h
include/xulrunner/unstable/nsIHandlerService.h
include/xulrunner/unstable/nsIHashable.h
include/xulrunner/unstable/nsIHelperAppLauncherDialog.h
@ -1441,12 +1454,15 @@ include/xulrunner/unstable/nsIInterfaceInfo.h
include/xulrunner/unstable/nsIInterfaceInfoManager.h
include/xulrunner/unstable/nsIInterfaceRequestor.h
include/xulrunner/unstable/nsIInterfaceRequestorUtils.h
include/xulrunner/unstable/nsIJRILiveConnectPIPeer.h
include/xulrunner/unstable/nsIJRILiveConnectPlugin.h
include/xulrunner/unstable/nsIJRIPlugin.h
include/xulrunner/unstable/nsIJSContextStack.h
include/xulrunner/unstable/nsIJSEventListener.h
include/xulrunner/unstable/nsIJSNativeInitializer.h
include/xulrunner/unstable/nsIJSON.h
include/xulrunner/unstable/nsIJSRuntimeService.h
include/xulrunner/unstable/nsIJVMAuthTools.h
include/xulrunner/unstable/nsIJVMConfigManager.h
include/xulrunner/unstable/nsIJVMConsole.h
include/xulrunner/unstable/nsIJVMManager.h
@ -1468,6 +1484,7 @@ include/xulrunner/unstable/nsILinkHandler.h
include/xulrunner/unstable/nsIListBoxObject.h
include/xulrunner/unstable/nsIListControlFrame.h
include/xulrunner/unstable/nsILiveConnectManager.h
include/xulrunner/unstable/nsILiveconnect.h
include/xulrunner/unstable/nsILivemarkService.h
include/xulrunner/unstable/nsILoadContext.h
include/xulrunner/unstable/nsILoadGroup.h
@ -1550,6 +1567,22 @@ include/xulrunner/unstable/nsIPersistentProperties2.h
include/xulrunner/unstable/nsIPhonetic.h
include/xulrunner/unstable/nsIPipe.h
include/xulrunner/unstable/nsIPlatformCharset.h
include/xulrunner/unstable/nsIPlugin.h
include/xulrunner/unstable/nsIPluginDocument.h
include/xulrunner/unstable/nsIPluginHost.h
include/xulrunner/unstable/nsIPluginInputStream.h
include/xulrunner/unstable/nsIPluginInstance.h
include/xulrunner/unstable/nsIPluginInstanceInternal.h
include/xulrunner/unstable/nsIPluginInstanceOwner.h
include/xulrunner/unstable/nsIPluginInstancePeer.h
include/xulrunner/unstable/nsIPluginInstancePeer2.h
include/xulrunner/unstable/nsIPluginManager.h
include/xulrunner/unstable/nsIPluginManager2.h
include/xulrunner/unstable/nsIPluginStreamInfo.h
include/xulrunner/unstable/nsIPluginStreamListener.h
include/xulrunner/unstable/nsIPluginTag.h
include/xulrunner/unstable/nsIPluginTagInfo.h
include/xulrunner/unstable/nsIPluginTagInfo2.h
include/xulrunner/unstable/nsIPluginWidget.h
include/xulrunner/unstable/nsIPopupBoxObject.h
include/xulrunner/unstable/nsIPosixLocale.h
@ -1681,6 +1714,7 @@ include/xulrunner/unstable/nsIScriptTimeoutHandler.h
include/xulrunner/unstable/nsIScriptableDateFormat.h
include/xulrunner/unstable/nsIScriptableInputStream.h
include/xulrunner/unstable/nsIScriptableInterfaces.h
include/xulrunner/unstable/nsIScriptablePlugin.h
include/xulrunner/unstable/nsIScriptableRegion.h
include/xulrunner/unstable/nsIScriptableUConv.h
include/xulrunner/unstable/nsIScrollBoxObject.h
@ -1691,7 +1725,9 @@ include/xulrunner/unstable/nsIScrollbarMediator.h
include/xulrunner/unstable/nsISecretDecoderRing.h
include/xulrunner/unstable/nsISecureBrowserUI.h
include/xulrunner/unstable/nsISecureEnv.h
include/xulrunner/unstable/nsISecureLiveconnect.h
include/xulrunner/unstable/nsISecurityCheckedComponent.h
include/xulrunner/unstable/nsISecurityContext.h
include/xulrunner/unstable/nsISecurityEventSink.h
include/xulrunner/unstable/nsISecurityInfoProvider.h
include/xulrunner/unstable/nsISecurityPref.h
@ -1837,6 +1873,7 @@ include/xulrunner/unstable/nsIWebShellServices.h
include/xulrunner/unstable/nsIWidget.h
include/xulrunner/unstable/nsIWin32Locale.h
include/xulrunner/unstable/nsIWindowWatcher.h
include/xulrunner/unstable/nsIWindowlessPlugInstPeer.h
include/xulrunner/unstable/nsIWritablePropertyBag.h
include/xulrunner/unstable/nsIWritablePropertyBag2.h
include/xulrunner/unstable/nsIWyciwygChannel.h
@ -1920,6 +1957,8 @@ include/xulrunner/unstable/nsPIDOMEventTarget.h
include/xulrunner/unstable/nsPIDOMStorage.h
include/xulrunner/unstable/nsPIDOMWindow.h
include/xulrunner/unstable/nsPIPlacesDatabase.h
include/xulrunner/unstable/nsPIPluginHost.h
include/xulrunner/unstable/nsPIPluginInstancePeer.h
include/xulrunner/unstable/nsPIPromptService.h
include/xulrunner/unstable/nsPISocketTransportService.h
include/xulrunner/unstable/nsPIWindowRoot.h
@ -1929,6 +1968,10 @@ include/xulrunner/unstable/nsPSPrinters.h
include/xulrunner/unstable/nsPaperPS.h
include/xulrunner/unstable/nsParserCIID.h
include/xulrunner/unstable/nsParserDataListener.h
include/xulrunner/unstable/nsPluginError.h
include/xulrunner/unstable/nsPluginLogging.h
include/xulrunner/unstable/nsPluginNativeWindow.h
include/xulrunner/unstable/nsPluginsCID.h
include/xulrunner/unstable/nsPoint.h
include/xulrunner/unstable/nsPrefsCID.h
include/xulrunner/unstable/nsPresContext.h
@ -2053,6 +2096,9 @@ include/xulrunner/unstable/nsXULAppAPI.h
include/xulrunner/unstable/nsXULPopupManager.h
include/xulrunner/unstable/nscore.h
include/xulrunner/unstable/nsjvm.h
include/xulrunner/unstable/nsplugin.h
include/xulrunner/unstable/nsplugindefs.h
include/xulrunner/unstable/nspluginroot.h
include/xulrunner/unstable/nspr.h
include/xulrunner/unstable/nspr_md.h
include/xulrunner/unstable/nsrootidl.h

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.12 2009/09/27 17:52:22 tnn Exp $
$NetBSD: distinfo,v 1.13 2009/10/11 10:49:56 tnn Exp $
SHA1 (firefox-3.5.3.source.tar.bz2) = 83b2625eb74e81b473ac40ac52505e5fc9a497eb
RMD160 (firefox-3.5.3.source.tar.bz2) = c2487c90b4a9490840817c7b00dcccd68a0c4422
Size (firefox-3.5.3.source.tar.bz2) = 46766383 bytes
SHA1 (patch-aa) = 3bcbced4642b8814f5255973d45a0ac1eaded64d
SHA1 (patch-aa) = 1a103647b3ce602e1bf2d22f6486a6649a68878b
SHA1 (patch-ab) = 5331bae45501013d3ca13d161226e311bc10aafe
SHA1 (patch-ac) = e50356963fd235ea11fa45baae356fcf21c6669d
SHA1 (patch-ad) = 7afb960af4e4a311481e7a7b25008ca9b9f7fba1
@ -27,6 +27,7 @@ SHA1 (patch-au) = f27b6c8b2c744da388e1d15d0776929e7165ee76
SHA1 (patch-av) = e22c544894123a6ab8fc428067716b9e68685771
SHA1 (patch-aw) = eed2f98b732fa776d2ca64d2b82e88677a207657
SHA1 (patch-ax) = 579041ecba36dfa0d42d3ab576e79ecf2321749d
SHA1 (patch-ay) = 6ddcbbd3f0197fb88622fc32d6d0fd602ec4ad34
SHA1 (patch-ma) = a20b263ff14c841fd0ae1634962b90a41173b524
SHA1 (patch-mb) = 05298c1ec02363ff0bada87337cf0ccb5b42c55b
SHA1 (patch-md) = 6bf5242245b17fbd868a6a978eb5849726f81393
@ -51,6 +52,9 @@ SHA1 (patch-pd) = b87adef8cfb53d4a1926f4bab5481dd1b9cf14ab
SHA1 (patch-pe) = 3e4db1032a1e1f26f3a4e86653804b435aaf3ee8
SHA1 (patch-pf) = 95b3f07dfd0e3de9961181ec6e42f7174180942d
SHA1 (patch-pg) = 33f0664512c94b1f1b7b65f43accc1dae457a2d0
SHA1 (patch-ra) = b215219b8429274ca3aa81790b62531aaf189127
SHA1 (patch-rb) = 15970b5fe79621d47e573ddec074a6e67e8c5146
SHA1 (patch-rc) = 890012b4fca22d965a40262830aabbb06a2da36e
SHA1 (patch-xa) = ae5ed1f0fb9a0fd45242a94739853b199ed7da72
SHA1 (patch-xb) = c09bd676d21bef02e04c68c2362e32f408ea9201
SHA1 (patch-xc) = 6e1d6b21d7ded744b082173ea6f35b45999fa965

View file

@ -1,6 +1,6 @@
$NetBSD: patch-aa,v 1.1.1.1 2009/08/05 02:59:48 tnn Exp $
$NetBSD: patch-aa,v 1.2 2009/10/11 10:49:56 tnn Exp $
--- configure.in.orig 2009-06-29 18:14:41.000000000 +0200
--- configure.in.orig 2009-08-24 17:52:36.000000000 +0200
+++ configure.in
@@ -1799,7 +1799,7 @@ case "$target" in
fi
@ -47,10 +47,26 @@ $NetBSD: patch-aa,v 1.1.1.1 2009/08/05 02:59:48 tnn Exp $
*)
AC_CHECK_LIB(c_r, gethostbyname_r)
;;
@@ -8468,6 +8481,7 @@ if test -z "$MOZ_NATIVE_NSPR"; then
@@ -4160,6 +4173,14 @@ else
fi
fi
+if test -n "${LIBXUL_SDK_DIR}"; then
+ AC_MSG_WARN([pkgsrc: LIBXUL_SDK_DIR is set; assuming we want nss and nspr from xulrunner.])
+ NSPR_CFLAGS="-I${prefix}/include/xulrunner/unstable `pkg-config --cflags mozilla-nspr`"
+ NSPR_LIBS="`pkg-config --libs mozilla-nspr`"
+ NSS_CFLAGS="`pkg-config --cflags mozilla-nss`"
+ NSS_LIBS="`pkg-config --libs mozilla-nss`"
+fi
+
if test -z "$SKIP_LIBRARY_CHECKS"; then
dnl system JPEG support
dnl ========================================================
@@ -8468,6 +8489,8 @@ if test -z "$MOZ_NATIVE_NSPR"; then
AC_MSG_WARN([Recreating autoconf.mk with updated nspr-config output])
if test "$OS_ARCH" != "WINNT" && test "$OS_ARCH" != "WINCE"; then
NSPR_LIBS=`./nsprpub/config/nspr-config --prefix=$LIBXUL_DIST --exec-prefix=$MOZ_BUILD_ROOT/dist --libdir=$LIBXUL_DIST/lib --libs`
+ AC_MSG_WARN([pkgsrc: adding run path to NSPR_LIBS for bundled NSPR.])
+ NSPR_LIBS="-Wl,-R${prefix}/lib/\${MOZILLA_PKG_NAME} ${NSPR_LIBS}"
$PERL -pi.bak -e "s '^NSPR_LIBS\\s*=.*'NSPR_LIBS = $NSPR_LIBS'" config/autoconf.mk
NSPR_CFLAGS=`./nsprpub/config/nspr-config --prefix=$LIBXUL_DIST --exec-prefix=$MOZ_BUILD_ROOT/dist --includedir=$LIBXUL_DIST/include/nspr --cflags`

View file

@ -0,0 +1,40 @@
$NetBSD: patch-ay,v 1.1 2009/10/11 10:49:56 tnn Exp $
--- browser/app/nsBrowserApp.cpp.orig 2009-06-29 18:14:40.000000000 +0200
+++ browser/app/nsBrowserApp.cpp
@@ -44,6 +44,27 @@
#include <stdio.h>
#include <stdarg.h>
+#include <sys/resource.h>
+/*
+ * On netbsd-4, ulimit -n is 64 by default; too few for us.
+ */
+static void netbsd_fixrlimit(void) {
+ struct rlimit rlp;
+ if (getrlimit(RLIMIT_NOFILE, &rlp) == -1) {
+ fprintf(stderr, "warning: getrlimit failed\n");
+ return;
+ }
+ if (rlp.rlim_cur >= 512)
+ return;
+ if (rlp.rlim_max < 512) {
+ fprintf(stderr, "warning: hard limit of 'ulimit -n' too low\n");
+ rlp.rlim_cur = rlp.rlim_max;
+ }
+ else
+ rlp.rlim_cur = 512;
+ if (setrlimit(RLIMIT_NOFILE, &rlp) == -1)
+ fprintf(stderr, "warning: setrlimit failed\n");
+}
#include "plstr.h"
#include "prprf.h"
@@ -106,6 +127,7 @@ public:
int main(int argc, char* argv[])
{
+ netbsd_fixrlimit();
ScopedLogging log;
nsCOMPtr<nsILocalFile> appini;

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ra,v 1.1 2009/09/23 16:46:32 tnn Exp $
$NetBSD: patch-ra,v 1.1 2009/10/11 10:49:56 tnn Exp $
--- browser/branding/unofficial/locales/browserconfig.properties.orig 2009-08-24 17:52:36.000000000 +0200
+++ browser/branding/unofficial/locales/browserconfig.properties

View file

@ -1,4 +1,4 @@
$NetBSD: patch-rb,v 1.1 2009/09/23 16:46:32 tnn Exp $
$NetBSD: patch-rb,v 1.1 2009/10/11 10:49:56 tnn Exp $
--- browser/branding/unofficial/configure.sh.orig 2009-08-24 17:52:35.000000000 +0200
+++ browser/branding/unofficial/configure.sh

View file

@ -1,4 +1,4 @@
$NetBSD: patch-rc,v 1.1 2009/09/23 16:46:32 tnn Exp $
$NetBSD: patch-rc,v 1.1 2009/10/11 10:49:56 tnn Exp $
--- browser/branding/unofficial/locales/en-US/brand.dtd.orig 2009-08-24 17:52:36.000000000 +0200
+++ browser/branding/unofficial/locales/en-US/brand.dtd

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.59 2009/10/09 19:41:46 tnn Exp $
# $NetBSD: Makefile,v 1.60 2009/10/11 10:49:56 tnn Exp $
#
DISTNAME= firefox-${FIREFOX_VER}.source
PKGNAME= firefox-${FIREFOX_VER}
FIREFOX_VER= 3.5.3
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA:=firefox/releases/${FIREFOX_VER}/source/}
EXTRACT_SUFX= .tar.bz2
@ -14,42 +14,20 @@ HOMEPAGE= http://www.mozilla.com/en-US/firefox/
COMMENT= Web browser with support for extensions
WRKSRC= ${WRKDIR}/mozilla-1.9.1
GNU_CONFIGURE= yes
USE_TOOLS+= pkg-config perl gmake autoconf213
USE_LANGUAGES= c c++
BUILD_DEPENDS+= zip>=2.3:../../archivers/zip
PKG_DESTDIR_SUPPORT= user-destdir
CHECK_PORTABILITY_SKIP= security/nss/tests/libpkix/libpkix.sh
PRIVILEGED_STAGES= clean
CONFIG_GUESS_OVERRIDE= build/autoconf/config.guess
CONFIG_SUB_OVERRIDE= build/autoconf/config.sub
MOZILLA_DIR= # empty
CONFIGURE_ARGS+= --enable-application=browser
CONFIGURE_ARGS+= --disable-tests --disable-pedantic
CONFIGURE_ARGS+= --enable-crypto
CONFIGURE_ARGS+= --enable-optimize=-O2 --with-pthreads
CONFIGURE_ARGS+= --disable-javaxpcom
CONFIGURE_ARGS+= --enable-default-toolkit=cairo-gtk2
CONFIGURE_ARGS+= --enable-svg --enable-mathml
CONFIGURE_ARGS+= --enable-system-cairo
CONFIGURE_ARGS+= --with-system-jpeg
CONFIGURE_ARGS+= --with-system-zlib --with-system-bz2
CONFIGURE_ARGS+= --enable-system-sqlite
CONFIGURE_ARGS+= --disable-crashreporter
CONFIGURE_ARGS+= --with-libxul-sdk=${PREFIX}/lib/xulrunner-sdk
CONFIGURE_ARGS+= --with-system-libxul
ALL_ENV+= MOZILLA_PKG_NAME=firefox
PYTHON_FOR_BUILD_ONLY= yes
.include "../../lang/python/application.mk"
CONFIGURE_ENV+= PYTHON=${PYTHONBIN:Q}
DISTINFO_FILE= ${.CURDIR}/../../devel/xulrunner/distinfo
PATCHDIR= ${.CURDIR}/../../devel/xulrunner/patches
.include "options.mk"
.include "../../mk/bsd.prefs.mk"
.include "../../devel/xulrunner/mozilla-common.mk"
.include "options.mk"
MOZILLA=firefox
.if !empty(PKG_OPTIONS:Mofficial-mozilla-branding)
@ -62,10 +40,6 @@ MOZILLA_ICON= ${WRKSRC}/browser/branding/unofficial/default48.png
pre-configure:
cd ${WRKSRC} && autoconf
# Makefiles sometimes call "rm -f" without more arguments. Kludge around ...
printf '#!/bin/sh\n[ "$$*" = "-f" ] && exit 0\nexec /bin/rm $$@\n' > \
${WRAPPER_DIR}/bin/rm
chmod +x ${WRAPPER_DIR}/bin/rm
post-install:
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/applications
@ -84,12 +58,6 @@ post-install:
> ${WRKDIR}/firefox
${INSTALL_SCRIPT} ${WRKDIR}/firefox ${DESTDIR}${PREFIX}/bin
.if ${OPSYS} == "Linux"
# XXX check if this still applies after xulrunnerization
.include "../../audio/alsa-lib/buildlink3.mk"
.endif
.include "../../archivers/bzip2/buildlink3.mk"
.include "../../databases/sqlite3/buildlink3.mk"
BUILDLINK_API_DEPENDS.xulrunner+= xulrunner>=1.9.1.3nb4
.include "../../devel/xulrunner/buildlink3.mk"
PLIST_VARS+= gnome
@ -99,9 +67,5 @@ PLIST.gnome= yes
.else
CONFIGURE_ARGS+= --disable-gnomevfs --disable-dbus --disable-gnomeui
.endif
.include "../../devel/zlib/buildlink3.mk"
.include "../../net/libIDL/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,14 +0,0 @@
$NetBSD: distinfo,v 1.98 2009/09/23 16:46:31 tnn Exp $
SHA1 (firefox-3.5.3.source.tar.bz2) = 83b2625eb74e81b473ac40ac52505e5fc9a497eb
RMD160 (firefox-3.5.3.source.tar.bz2) = c2487c90b4a9490840817c7b00dcccd68a0c4422
Size (firefox-3.5.3.source.tar.bz2) = 46766383 bytes
SHA1 (patch-aa) = 64ebd1d94d69acdbf6d5a0c25fc3015d90d5540c
SHA1 (patch-ao) = af027520b0277838a5a5f4ad33e14174e6e8bc0c
SHA1 (patch-ma) = a20b263ff14c841fd0ae1634962b90a41173b524
SHA1 (patch-mi) = 787cb043bb7e687936afaf8f0c67b6b3a7b03e5b
SHA1 (patch-mk) = 793dfa16e19e213d78995c893a28bc0d514135d9
SHA1 (patch-mm) = faabab8816522bd9a74c2e6e65b2ae3d791affe0
SHA1 (patch-ra) = b215219b8429274ca3aa81790b62531aaf189127
SHA1 (patch-rb) = 15970b5fe79621d47e573ddec074a6e67e8c5146
SHA1 (patch-rc) = 890012b4fca22d965a40262830aabbb06a2da36e

View file

@ -1,78 +0,0 @@
$NetBSD: patch-aa,v 1.8 2009/09/17 09:41:50 tnn Exp $
--- configure.in.orig 2009-08-24 17:52:36.000000000 +0200
+++ configure.in
@@ -1799,7 +1799,7 @@ case "$target" in
fi
;;
-*-freebsd*)
+*-freebsd* | *-dragonfly*)
if test `test -x /usr/bin/objformat && /usr/bin/objformat || echo elf` != "elf"; then
DLL_SUFFIX=".so.1.0"
DSO_LDOPTS="-shared"
@@ -1813,6 +1813,9 @@ case "$target" in
# MKSHLIB_FORCE_ALL='-Wl,-Bforcearchive'
# MKSHLIB_UNFORCE_ALL=''
# fi
+ if test "$LIBRUNPATH"; then
+ DSO_LDOPTS="-Wl,-R$LIBRUNPATH $DSO_LDOPTS"
+ fi
;;
*-hpux*)
@@ -2349,8 +2352,15 @@ case "$target" in
if test "$LIBRUNPATH"; then
DSO_LDOPTS="-R$LIBRUNPATH $DSO_LDOPTS"
fi
+ case "${target_cpu}" in
+ alpha*)
+ CFLAGS="$CFLAGS -mieee"
+ CXXFLAGS="$CXXFLAGS -mieee"
+ ;;
+ esac
;;
+
*-openvms*)
AC_DEFINE(NO_PW_GECOS)
AC_DEFINE(NO_UDSOCK)
@@ -3043,6 +3053,9 @@ dnl ====================================
case $target in
*-hpux11.*)
;;
+*-dragonfly*)
+ AC_CHECK_LIB(c, gethostbyname_r)
+ ;;
*)
AC_CHECK_LIB(c_r, gethostbyname_r)
;;
@@ -4117,8 +4130,8 @@ else
NSPR_LIBS="${LIBXUL_DIST}/lib/nspr${NSPR_VERSION}.lib ${LIBXUL_DIST}/lib/plc${NSPR_VERSION}.lib ${LIBXUL_DIST}/lib/plds${NSPR_VERSION}.lib "
fi
else
- NSPR_CFLAGS='`$(LIBXUL_DIST)/bin/nspr-config --prefix='${LIBXUL_DIST}' --includedir='${LIBXUL_DIST}'/include/nspr --cflags`'
- NSPR_LIBS='`$(LIBXUL_DIST)/bin/nspr-config --prefix='${LIBXUL_DIST}' --libdir='${LIBXUL_DIST}'/lib --libs`'
+ NSPR_CFLAGS="-I${prefix}/include/xulrunner/unstable `pkg-config --cflags mozilla-nspr`"
+ NSPR_LIBS="`pkg-config --libs mozilla-nspr`"
fi
fi
@@ -4138,7 +4151,7 @@ fi
if test -n "$MOZ_NATIVE_NSS"; then
NSS_LIBS="$NSS_LIBS -lcrmf"
else
- NSS_CFLAGS='-I$(LIBXUL_DIST)/include/nss'
+ NSS_CFLAGS="`pkg-config --cflags mozilla-nss`"
NSS_DEP_LIBS="\
\$(LIBXUL_DIST)/lib/\$(LIB_PREFIX)crmf.\$(LIB_SUFFIX) \
\$(LIBXUL_DIST)/lib/\$(DLL_PREFIX)smime$NSS_VERSION\$(DLL_SUFFIX) \
@@ -4156,7 +4169,7 @@ else
\$(LIBXUL_DIST)/lib/\$(LIB_PREFIX)nssutil$NSS_VERSION.\$(IMPORT_LIB_SUFFIX) \
\$(LIBXUL_DIST)/lib/\$(LIB_PREFIX)softokn$NSS_VERSION.\$(IMPORT_LIB_SUFFIX)"
else
- NSS_LIBS='$(LIBS_DIR)'" -lcrmf -lsmime$NSS_VERSION -lssl$NSS_VERSION -lnss$NSS_VERSION -lnssutil$NSS_VERSION -lsoftokn$NSS_VERSION"
+ NSS_LIBS="`pkg-config --libs mozilla-nss`"
fi
fi

View file

@ -1,24 +0,0 @@
$NetBSD: patch-ao,v 1.7 2009/08/05 02:43:47 tnn Exp $
--- toolkit/mozapps/installer/packager.mk.orig 2009-06-29 18:15:27.000000000 +0200
+++ toolkit/mozapps/installer/packager.mk
@@ -449,8 +449,8 @@ endif
(cd $(DIST)/$(MOZ_PKG_DIR) && tar $(TAR_CREATE_FLAGS) - .) | \
(cd $(DESTDIR)$(installdir) && tar -xf -)
$(NSINSTALL) -D $(DESTDIR)$(bindir)
- $(RM) -f $(DESTDIR)$(bindir)/$(MOZ_APP_NAME)
- ln -s $(installdir)/$(MOZ_APP_NAME) $(DESTDIR)$(bindir)
+ $(RM) -f $(DESTDIR)$(bindir)/$(MOZILLA_PKG_NAME)
+ ln -s $(installdir)/$(MOZ_APP_NAME) $(DESTDIR)$(bindir)/$(MOZILLA_PKG_NAME)
ifdef INSTALL_SDK # Here comes the hard part
# include directory is stable (dist/sdk/include) and unstable (dist/include)
$(NSINSTALL) -D $(DESTDIR)$(includedir)/stable
@@ -458,7 +458,7 @@ ifdef INSTALL_SDK # Here comes the hard
(cd $(DIST)/sdk/include && tar $(TAR_CREATE_FLAGS) - .) | \
(cd $(DESTDIR)$(includedir)/stable && tar -xf -)
# The dist/include has module subdirectories that we need to flatten
- find $(DIST)/include -xtype f -exec $(SYSINSTALL) $(IFLAGS1) {} $(DESTDIR)$(includedir)/unstable \;
+ find $(DIST)/include -type f -exec $(SYSINSTALL) $(IFLAGS1) {} $(DESTDIR)$(includedir)/unstable \;
# IDL directory is stable (dist/sdk/idl) and unstable (dist/idl)
$(NSINSTALL) -D $(DESTDIR)$(idldir)/stable
$(NSINSTALL) -D $(DESTDIR)$(idldir)/unstable

View file

@ -1,23 +0,0 @@
$NetBSD: patch-ma,v 1.1.1.1 2009/08/05 02:37:11 tnn Exp $
--- config/autoconf.mk.in.orig 2009-06-29 18:14:41.000000000 +0200
+++ config/autoconf.mk.in
@@ -57,14 +57,14 @@ MOZ_PKG_SPECIAL = @MOZ_PKG_SPECIAL@
prefix = @prefix@
exec_prefix = @exec_prefix@
bindir = @bindir@
-includedir = @includedir@/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+includedir = @includedir@/$(MOZILLA_PKG_NAME)
libdir = @libdir@
datadir = @datadir@
mandir = @mandir@
-idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+idldir = @datadir@/idl/$(MOZILLA_PKG_NAME)
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
+installdir = $(libdir)/$(MOZILLA_PKG_NAME)
+sdkdir = $(libdir)/$(MOZILLA_PKG_NAME)-sdk
DIST = $(DEPTH)/dist
LIBXUL_SDK = @LIBXUL_SDK@

View file

@ -1,15 +0,0 @@
$NetBSD: patch-mi,v 1.1.1.1 2009/08/05 02:37:11 tnn Exp $
Add DragonFly support.
--- config/config.mk.orig 2009-06-29 18:14:41.000000000 +0200
+++ config/config.mk
@@ -133,7 +133,7 @@ endif
# but save the version to allow multiple versions of the same base
# platform to be built in the same tree.
#
-ifneq (,$(filter FreeBSD HP-UX IRIX Linux NetBSD OpenBSD OSF1 SunOS,$(OS_ARCH)))
+ifneq (,$(filter DragonFly FreeBSD HP-UX IRIX Linux NetBSD OpenBSD OSF1 SunOS,$(OS_ARCH)))
OS_RELEASE := $(basename $(OS_RELEASE))
# Allow the user to ignore the OS_VERSION, which is usually irrelevant.

View file

@ -1,19 +0,0 @@
$NetBSD: patch-mk,v 1.1.1.1 2009/08/05 02:37:11 tnn Exp $
Treat DragonFly like FreeBSD.
--- config/rules.mk.orig 2009-06-29 18:14:41.000000000 +0200
+++ config/rules.mk
@@ -592,6 +592,12 @@ EXTRA_DSO_LDOPTS += -Wl,-Bsymbolic
endif
endif
+ifeq ($(OS_ARCH),DragonFly)
+ifdef IS_COMPONENT
+EXTRA_DSO_LDOPTS += -Wl,-Bsymbolic
+endif
+endif
+
ifeq ($(OS_ARCH),NetBSD)
ifneq (,$(filter arc cobalt hpcmips mipsco newsmips pmax sgimips,$(OS_TEST)))
ifeq ($(MODULE),layout)

View file

@ -1,19 +0,0 @@
$NetBSD: patch-mm,v 1.1.1.1 2009/08/05 02:37:11 tnn Exp $
Don't link with -lCstd on Solaris when using GCC. From Tim Zingelman.
part of PR pkg/39085
--- toolkit/library/Makefile.in.orig 2009-06-29 18:15:25.000000000 +0200
+++ toolkit/library/Makefile.in
@@ -252,7 +252,10 @@ EXTRA_DSO_LDOPTS += -lbe -ltracker
endif
ifeq ($(OS_ARCH),SunOS)
-EXTRA_DSO_LDOPTS += -lelf -ldemangle -lCstd
+EXTRA_DSO_LDOPTS += -lelf -ldemangle
+ifndef GNU_CC
+EXTRA_DSO_LDOPTS += -lCstd
+endif
endif
ifeq ($(OS_ARCH),WINNT)