Fix ambiguity between glib and gtk vala binding.
This commit is contained in:
parent
a086749dab
commit
4d26b4f6d6
3 changed files with 28 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.78 2015/04/06 08:17:40 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.79 2015/04/24 11:23:05 joerg Exp $
|
||||
|
||||
DISTNAME= midori_0.5.9_all_
|
||||
PKGNAME= ${DISTNAME:S/_all_//:S/_/-/}
|
||||
|
@ -42,6 +42,9 @@ CONF_FILES+= ${EGDIR}/extensions/adblock/config \
|
|||
|
||||
CONFIGURE_ENV= VALAC=${VALAC}
|
||||
|
||||
pre-configure:
|
||||
${RM} ${WRKSRC}/extensions/history-list.vala.orig
|
||||
|
||||
.include "../../databases/sqlite3/buildlink3.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../devel/libidn/buildlink3.mk"
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.23 2014/12/02 10:07:23 snj Exp $
|
||||
$NetBSD: distinfo,v 1.24 2015/04/24 11:23:05 joerg Exp $
|
||||
|
||||
SHA1 (midori_0.5.9_all_.tar.bz2) = 475614dcc89a214a3c2fdc2aaefc817a5fa0ca03
|
||||
RMD160 (midori_0.5.9_all_.tar.bz2) = 0436382ed629bfce63a93b2645314f5a08f2b855
|
||||
Size (midori_0.5.9_all_.tar.bz2) = 1332192 bytes
|
||||
SHA1 (patch-config_CMakeLists.txt) = 5ac4af9f980749659058fb55e7fd25ad6226861f
|
||||
SHA1 (patch-extensions_history-list.vala) = 74959c33009040b33f34da1173c8114e82434399
|
||||
|
|
22
www/midori/patches/patch-extensions_history-list.vala
Normal file
22
www/midori/patches/patch-extensions_history-list.vala
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-extensions_history-list.vala,v 1.1 2015/04/24 11:23:05 joerg Exp $
|
||||
|
||||
--- extensions/history-list.vala.orig 2015-04-23 18:29:27.000000000 +0000
|
||||
+++ extensions/history-list.vala
|
||||
@@ -319,7 +319,7 @@ namespace HistoryList {
|
||||
}
|
||||
|
||||
private void create_widgets () {
|
||||
- ListStore model;
|
||||
+ Gtk.ListStore model;
|
||||
TreeIter iter;
|
||||
TreeIter? active_iter = null;
|
||||
|
||||
@@ -331,7 +331,7 @@ namespace HistoryList {
|
||||
|
||||
var tab_closing_behavior = this.hl_manager.get_integer ("TabClosingBehavior");
|
||||
|
||||
- model = new ListStore (2, typeof (string), typeof (int));
|
||||
+ model = new Gtk.ListStore (2, typeof (string), typeof (int));
|
||||
|
||||
model.append (out iter);
|
||||
model.set (iter, TabClosingBehaviorModel.TEXT, _("Do nothing"),
|
Loading…
Reference in a new issue