Avoid too strict requirements (upper limit of dependencies versions), again!

Bump PKGREVISION.
This commit is contained in:
leot 2016-02-11 11:07:58 +00:00
parent 5b4891daf0
commit 4d53e73b72
3 changed files with 49 additions and 13 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.8 2015/12/30 15:08:08 leot Exp $
# $NetBSD: Makefile,v 1.9 2016/02/11 11:07:58 leot Exp $
DISTNAME= mitmproxy-0.15
PKGREVISION= 1
CATEGORIES= net
MASTER_SITES= http://mitmproxy.org/download/

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.6 2015/12/30 15:08:08 leot Exp $
$NetBSD: distinfo,v 1.7 2016/02/11 11:07:58 leot Exp $
SHA1 (mitmproxy-0.15.tar.gz) = c26793c8ac957f8a4d75073ca22edc4ebdaf158e
RMD160 (mitmproxy-0.15.tar.gz) = de16080adb8d218c21d62577afb9bcb14e265bd1
SHA512 (mitmproxy-0.15.tar.gz) = 3130e82965fd12379ddc2ca0369900a668a6bf68b122781fc8e84079d2ebad0d3e3d7b553b397100cf40872f33ce0014edebed5b056602c30df51c9084014ce7
Size (mitmproxy-0.15.tar.gz) = 1503247 bytes
SHA1 (patch-setup.py) = 5310ac499386aa630278249aad3698d4e7c34883
SHA1 (patch-setup.py) = 957ab39809084e7a1b1f0e1d63f14785d71f1a4a

View file

@ -1,19 +1,54 @@
$NetBSD: patch-setup.py,v 1.1 2015/12/30 15:08:08 leot Exp $
$NetBSD: patch-setup.py,v 1.2 2016/02/11 11:07:58 leot Exp $
Avoid too strict version requirements.
--- setup.py.orig 2015-12-03 17:16:16.000000000 +0000
+++ setup.py
@@ -20,10 +20,10 @@ deps = {
"pyperclip>=1.5.22, <1.6",
"blinker>=1.4, <1.5",
"pyparsing>=2.0.5, <2.1",
@@ -15,25 +15,25 @@ with open(os.path.join(here, 'README.rst
# Core dependencies
deps = {
"netlib>=%s, <%s" % (version.MINORVERSION, version.NEXT_MINORVERSION),
- "tornado>=4.3.0, <4.4",
- "configargparse>=0.10.0, <0.11",
- "pyperclip>=1.5.22, <1.6",
- "blinker>=1.4, <1.5",
- "pyparsing>=2.0.5, <2.1",
- "html2text==2015.11.4",
+ "html2text>=2015.11.4",
"construct>=2.5.2, <2.6",
"six>=1.10.0, <1.11",
- "construct>=2.5.2, <2.6",
- "six>=1.10.0, <1.11",
- "lxml==3.4.4", # there are no Windows wheels for 3.5!
- "Pillow>=3.0.0, <3.1",
- "watchdog>=0.8.3, <0.9",
+ "tornado>=4.3.0",
+ "configargparse>=0.10.0",
+ "pyperclip>=1.5.22",
+ "blinker>=1.4",
+ "pyparsing>=2.0.5",
+ "html2text>=2015.11.4",
+ "construct>=2.5.2",
+ "six>=1.10.0",
+ "lxml>=3.4.4", # there are no Windows wheels for 3.5!
"Pillow>=3.0.0, <3.1",
"watchdog>=0.8.3, <0.9",
+ "Pillow>=3.0.0",
+ "watchdog>=0.8.3",
}
# A script -> additional dependencies dict.
scripts = {
"mitmproxy": {
- "urwid>=1.3.1, <1.4",
+ "urwid>=1.3.1",
},
"mitmdump": {
- "click>=6.2, <6.3",
+ "click>=6.2",
},
"mitmweb": set()
}
@@ -68,7 +68,7 @@ for script_deps in scripts.values():
deps.update(script_deps)
if sys.version_info < (3, 4):
- example_deps.add("enum34>=1.0.4, <1.1")
+ example_deps.add("enum34>=1.0.4")
console_scripts = ["%s = libmproxy.main:%s" % (s, s) for s in scripts.keys()]