Link network libs and include filio.h for FIONBIO on SunOS

This commit is contained in:
wiedi 2014-02-24 13:11:53 +00:00
parent cbc590ba64
commit 4d6b78c334
3 changed files with 20 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.21 2012/10/23 17:19:13 asau Exp $
# $NetBSD: Makefile,v 1.22 2014/02/24 13:11:53 wiedi Exp $
#
DISTNAME= tn5250-0.12.51
@ -13,5 +13,7 @@ COMMENT= Implementation of the IBM 5250 telnet protocol
GNU_CONFIGURE= YES
USE_LANGUAGES= c c++
LDFLAGS.SunOS+= -lsocket -lnsl -lxnet
.include "../../devel/ncurses/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.7 2005/02/24 12:14:05 agc Exp $
$NetBSD: distinfo,v 1.8 2014/02/24 13:11:53 wiedi Exp $
SHA1 (tn5250-0.12.51.tar.gz) = c4394dd699afa3e38989015100f5837f266a80d9
RMD160 (tn5250-0.12.51.tar.gz) = 382c5988b1ddf6c7cb9345b79e760160c00c64fb
@ -6,3 +6,4 @@ Size (tn5250-0.12.51.tar.gz) = 101747 bytes
SHA1 (patch-aa) = eded51dff90cdab29069b281c991e5d53f393c88
SHA1 (patch-ab) = 32a611ae4ac1ad19a4063bebf17959bcfa5f5776
SHA1 (patch-ac) = b2d7ac117722cc225b5d960b966b4a6917b96bed
SHA1 (patch-stream5250.cc) = 122375d21017998f4bcf956bcdffb60df8b93e9a

View file

@ -0,0 +1,15 @@
$NetBSD: patch-stream5250.cc,v 1.1 2014/02/24 13:11:53 wiedi Exp $
need filio.h for FIONBIO on SunOS
--- stream5250.cc.orig 1999-04-05 16:25:45.000000000 +0000
+++ stream5250.cc
@@ -27,6 +27,9 @@
#include <sys/types.h>
#ifndef WIN32
#include <sys/time.h>
+#if defined(__sun)
+#include <sys/filio.h>
+#endif
#include <sys/ioctl.h>
#include <sys/socket.h>
#include <netinet/in.h>