Update to 0.9.2

Changelog:
2011-09-27 Release 0.9.2:
    * Score Checking
           o Performed automatically before printing (optional)
           o Under/Overfull measures
           o Unterminated tuplets
           o Miss-matched slurs.
    * Pitch Spelling
           o Performed live on MIDI entry
           o Colors intervals that may be enharmonic spelling mistakes with a di
fferent timbre
    * Enter Accidental before or after note
           o Use enter accidental to avoid sounding spurious notes on entry.
           o Change a note to one of its enharmonic variants. Same absolute pitc
h (in Equal Temperament).
           o Change the duration of single notes in a chord to create single-voi
ce polyphony
    * Vertical Rest Positioning (for polyphony)
    * Grace Notes that come after rather than before the main note.
    * Improved display of under/overfull measures
    * Display shows if there are measures before/after those on screen and provi
des buttons to navigate
    * Better beaming control.
    * Arbitrary Dynamics text.
    * New Denemo fonts
           o Denemo's own font now uses standard unicode font symbols
           o LilyPond font accessible to scripts
           o Improved display of entered music, help texts etc.
           o Simpler scripting to display any LilyPond feature.
    * Thumbnails for .denemo files in file open dialog and for your Window Manager
           o Thumbnail shows a selection of your choice as finally typeset.
           o Default thumbnail is first three measures
    * Import images of scores for transcription
           o Scores captured bar-by-bar into Denemo, displayed directly underneath the bar they relate to.
           o Editorial decisions/errors can easily be checked
           But Linux only.
    * Bug Fixes
           o Vertical scrolling (a long-standing bug fixed at last)
           o Bookmark searching
           o Nested tuplet display
           o Redo crashes
    * Notes:
           o As yet no windows binary is available
           o Playback out of priority thread is not in this release.
           o The manual does not have the latest list of scheme commands available.
This commit is contained in:
ryoon 2011-10-06 11:57:24 +00:00
parent da54d668d3
commit 4d6fdd30ac
8 changed files with 1363 additions and 100 deletions

View file

@ -1,22 +1,44 @@
# $NetBSD: Makefile,v 1.28 2011/04/22 13:43:42 obache Exp $
# $NetBSD: Makefile,v 1.29 2011/10/06 11:57:24 ryoon Exp $
#
DISTNAME= denemo-0.7.6
PKGREVISION= 6
DISTNAME= denemo-0.9.2
CATEGORIES= graphics print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=denemo/}
MASTER_SITES= ${MASTER_SITE_GNU:=denemo/}
MAINTAINER= rh@NetBSD.org
HOMEPAGE= http://denemo.sourceforge.net/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.denemo.org/
COMMENT= GUI musical score editor written in C/GTK+
LICENSE= gnu-gpl-v3
PKG_DESTDIR_SUPPORT= user-destdir
DEPENDS+= lilypond-[0-9]*:../../print/lilypond
GNU_CONFIGURE= YES
USE_TOOLS+= pkg-config
USE_TOOLS+= pkg-config gmake
EXTRACT_USING= bsdtar
INSTALLATION_DIRS= etc/${PKGBASE}
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
CONF_FILES= ${EGDIR}/denemo.conf ${PKG_SYSCONFDIR}/denemo/denemo.conf
#XXX Makefile contains .destdir/ path
post-install:
${RM} ${DESTDIR}${PREFIX}/share/denemo/actions/Makefile*
${RM} ${DESTDIR}${PREFIX}/share/denemo/examples/Makefile*
${RM} ${DESTDIR}${PREFIX}/share/denemo/manual/images/Makefile*
${RM} ${DESTDIR}${PREFIX}/share/denemo/templates/Makefile*
.include "../../audio/aubio/buildlink3.mk"
.include "../../audio/libsmf/buildlink3.mk"
.include "../../audio/fluidsynth/buildlink3.mk"
.include "../../audio/portaudio-devel/buildlink3.mk"
.include "../../graphics/librsvg/buildlink3.mk"
.include "../../lang/guile/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../x11/gtksourceview2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

File diff suppressed because it is too large Load diff

View file

@ -1,9 +1,6 @@
$NetBSD: distinfo,v 1.6 2007/08/08 18:48:32 joerg Exp $
$NetBSD: distinfo,v 1.7 2011/10/06 11:57:24 ryoon Exp $
SHA1 (denemo-0.7.6.tar.gz) = 6cb41657052964e69235722cf789f32cd4a29b9b
RMD160 (denemo-0.7.6.tar.gz) = 2c3805fc9d608a4a9fcdc093f4a712423dd40169
Size (denemo-0.7.6.tar.gz) = 1947693 bytes
SHA1 (patch-aa) = 200ae491fe5db81ff5db043e795f39e0c9be1a63
SHA1 (patch-ab) = 3b95f78bba437f4fb62db18850e810a14f8b36d2
SHA1 (patch-configure) = e713b0073a24b46838e3e61f06f3a551ac0bf934
SHA1 (patch-midic) = 71d411805173650c9a4ee533334a246995b74bd0
SHA1 (denemo-0.9.2.tar.gz) = 3332f50fc9d4ab550d10662728e294cac8c6bb08
RMD160 (denemo-0.9.2.tar.gz) = ee1f9fe4a7b3d5e5e316383386e229bb2c431d80
Size (denemo-0.9.2.tar.gz) = 12305392 bytes
SHA1 (patch-Makefile.in) = 94274f3105eb2d75536d00653572b166ea23463a

View file

@ -0,0 +1,25 @@
$NetBSD: patch-Makefile.in,v 1.1 2011/10/06 11:57:24 ryoon Exp $
* Support PKG_SYSCONFDIR
--- Makefile.in.orig 2011-04-27 18:00:54.000000000 +0000
+++ Makefile.in
@@ -388,15 +388,15 @@ distclean-libtool:
-rm -f libtool config.lt
install-dist_sysconfDATA: $(dist_sysconf_DATA)
@$(NORMAL_INSTALL)
- test -z "$(sysconfdir)" || $(MKDIR_P) "$(DESTDIR)$(sysconfdir)"
+ test -z "${PREFIX}/share/examples/denemo" || $(MKDIR_P) "$(DESTDIR)${PREFIX}/share/examples/denemo"
@list='$(dist_sysconf_DATA)'; test -n "$(sysconfdir)" || list=; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \
done | $(am__base_list) | \
while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(sysconfdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(sysconfdir)" || exit $$?; \
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)${PREFIX}/share/examples/denemo'"; \
+ $(INSTALL_DATA) $$files "$(DESTDIR)${PREFIX}/share/examples/denemo" || exit $$?; \
done
uninstall-dist_sysconfDATA:

View file

@ -1,22 +0,0 @@
$NetBSD: patch-aa,v 1.3 2007/03/30 16:22:52 joerg Exp $
--- src/staffpropdialog.c.orig 2007-03-30 15:57:04.000000000 +0000
+++ src/staffpropdialog.c
@@ -189,7 +189,7 @@ struct callbackdata
* @return denemocontext of the string
*/
static DenemoContext
-setcontext (const gchar * string)
+my_setcontext (const gchar * string)
{
if (!strcmp ("PianoContext", string))
return DENEMO_PIANO;
@@ -238,7 +238,7 @@ set_properties (struct callbackdata *cbd
if ((n = atoi (gtk_entry_get_text (GTK_ENTRY (cbdata->volume)))))
staffstruct->volume = n;
staffstruct->context =
- setcontext (gtk_entry_get_text (GTK_ENTRY (cbdata->contexts)));
+ my_setcontext (gtk_entry_get_text (GTK_ENTRY (cbdata->contexts)));
}

View file

@ -1,18 +0,0 @@
$NetBSD: patch-ab,v 1.3 2007/08/08 18:48:32 joerg Exp $
--- src/file.c.orig 2007-08-08 18:23:41.000000000 +0000
+++ src/file.c
@@ -31,12 +31,12 @@
#include "binreloc.h"
#include "view.h"
+#include <stdlib.h>
#include <stdio.h>
#include <string.h>
#include <sys/stat.h> /* check existance and type of files */
#include <dirent.h> /* filter and sort filenames */
#include <fnmatch.h> /* find filenames matches */
-#include <malloc.h> /* I use free() */
typedef enum

View file

@ -1,13 +0,0 @@
$NetBSD: patch-configure,v 1.1 2007/01/07 08:28:05 rillig Exp $
--- configure.orig 2006-11-11 13:15:02.000000000 +0100
+++ configure 2007-01-07 09:16:21.000000000 +0100
@@ -24778,7 +24778,7 @@ done
-if test "${prefix}" == "NONE"; then
+if test "${prefix}" = "NONE"; then
prefix=${ac_default_prefix}
fi

View file

@ -1,17 +0,0 @@
$NetBSD: patch-midic,v 1.1 2007/01/07 08:28:05 rillig Exp $
--- src/midi.c.orig 2006-08-06 20:11:09.000000000 +0200
+++ src/midi.c 2007-01-07 09:20:08.000000000 +0100
@@ -14,6 +14,12 @@
#include <sys/soundcard.h>
#endif
+#if !defined(SEQ_DEFINEBUF)
+/* Some systems (for example NetBSD 3.0) do not have sequencer support
+ * (SEQ_DEFINEBUF(), struct synth_card). */
+# undef HAVE_SYS_SOUNDCARD_H
+#endif
+
#include <sys/types.h>
#include <sys/stat.h>
#include <fcntl.h>