gtksql: remove

Doesn't build, uses gtk1, pkgsrc version from 2000, last release from 2007
This commit is contained in:
wiz 2022-04-25 07:55:18 +00:00
parent a8ddb5b911
commit 4d90da6cd0
8 changed files with 3 additions and 153 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.660 2022/04/24 17:50:25 tnn Exp $
# $NetBSD: Makefile,v 1.661 2022/04/25 07:55:18 wiz Exp $
COMMENT= Databases
@ -47,7 +47,6 @@ SUBDIR+= gom
SUBDIR+= gourmet
SUBDIR+= gramps5
SUBDIR+= gtkdbfeditor
SUBDIR+= gtksql
SUBDIR+= guile-pg
SUBDIR+= guile-sqlite3
SUBDIR+= hiredis

View file

@ -1,10 +0,0 @@
GtkSQL is a graphical query tool (like PostgreSQL's psql). It
is released under the GNU GPL license, and was developped using
Gtk+ 1.0.0 and PostgreSQL 6.3.
Its main features are:
* multiple SQL buffers
* SQL keywords, table names and fields autocompletion
* easy displaying of tables definitions
* exporting of query results

View file

@ -1,20 +0,0 @@
# $NetBSD: Makefile,v 1.48 2016/10/09 21:41:56 wiz Exp $
#
DISTNAME= gtksql-0.3
PKGREVISION= 11
CATEGORIES= databases
MASTER_SITES= http://membres.lycos.fr/bbrox/GtkSQL/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://membres.lycos.fr/bbrox/GtkSQL/
COMMENT= Query tool for PostgreSQL written with GTK
INSTALLATION_DIRS+= bin
MAKE_ENV+= MCFLAGS=${CFLAGS:M*:Q} PGSQL_PREFIX=${PGSQL_PREFIX:Q}
.include "../../mk/pgsql.buildlink3.mk"
.include "../../x11/gtk/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,2 +0,0 @@
@comment $NetBSD: PLIST,v 1.1 2001/11/01 00:11:44 zuntum Exp $
bin/gtksql

View file

@ -1,7 +0,0 @@
$NetBSD: distinfo,v 1.15 2021/10/26 10:09:19 nia Exp $
BLAKE2s (gtksql-0.3.tar.gz) = c1e38e277261f9bd71ef47e6d734b280604b420de97cb7f78f7954fa7d2a9c3d
SHA512 (gtksql-0.3.tar.gz) = a36ff4624d71b1477e3e22f3f42c7faca09e5a3d39e3bef33e8d1ef4a37b2754a5536798f45cf768d5baf9dc8410ee79306471e114d1d4058d17e6f67684bc2d
Size (gtksql-0.3.tar.gz) = 50557 bytes
SHA1 (patch-aa) = e7c521a660c8f48fbb1a3cd6fdfacd54b50aecc3
SHA1 (patch-ab) = 0d194dd153e3d3ce34b0f0d805ae0d83408de33b

View file

@ -1,46 +0,0 @@
$NetBSD: patch-aa,v 1.13 2010/01/29 17:05:46 joerg Exp $
--- Makefile.orig Sat Jun 5 06:05:36 1999
+++ Makefile
@@ -1,17 +1,17 @@
# Your favorite compilation options here :-)
-MCFLAGS = -Wall -O -g
-LDFLAGS = -lcrypt
+#MCFLAGS = -Wall -O -g
+LDFLAGS += -lcrypt
# Comment out the variables for the databases that you do not want
# Here, what you need for PostgreSQL
-PGSQLIBS = -L/usr/local/pgsql/lib -lpq
-PGSQLCFLAGS = -I/usr/local/pgsql/include -DUSE_POSTGRESQL
+PGSQLIBS = -L${PGSQL_PREFIX}/lib -lpq
+PGSQLCFLAGS = -I${PGSQL_PREFIX}/include/postgresql/server -DUSE_POSTGRESQL
PGSQLOBJS = postgres.o
# Here, what you need for MySQL
-MYSQLIBS = -L/usr/lib/mysql -lmysqlclient
-MYSQLCFLAGS = -I/usr/include/mysql -DUSE_MYSQL
-MYSQLOBJS = mysql.o
+#MYSQLIBS = -L/usr/lib/mysql -lmysqlclient
+#MYSQLCFLAGS = -I/usr/include/mysql -DUSE_MYSQL
+#MYSQLOBJS = mysql.o
# Nothing to change below this point...
DBSQLIBS = $(PGSQLIBS) $(MYSQLIBS)
@@ -28,13 +28,13 @@ GTKLIBS = `gtk-config --libs`
GTKCFLAGS = `gtk-config --cflags`
all: $(OBJS)
- gcc -o gtksql $(OBJS) $(DBSQLIBS) $(GTKLIBS) $(CFLAGS) $(LDFLAGS)
+ ${CC} -o gtksql $(OBJS) $(DBSQLIBS) $(GTKLIBS) $(CFLAGS) $(LDFLAGS)
clean:
rm -f *.o gtksql
install: all
- cp gtksql $(DESTDIR)usr/bin/
+ ${BSD_INSTALL_PROGRAM} gtksql ${DESTDIR}${PREFIX}/bin
.c.o:
- gcc $(CFLAGS) $(GTKCFLAGS) $(DBSQLCFLAGS) -c $*.c -o ./$*.o
+ ${CC} $(CFLAGS) $(GTKCFLAGS) $(DBSQLCFLAGS) -c $*.c -o ./$*.o

View file

@ -1,65 +0,0 @@
$NetBSD: patch-ab,v 1.1 2003/09/08 12:13:50 kleink Exp $
--- postgres.c.orig 1999-06-05 15:05:36.000000000 +0200
+++ postgres.c 2003-09-08 14:11:15.000000000 +0200
@@ -129,14 +129,14 @@
PGresult *table_info;
char query[512];
- sprintf(query, "SELECT a.attnum, a.attname, t.typname, a.attlen,
- a.atttypmod, a.attnotnull, a.atthasdef
- FROM pg_class c, pg_attribute a, pg_type t
- WHERE c.relname = '%s' AND
- a.attnum > 0 AND
- a.attrelid = c.oid AND
- a.atttypid = t.oid
- ORDER BY attnum", tbf->name);
+ sprintf(query, "SELECT a.attnum, a.attname, t.typname, a.attlen,"\
+ "a.atttypmod, a.attnotnull, a.atthasdef"\
+ "FROM pg_class c, pg_attribute a, pg_type t"\
+ "WHERE c.relname = '%s' AND"\
+ "a.attnum > 0 AND"\
+ "a.attrelid = c.oid AND"\
+ "a.atttypid = t.oid"\
+ "ORDER BY attnum", tbf->name);
table_info = PQexec(conn, query);
if ((table_info == NULL) ||
@@ -183,11 +183,11 @@
if (rnotnull[0] == 't')
strcat(type_str, " not null");
if (rhasdef[0] == 't') {
- sprintf(buf, "SELECT d.adsrc
- FROM pg_attrdef d, pg_class c
- WHERE c.relname = '%s' AND
- c.oid = d.adrelid AND
- d.adnum = %s",
+ sprintf(buf, "SELECT d.adsrc"\
+ "FROM pg_attrdef d, pg_class c"\
+ "WHERE c.relname = '%s' AND"\
+ "c.oid = d.adrelid AND"\
+ "d.adnum = %s",
tbf->name, PQgetvalue(table_info, i, 0));
table_info2 = PQexec(conn, buf);
if ((table_info2 == NULL) ||
@@ -240,13 +240,13 @@
PGresult *tables;
char query[512];
- sprintf(query, "SELECT usename, relname, relkind, relhasrules
- FROM pg_class, pg_user
- WHERE relkind = 'r' AND
- relname !~ '^pg_' AND
- relname !~ '^xin[vx][0-9]+' AND
- usesysid = relowner
- ORDER BY relname");
+ sprintf(query, "SELECT usename, relname, relkind, relhasrules"\
+ "FROM pg_class, pg_user"\
+ "WHERE relkind = 'r' AND"\
+ "relname !~ '^pg_' AND"\
+ "relname !~ '^xin[vx][0-9]+' AND"\
+ "usesysid = relowner"\
+ "ORDER BY relname");
tables = PQexec(conn->conn, query);
if ((tables == NULL) || (PQresultStatus(tables) != PGRES_TUPLES_OK)) {

View file

@ -1,4 +1,4 @@
$NetBSD: CHANGES-2022,v 1.2084 2022/04/25 07:20:35 wiz Exp $
$NetBSD: CHANGES-2022,v 1.2085 2022/04/25 07:55:19 wiz Exp $
Changes to the packages collection and infrastructure in 2022:
@ -3243,3 +3243,4 @@ Changes to the packages collection and infrastructure in 2022:
Updated net/libslirp to 4.6.1 [nia 2022-04-25]
Removed net/gst-plugins1-mms [wiz 2022-04-25]
Updated multimedia/py-gstreamer1 to 1.20.1 [wiz 2022-04-25]
Removed databases/gtksql [wiz 2022-04-25]