Force common shared library version scheme on FreeBSD to avoid PLIST divergence.
This commit is contained in:
parent
b79e429498
commit
4d9f2167bc
8 changed files with 77 additions and 26 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.23 2012/07/12 19:46:50 marino Exp $
|
||||
$NetBSD: distinfo,v 1.24 2012/07/16 21:17:10 asau Exp $
|
||||
|
||||
SHA1 (postgresql-8.3.19.tar.bz2) = bd7fcb188f668d30029f02048b5b5b86b9d3d14e
|
||||
RMD160 (postgresql-8.3.19.tar.bz2) = 1611a009386ba6984689fbbf8663c49d405f864c
|
||||
|
@ -11,7 +11,7 @@ SHA1 (patch-af) = fcb43276c1f3349f62acfc37ac0bd6ccaae96f29
|
|||
SHA1 (patch-ag) = 402d5d211af99efdfa35677299c97e91e14ed85d
|
||||
SHA1 (patch-ah) = 3640573195f66a46c37d9fca2648d6be39f5593b
|
||||
SHA1 (patch-ai) = a2364b8e1e8a3094e1c5bfb0cad2d0babe0a8841
|
||||
SHA1 (patch-ba) = db6be7665f19d2b2b707ffcaa04cb92b44544d61
|
||||
SHA1 (patch-ba) = 4a1a9df19eca3c602df19a4201041494a49262f9
|
||||
SHA1 (patch-src_interfaces_ecpg_ecpglib_Makefile) = 9107a858d4066f0c1e7ece8332d4b32ded718af1
|
||||
SHA1 (patch-src_makefiles_Makefile.solaris) = 21fd5b1103e1c8aaf339ee6ef91e0d6dab5bea3a
|
||||
SHA1 (patch-src_pl_plperl_plperl.h) = a521489a0e233a8dbaa8c56dd8fe5c411b0639c5
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ba,v 1.1 2011/09/11 10:07:34 marino Exp $
|
||||
$NetBSD: patch-ba,v 1.2 2012/07/16 21:17:11 asau Exp $
|
||||
|
||||
--- src/Makefile.shlib.orig 2011-07-15 22:27:14.818068000 +0000
|
||||
--- src/Makefile.shlib.orig 2012-05-31 23:14:08.000000000 +0000
|
||||
+++ src/Makefile.shlib
|
||||
@@ -136,6 +136,10 @@ ifeq ($(PORTNAME), bsdi)
|
||||
@@ -136,12 +136,14 @@ ifeq ($(PORTNAME), bsdi)
|
||||
endif
|
||||
endif
|
||||
|
||||
|
@ -12,4 +12,10 @@ $NetBSD: patch-ba,v 1.1 2011/09/11 10:07:34 marino Exp $
|
|||
+
|
||||
ifeq ($(PORTNAME), freebsd)
|
||||
ifdef ELF_SYSTEM
|
||||
shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
|
||||
- shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
|
||||
LINK.shared = $(COMPILER) -shared -Wl,-x,-soname,$(soname)
|
||||
else
|
||||
- shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION).$(SO_MINOR_VERSION)
|
||||
LINK.shared = $(LD) -x -Bshareable -Bforcearchive
|
||||
endif
|
||||
endif
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.19 2012/07/12 18:57:27 marino Exp $
|
||||
$NetBSD: distinfo,v 1.20 2012/07/16 21:17:11 asau Exp $
|
||||
|
||||
SHA1 (postgresql-8.4.12.tar.bz2) = 04ad9650573df7723511f57ef8cdeadce8d3855d
|
||||
RMD160 (postgresql-8.4.12.tar.bz2) = 2aa0da64dc3220497d510bd60a1abf0b68fd51ef
|
||||
|
@ -12,7 +12,7 @@ SHA1 (patch-ag) = 85dac95e40efc16270885087f868aeb76e1b9214
|
|||
SHA1 (patch-ah) = 25102dce1b9b22385353af23500636fb18e3bf64
|
||||
SHA1 (patch-ai) = 0d6f536f7593e362ec216eafa73c718ad6bed8fc
|
||||
SHA1 (patch-ao) = b098032408fc951865966710554667a249db6320
|
||||
SHA1 (patch-ba) = 2cc374fdf4351a4c03ecad30fb99d2aff2cf0bdf
|
||||
SHA1 (patch-ba) = f8de4ee18a433b65a54280d047d18b161d3e9ca8
|
||||
SHA1 (patch-bb) = 22859530d2694cf4c347f5e4c02eff0483d536d1
|
||||
SHA1 (patch-src_pl_plperl_plperl.h) = 8d448cc8e0e0dbc4d15dad369d3ca7a796874ac2
|
||||
SHA1 (patch-src_pl_plpgsql_src_Makefile) = 1592ecb85d6ef1bd691f77b320f639b6fc822e14
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ba,v 1.1 2011/09/11 10:53:31 marino Exp $
|
||||
$NetBSD: patch-ba,v 1.2 2012/07/16 21:17:11 asau Exp $
|
||||
|
||||
--- src/Makefile.shlib.orig 2011-07-15 20:03:13.383961000 +0000
|
||||
--- src/Makefile.shlib.orig 2012-05-31 23:11:47.000000000 +0000
|
||||
+++ src/Makefile.shlib
|
||||
@@ -175,6 +175,13 @@ ifeq ($(PORTNAME), bsdi)
|
||||
@@ -175,19 +175,20 @@ ifeq ($(PORTNAME), bsdi)
|
||||
endif
|
||||
endif
|
||||
|
||||
|
@ -15,4 +15,17 @@ $NetBSD: patch-ba,v 1.1 2011/09/11 10:53:31 marino Exp $
|
|||
+
|
||||
ifeq ($(PORTNAME), freebsd)
|
||||
ifdef ELF_SYSTEM
|
||||
ifdef SO_MAJOR_VERSION
|
||||
- ifdef SO_MAJOR_VERSION
|
||||
- shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
|
||||
- endif
|
||||
LINK.shared = $(COMPILER) -shared
|
||||
ifdef soname
|
||||
LINK.shared += -Wl,-x,-soname,$(soname)
|
||||
endif
|
||||
else
|
||||
- ifdef SO_MAJOR_VERSION
|
||||
- shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION).$(SO_MINOR_VERSION)
|
||||
- endif
|
||||
LINK.shared = $(LD) -x -Bshareable -Bforcearchive
|
||||
endif
|
||||
endif
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.11 2012/07/01 19:42:06 morr Exp $
|
||||
$NetBSD: distinfo,v 1.12 2012/07/16 21:17:11 asau Exp $
|
||||
|
||||
SHA1 (postgresql-9.0.8.tar.bz2) = 240d2d45bc87d8cdad8e2b74cf378f5668b604fe
|
||||
RMD160 (postgresql-9.0.8.tar.bz2) = fab8564774c99300ca8a69298417eec960e70601
|
||||
|
@ -12,6 +12,6 @@ SHA1 (patch-ag) = 85dac95e40efc16270885087f868aeb76e1b9214
|
|||
SHA1 (patch-ah) = 25102dce1b9b22385353af23500636fb18e3bf64
|
||||
SHA1 (patch-ai) = 0d6f536f7593e362ec216eafa73c718ad6bed8fc
|
||||
SHA1 (patch-ao) = 4d7c40d107d4c13c63ef2908d9a02be319863657
|
||||
SHA1 (patch-src_Makefile.shlib) = b5f66154482df3d14af5ecbb524eeff6c246d049
|
||||
SHA1 (patch-src_Makefile.shlib) = 72d6db917b7d6ba1dbf8037e03f83a7ce7c4d6c9
|
||||
SHA1 (patch-src_makefiles_Makefile.solaris) = 0168f5bc105ffc89d5db40907a08966d8465f5a0
|
||||
SHA1 (patch-src_pl_plperl_plperl.h) = 8e2d954642cb68dc6c6fd08debd058d053566826
|
||||
|
|
|
@ -1,10 +1,26 @@
|
|||
$NetBSD: patch-src_Makefile.shlib,v 1.1 2011/02/28 07:40:56 adam Exp $
|
||||
$NetBSD: patch-src_Makefile.shlib,v 1.2 2012/07/16 21:17:12 asau Exp $
|
||||
|
||||
Properly define the linker on DragonFly BSD.
|
||||
|
||||
--- src/Makefile.shlib.orig 2011-01-28 02:21:31 +0000
|
||||
--- src/Makefile.shlib.orig 2012-05-31 23:09:35.000000000 +0000
|
||||
+++ src/Makefile.shlib
|
||||
@@ -197,6 +197,17 @@ ifeq ($(PORTNAME), netbsd)
|
||||
@@ -171,17 +171,11 @@ endif
|
||||
|
||||
ifeq ($(PORTNAME), freebsd)
|
||||
ifdef ELF_SYSTEM
|
||||
- ifdef SO_MAJOR_VERSION
|
||||
- shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
|
||||
- endif
|
||||
LINK.shared = $(COMPILER) -shared
|
||||
ifdef soname
|
||||
LINK.shared += -Wl,-x,-soname,$(soname)
|
||||
endif
|
||||
else
|
||||
- ifdef SO_MAJOR_VERSION
|
||||
- shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION).$(SO_MINOR_VERSION)
|
||||
- endif
|
||||
LINK.shared = $(LD) -x -Bshareable -Bforcearchive
|
||||
endif
|
||||
endif
|
||||
@@ -197,6 +191,17 @@ ifeq ($(PORTNAME), netbsd)
|
||||
endif
|
||||
endif
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.6 2012/07/01 19:49:24 morr Exp $
|
||||
$NetBSD: distinfo,v 1.7 2012/07/16 21:17:12 asau Exp $
|
||||
|
||||
SHA1 (postgresql-9.1.4.tar.bz2) = c75fd5696af02a275a104260eac8b3a4abe35682
|
||||
RMD160 (postgresql-9.1.4.tar.bz2) = ff08ad702c7ffc0172b3f66aa4819d4865f0e77b
|
||||
|
@ -7,7 +7,7 @@ SHA1 (patch-config_perl.m4) = c7e5aaff1c47d2e33df7692a412ef984c77ffcc0
|
|||
SHA1 (patch-configure) = dab79533dac06a79a5aa8439d6b15830d8d2fba7
|
||||
SHA1 (patch-contrib_dblink_Makefile) = 4960ad57d42465fae203870548e4c53f8a32ce04
|
||||
SHA1 (patch-contrib_dblink_dblink.c) = 4d7c40d107d4c13c63ef2908d9a02be319863657
|
||||
SHA1 (patch-src_Makefile.shlib) = 39c9d8fa983658fd609a7879cbe46c95aabb8011
|
||||
SHA1 (patch-src_Makefile.shlib) = 2370e3c4260ba7f947b0c15b9bdc43e4820e01a4
|
||||
SHA1 (patch-src_backend_Makefile) = 76ddd3015d93b19cdd6000eaffc4f53cbd4965b5
|
||||
SHA1 (patch-src_makefiles_Makefile.solaris) = 0168f5bc105ffc89d5db40907a08966d8465f5a0
|
||||
SHA1 (patch-src_pl_plperl_GNUmakefile) = 2b7448d6dd8550e2ea61f40728a2780068b93d07
|
||||
|
|
|
@ -1,10 +1,26 @@
|
|||
$NetBSD: patch-src_Makefile.shlib,v 1.1.1.1 2011/09/15 08:27:39 adam Exp $
|
||||
$NetBSD: patch-src_Makefile.shlib,v 1.2 2012/07/16 21:17:12 asau Exp $
|
||||
|
||||
Properly define the linker on DragonFly BSD.
|
||||
|
||||
--- src/Makefile.shlib.orig 2011-01-28 02:21:31 +0000
|
||||
--- src/Makefile.shlib.orig 2012-05-31 23:07:09.000000000 +0000
|
||||
+++ src/Makefile.shlib
|
||||
@@ -198,6 +198,17 @@ ifeq ($(PORTNAME), netbsd)
|
||||
@@ -172,17 +172,11 @@ endif
|
||||
|
||||
ifeq ($(PORTNAME), freebsd)
|
||||
ifdef ELF_SYSTEM
|
||||
- ifdef SO_MAJOR_VERSION
|
||||
- shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
|
||||
- endif
|
||||
LINK.shared = $(COMPILER) -shared
|
||||
ifdef soname
|
||||
LINK.shared += -Wl,-x,-soname,$(soname)
|
||||
endif
|
||||
else
|
||||
- ifdef SO_MAJOR_VERSION
|
||||
- shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION).$(SO_MINOR_VERSION)
|
||||
- endif
|
||||
LINK.shared = $(LD) -x -Bshareable -Bforcearchive
|
||||
endif
|
||||
endif
|
||||
@@ -198,6 +192,17 @@ ifeq ($(PORTNAME), netbsd)
|
||||
endif
|
||||
endif
|
||||
|
||||
|
|
Loading…
Reference in a new issue