py-foolscap: convert to wheel.mk

Fix build with Python 3.12.

Bump PKGREVISION.
This commit is contained in:
wiz 2023-11-05 22:50:39 +00:00
parent df5be90ec8
commit 4da1fcc716
4 changed files with 31 additions and 16 deletions

View File

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.42 2023/06/18 05:39:37 adam Exp $
# $NetBSD: Makefile,v 1.43 2023/11/05 22:50:39 wiz Exp $
DISTNAME= foolscap-21.7.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_PYPI:=f/foolscap/}
@ -13,18 +13,14 @@ HOMEPAGE= https://foolscap.lothar.com/trac
COMMENT= RPC protocol for Twisted
LICENSE= mit
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
DEPENDS+= ${PYPKGPREFIX}-twisted-[0-9]*:../../net/py-twisted
DEPENDS+= ${PYPKGPREFIX}-zope.interface>=3.6.1:../../devel/py-zope.interface
PYTHON_VERSIONS_INCOMPATIBLE= 27
# \todo Restore tests
#TEST_TARGET= test
USE_LANGUAGES= # none
USE_PKG_RESOURCES= yes
INSTALLATION_DIRS+= share/doc/py-foolscap
post-install:
@ -33,7 +29,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/*.rst \
${DESTDIR}${PREFIX}/share/doc/py-foolscap
.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
PYTHON_VERSIONED_DEPENDENCIES+= OpenSSL
.include "../../lang/python/versioned_dependencies.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,13 +1,13 @@
@comment $NetBSD: PLIST,v 1.11 2021/08/31 17:16:22 gdt Exp $
@comment $NetBSD: PLIST,v 1.12 2023/11/05 22:50:39 wiz Exp $
bin/flappclient
bin/flappserver
bin/flogtool
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/entry_points.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/entry_points.txt
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
${PYSITELIB}/foolscap/__init__.py
${PYSITELIB}/foolscap/__init__.pyc
${PYSITELIB}/foolscap/__init__.pyo

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.22 2021/10/26 11:06:36 nia Exp $
$NetBSD: distinfo,v 1.23 2023/11/05 22:50:39 wiz Exp $
BLAKE2s (foolscap-21.7.0.tar.gz) = d89d7e3c2273222e3c3c8cddc71b91a9ad42ca869fdce387eccf2cb94815c17d
SHA512 (foolscap-21.7.0.tar.gz) = 1456e386b62c5070fdc606d1b6ce3939830ed930d98f542aca758109228bcfe544b7a372cb60df813a70779ea850ad0abca4b33f11f1369292d48cc60d761b86
Size (foolscap-21.7.0.tar.gz) = 489611 bytes
SHA1 (patch-versioneer.py) = e4cfc8afea123b14d1c8122745f7cfe03aef6def

View File

@ -0,0 +1,18 @@
$NetBSD: patch-versioneer.py,v 1.1 2023/11/05 22:50:39 wiz Exp $
Fix build with Python 3.12.
--- versioneer.py.orig 2021-06-30 19:52:29.000000000 +0000
+++ versioneer.py
@@ -339,9 +339,9 @@ def get_config_from_root(root):
# configparser.NoOptionError (if it lacks "VCS="). See the docstring at
# the top of versioneer.py for instructions on writing your setup.cfg .
setup_cfg = os.path.join(root, "setup.cfg")
- parser = configparser.SafeConfigParser()
+ parser = configparser.ConfigParser()
with open(setup_cfg, "r") as f:
- parser.readfp(f)
+ parser.read_file(f)
VCS = parser.get("versioneer", "VCS") # mandatory
def get(parser, name):