Use REPLACE_INTERPRETER instead of a patch.

This commit is contained in:
ghen 2006-03-09 11:28:00 +00:00
parent 3a7c9408de
commit 4de20ba9c9
3 changed files with 13 additions and 11 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.7 2006/03/04 21:30:40 jlam Exp $
# $NetBSD: Makefile,v 1.8 2006/03/09 11:28:00 ghen Exp $
DISTNAME= atitvout-0.4
PKGREVISION= 1
@ -25,11 +25,15 @@ do-configure:
${CP} ${FILESDIR}/Makefile.bsd ${WRKSRC}
.endif
REPLACE_INTERPRETER+= bash
_REPLACE.bash.old= /bin/bash
_REPLACE.bash.new= ${SH:Q}
_REPLACE_FILES.bash= test.sh
SUBST_CLASSES+= sh
SUBST_STAGE.sh= post-patch
SUBST_STAGE.sh= pre-configure
SUBST_FILES.sh= test.sh
SUBST_SED.sh= -e "s,@PREFIX@,${PREFIX},"
SUBST_MESSAGE.sh= "Fixing stupid bash scripts."
INSTALLATION_DIRS= sbin

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.4 2005/02/24 13:40:50 agc Exp $
$NetBSD: distinfo,v 1.5 2006/03/09 11:28:00 ghen Exp $
SHA1 (atitvout-0.4.tar.gz) = ac0d3f19119fa0c096099f952c9c59ac44ccc840
RMD160 (atitvout-0.4.tar.gz) = 594fbc3a20362275a2d9b4ca13ae0b7ae761bcf3
Size (atitvout-0.4.tar.gz) = 27163 bytes
SHA1 (patch-aa) = 68e79e289b1aadbba3aa1dbf3137fdf90c486afa
SHA1 (patch-ab) = 7cf654f43489be3ae982b17f458bf733342469b0
SHA1 (patch-ab) = e6b0e4fe8ba6427c3c9d2d99d3c0fbb43493f667

View file

@ -1,10 +1,8 @@
$NetBSD: patch-ab,v 1.1 2004/12/18 13:18:13 xtraeme Exp $
$NetBSD: patch-ab,v 1.2 2006/03/09 11:28:00 ghen Exp $
--- test.sh.orig 2004-12-18 14:12:20.000000000 +0100
+++ test.sh 2004-12-18 14:12:44.000000000 +0100
@@ -1,8 +1,8 @@
-#!/bin/bash
+#!/bin/sh
--- test.sh.orig 2006-03-09 12:24:22.000000000 +0100
+++ test.sh
@@ -2,7 +2,7 @@
testit () {
echo "TEST: Running 'atitvout $FLAG $1' ..."