Casting 0 to an iterator is not portable. Just use end() in that case.

This commit is contained in:
joerg 2013-05-23 15:00:00 +00:00
parent f447c7e283
commit 4de84f4833
2 changed files with 19 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.31 2011/11/26 17:10:24 joerg Exp $
$NetBSD: distinfo,v 1.32 2013/05/23 15:00:00 joerg Exp $
SHA1 (verilog-20090923.tar.gz) = 1836ebc4ef78341fb1a077e807c8d5b195ebb253
RMD160 (verilog-20090923.tar.gz) = 32a009d1390e71721d3a72a1940b655ed1853ba5
Size (verilog-20090923.tar.gz) = 1121376 bytes
SHA1 (patch-ad) = 9492af75153405c49076f2dcd11d2dc338640514
SHA1 (patch-net__scope.cc) = 97cf7d099b30b3549ad6262022ca32e8790b5d66
SHA1 (patch-pform__disciplines.cc) = 113365b68723462791728e6f998685a4ebca3547

View file

@ -0,0 +1,17 @@
$NetBSD: patch-net__scope.cc,v 1.1 2013/05/23 15:00:00 joerg Exp $
--- net_scope.cc.orig 2013-05-22 14:46:10.000000000 +0000
+++ net_scope.cc
@@ -221,11 +221,7 @@ map<perm_string,NetScope::param_expr_t>:
if (idx != parameters.end())
return idx;
- idx = localparams.find(perm_string::literal(key));
- if (idx != localparams.end())
- return idx;
-
- return (map<perm_string,param_expr_t>::iterator) 0;
+ return localparams.find(perm_string::literal(key));
}
NetScope::TYPE NetScope::type() const