Update to 0.86:

V0.86 Fixed default hostname logic.
      Fix for NetBSD: 64bit time_t -- Thomas Klausner
      Fix unnecessary runtime dependency on glib from VSYakovetsky through
           Thomas
      Inverted IPINFO define in the code. Removes double negatives.
         -- Vladimir Yakovetsky, REW.
      Fixed failure on IPv4 only systems when IPv6 was available at
         compile time. -- REW.
      Fixed (longstanding) bug that mtr used 100% cpu when paused.
      Cosmetic changes from Richard Hartman.
This commit is contained in:
wiz 2014-12-14 15:48:44 +00:00
parent cc514319c9
commit 4e0ac7f788
4 changed files with 6 additions and 45 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.88 2014/10/09 14:06:45 wiz Exp $
# $NetBSD: Makefile,v 1.89 2014/12/14 15:48:44 wiz Exp $
DISTNAME= mtr-0.85
PKGREVISION= 4
DISTNAME= mtr-0.86
CATEGORIES= net
MASTER_SITES= ftp://ftp.bitwizard.nl/mtr/

View file

@ -1,8 +1,6 @@
$NetBSD: distinfo,v 1.40 2013/08/09 11:41:20 fhajny Exp $
$NetBSD: distinfo,v 1.41 2014/12/14 15:48:44 wiz Exp $
SHA1 (mtr-0.85.tar.gz) = 77204a1a577cfca30c79c43a8fa3daafd280f1b8
RMD160 (mtr-0.85.tar.gz) = 0ca692799d3b4d4358d02f72787e8705c061c817
Size (mtr-0.85.tar.gz) = 534196 bytes
SHA1 (patch-asn.c) = 5582267de8777e2139acf30e0cd360262ae07a84
SHA1 (mtr-0.86.tar.gz) = 2c81d0f4c9296861a1159f07eec6acfb4bebecf7
RMD160 (mtr-0.86.tar.gz) = a3bd71a2102722e98e92c31988bc2c1ca13ea26a
Size (mtr-0.86.tar.gz) = 185374 bytes
SHA1 (patch-net.c) = b8a88ef7c4bad7cfbb502e60e12fd84b90e601dd
SHA1 (patch-report.c) = 13c834fa841bce84aadc57124b6de6ffbc8766e9

View file

@ -1,16 +0,0 @@
$NetBSD: patch-asn.c,v 1.3 2013/07/06 09:57:20 tron Exp $
Fix build under Mac OS X (Lion).
--- asn.c.orig 2013-04-24 10:32:13.000000000 +0100
+++ asn.c 2013-07-06 10:55:12.000000000 +0100
@@ -21,9 +21,7 @@
#include <stdlib.h>
#include <sys/types.h>
-#ifndef __APPLE__
#define BIND_8_COMPAT
-#endif
#include <arpa/nameser.h>
#ifdef HAVE_ARPA_NAMESER_COMPAT_H
#include <arpa/nameser_compat.h>

View file

@ -1,20 +0,0 @@
$NetBSD: patch-report.c,v 1.1 2013/07/04 03:41:48 dholland Exp $
Don't print time_t with %lu; it fails on 32-bit netbsd, where time_t is
wider than that.
--- report.c~ 2013-05-13 15:22:54.000000000 +0000
+++ report.c
@@ -343,10 +343,10 @@ void csv_close(time_t now)
if(!ipinfo_no) {
char* fmtinfo = fmt_ipinfo(addr);
if (fmtinfo != NULL) fmtinfo = trim(fmtinfo);
- printf("MTR.%s;%lu;%s;%s;%d;%s;%s;%d", MTR_VERSION, now, "OK", Hostname,
+ printf("MTR.%s;%lld;%s;%s;%d;%s;%s;%d", MTR_VERSION, (long long)now, "OK", Hostname,
at+1, name, fmtinfo, last);
} else {
- printf("MTR.%s;%lu;%s;%s;%d;%s;%d", MTR_VERSION, now, "OK", Hostname,
+ printf("MTR.%s;%lld;%s;%s;%d;%s;%d", MTR_VERSION, (long long)now, "OK", Hostname,
at+1, name, last);
}