Initialise errfp at runtime, unbreaks DragonFly and FreeBSD.

This commit is contained in:
joerg 2005-12-11 20:35:40 +00:00
parent 09b74498d3
commit 4e17beed91
2 changed files with 23 additions and 6 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.5 2005/02/23 20:39:54 agc Exp $
$NetBSD: distinfo,v 1.6 2005/12/11 20:35:40 joerg Exp $
SHA1 (xmmix-1.2.tar.gz) = 9ec44500dccba63ef7a9d50f66acfb6e45d08714
RMD160 (xmmix-1.2.tar.gz) = 05f5ca6811848f0b86a9dc94e6d943a07cda0ba8
@ -7,6 +7,6 @@ SHA1 (patch-aa) = 68a33a91de0e373da4818a26e339d3c87e895b33
SHA1 (patch-ab) = cbdc30e17aa2a857d756b403c0873436e9480129
SHA1 (patch-ac) = 8d68a2de3ee8a094a7f84ecb1d387bc22ca82bbb
SHA1 (patch-ba) = 8092fcec3c39060da476f2ad2d018e8e0a8aa028
SHA1 (patch-bb) = ce6a804c52dac8c65661d3a17c5cccbb4b2957d0
SHA1 (patch-bb) = 4c468f8b42150b2dc9d21176863be168428b8885
SHA1 (patch-bc) = 1c77a45c31ee023a3b0e7c9a720c1d9d2d2fb75e
SHA1 (patch-bd) = d4209f5de96ef45d47aec2c28ccfe099c0c13fdf

View file

@ -1,8 +1,25 @@
$NetBSD: patch-bb,v 1.1 2000/11/02 14:24:32 mjl Exp $
$NetBSD: patch-bb,v 1.2 2005/12/11 20:35:41 joerg Exp $
--- ../xmmix-1.2/main.c Thu Nov 7 17:01:43 1996
+++ ./main.c Mon Aug 11 23:12:51 1997
@@ -159,7 +159,7 @@
--- main.c.orig 1996-11-07 16:01:43.000000000 +0000
+++ main.c
@@ -33,7 +33,7 @@ static char *_main_c_ident_ = "@(#)main.
bool_t exit_flag; /* Flag indicating end of application */
appdata_t app_data; /* Options data */
widgets_t widgets; /* Holder of all widgets */
-FILE *errfp = stderr;/* Error message stream */
+FILE *errfp;/* Error message stream */
/***********************
@@ -103,6 +103,7 @@ main(int argc, char **argv)
/* Initialize variables */
exit_flag = FALSE;
+ errfp = stderr;
/* Handle some signals */
signal(SIGINT, onsig);
@@ -159,7 +160,7 @@ main(int argc, char **argv)
post_realize_config(&widgets);
/* Register callback routines */