Fix png update fallout.
This commit is contained in:
parent
22a7398954
commit
4e1af7df19
2 changed files with 15 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.7 2009/12/03 06:33:46 snj Exp $
|
||||
$NetBSD: distinfo,v 1.8 2013/02/26 11:16:19 joerg Exp $
|
||||
|
||||
SHA1 (neverball-1.5.4.tar.gz) = 619c227e1958bd60738f12dbbde9b30c91dd79a7
|
||||
RMD160 (neverball-1.5.4.tar.gz) = f546b5e6c12df1a125976a7e23fa55146480241d
|
||||
Size (neverball-1.5.4.tar.gz) = 26767623 bytes
|
||||
SHA1 (patch-ab) = 15b6864e06d363698c0855af42d0d4f7b010886f
|
||||
SHA1 (patch-share_base__image.c) = c7dd953bec0a8b44e18153c17d66b2cc7169b6d0
|
||||
|
|
13
games/neverball/patches/patch-share_base__image.c
Normal file
13
games/neverball/patches/patch-share_base__image.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-share_base__image.c,v 1.1 2013/02/26 11:16:19 joerg Exp $
|
||||
|
||||
--- share/base_image.c.orig 2013-02-25 20:30:28.000000000 +0000
|
||||
+++ share/base_image.c
|
||||
@@ -94,7 +94,7 @@ static void *image_load_png(const char *
|
||||
default: longjmp(png_jmpbuf(readp), -1);
|
||||
}
|
||||
|
||||
- if (!(bytep = png_malloc(readp, h * png_sizeof(png_bytep))))
|
||||
+ if (!(bytep = png_malloc(readp, h * sizeof(*bytep))))
|
||||
longjmp(png_jmpbuf(readp), -1);
|
||||
|
||||
/* Allocate the final pixel buffer and read pixels there. */
|
Loading…
Reference in a new issue