Fix build on SunOS.

This commit is contained in:
hans 2012-02-16 18:57:49 +00:00
parent 6fb7111e7d
commit 4e429c454b
6 changed files with 43 additions and 4 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.12 2011/04/22 13:43:48 obache Exp $
# $NetBSD: Makefile,v 1.13 2012/02/16 18:57:49 hans Exp $
DISTNAME= jpegpixi-1.1.1
PKGREVISION= 3
@ -15,6 +15,8 @@ PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
USE_PKGLOCALEDIR= yes
LIBS.SunOS+= -lintl
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../mk/jpeg.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.10 2012/01/18 14:32:10 adam Exp $
# $NetBSD: Makefile,v 1.11 2012/02/16 19:00:14 hans Exp $
DISTNAME= avenger-0.8.2
CATEGORIES= mail
@ -21,6 +21,9 @@ CONFIGURE_ARGS+= --with-etcdir=${PKG_SYSCONFDIR}
CONFIGURE_ENV+= BDB_TYPE="${BDB_TYPE}"
PKG_SYSCONFSUBDIR= avenger
LDFLAGS.SunOS+= -lsocket -lnsl
CFLAGS.SunOS+= -DDBM_RDONLY=O_RDONLY
.include "options.mk"
.include "../../mk/bdb.buildlink3.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.5 2012/01/18 14:32:10 adam Exp $
$NetBSD: distinfo,v 1.6 2012/02/16 19:00:14 hans Exp $
SHA1 (avenger-0.8.2.tar.gz) = bd645143289d28fac54eb1943b3f114ea396e205
RMD160 (avenger-0.8.2.tar.gz) = 539b1163fd805e34a432d988c255c92c0fee8963
@ -10,3 +10,4 @@ SHA1 (patch-libasync_ihash.h) = 745cadbcd9778182e0a17afbbd5e84d91572468e
SHA1 (patch-libasync_itree.h) = 52fdac5183e5be5406c1b67c0f97c5552a18a1ec
SHA1 (patch-libasync_qhash.h) = 8bc832dee629cc8e0f7efc25e9011d9883f08e92
SHA1 (patch-libasync_vec.h) = 91a4db8114a6ae8915f29610ab11fafdf4427cde
SHA1 (patch-util_avutil.h) = e7799fc638e9b5e7a888f7108785a3e54ed52540

View file

@ -0,0 +1,18 @@
$NetBSD: patch-util_avutil.h,v 1.1 2012/02/16 19:00:14 hans Exp $
--- util/avutil.h.orig 2008-05-20 20:48:23.000000000 +0200
+++ util/avutil.h 2012-01-27 11:02:13.469861902 +0100
@@ -70,6 +70,13 @@ int clock_gettime (int, struct timespec
# define CLOCK_PROF 2
#endif /* !CLOCK_PROF */
+#ifndef HAVE_INT16
+typedef short int16_t;
+#endif /* !HAVE_INT16 */
+#ifndef HAVE_U_INT16
+typedef unsigned short u_int16_t;
+#endif /* !HAVE_U_INT16 */
+
#ifndef HAVE_INT32_T
typedef int int32_t;
#endif /* !HAVE_INT32_T */

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.78 2012/02/06 10:44:43 drochner Exp $
$NetBSD: distinfo,v 1.79 2012/02/16 19:02:47 hans Exp $
SHA1 (evolution-data-server-2.32.3.tar.bz2) = cbf32c3438c4f1650b35b87007a337ebc1c56cec
RMD160 (evolution-data-server-2.32.3.tar.bz2) = adc8b07aef41a89d16fc426541c12190a3688b8f
@ -7,6 +7,7 @@ SHA1 (patch-aa) = 3b85e844c79edbd9a6dcee5e7819230671e0673e
SHA1 (patch-ab) = fd27fd0a521899be568c843b24d9b6eeeb99a2bb
SHA1 (patch-bd) = 8df85b9ab7ae71558fb939565e944b614de628bb
SHA1 (patch-ca) = e879d29105997045e1293fe627ec55a05e5ba88d
SHA1 (patch-calendar_libegdbus_Makefile.in) = ac5aabae5160967c498f12c0f29be3e206e03622
SHA1 (patch-cc) = a59bbc664a96f467888cae89cb00eb9a9033a925
SHA1 (patch-cd) = 6e366e65e68cd0c5a8eafa67c7f9152c6521de12
SHA1 (patch-ce) = 1da2a3773ff89319bc79bbb7375e8259f0be89e4

View file

@ -0,0 +1,14 @@
$NetBSD: patch-calendar_libegdbus_Makefile.in,v 1.1 2012/02/16 19:02:48 hans Exp $
--- calendar/libegdbus/Makefile.in.orig 2011-04-21 21:41:20.000000000 +0200
+++ calendar/libegdbus/Makefile.in 2012-01-26 12:39:33.239925972 +0100
@@ -387,9 +387,6 @@ libegdbus_cal_la_SOURCES = \
e-gdbus-marshallers.c \
e-gdbus-typemappers.h
-libegdbus_cal_la_LIBADD = \
- $(GNOME_PLATFORM_LIBS)
-
libegdbus_cal_la_LDFLAGS = $(NO_UNDEFINED)
EXTRA_DIST = e-gdbus-marshallers.list
all: all-am