Fixed ISO C90 violation.

This commit is contained in:
rillig 2006-02-14 01:13:32 +00:00
parent 68da0ffdec
commit 4e7f179dff
2 changed files with 25 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.5 2006/02/05 00:18:29 adrianp Exp $
$NetBSD: distinfo,v 1.6 2006/02/14 01:13:32 rillig Exp $
SHA1 (hydra-5.2-src.tar.gz) = 1a05b06030336c252dd4e8a0a048d8d45885f6f1
RMD160 (hydra-5.2-src.tar.gz) = b4a707890cfd07637a2bf12604da8ef26075d44f
@ -8,3 +8,4 @@ SHA1 (patch-ab) = b841c1cb0db99381516add4174a243ac43a6536f
SHA1 (patch-ac) = ade8ea964018dc7034154a35338f50361b5185f8
SHA1 (patch-ad) = 3734123af4511161eee93f624b1b9dd575be0ae7
SHA1 (patch-af) = 90c24ad7df23f2be23d08b646d68c93846c7618b
SHA1 (patch-ag) = b67ce4814866da7b93d376b6afcbcf455b700da2

View file

@ -0,0 +1,23 @@
$NetBSD: patch-ag,v 1.1 2006/02/14 01:13:32 rillig Exp $
gcc warning: ISO C90 forbids declarations intermixed with code.
--- hydra-pcanywhere.c.orig 2005-09-07 21:59:26.000000000 +0200
+++ hydra-pcanywhere.c 2006-02-14 02:11:44.000000000 +0100
@@ -114,6 +114,8 @@ start_pcanywhere(int s, unsigned long in
char *client[4];
int clientsize[4];
+ char *server[5];
+
client[0]="\x00\x00\x00\x00";
clientsize[0]=4;
client[1]="\x6F\x06\xff";
@@ -123,7 +125,6 @@ start_pcanywhere(int s, unsigned long in
client[3]="\x6f\x62\x01\x02\x00\x00\x00";
clientsize[3]=7;
- char *server[5];
server[0]= "nter";
server[1]="\x1B\x61";
server[2]="\0x1B\0x62";