Only include <inttypes.h> if configure said it exists. Add <stdlib.h> to

one place where uintptr_t is needed, for Interix.
This commit is contained in:
tv 2005-10-31 15:33:19 +00:00
parent 09b3ff19a9
commit 4ea12bfa08
3 changed files with 34 additions and 1 deletions

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.2 2005/02/23 20:39:46 agc Exp $
$NetBSD: distinfo,v 1.3 2005/10/31 15:33:19 tv Exp $
SHA1 (goom-2k4-0-src.tar.gz) = 4856b86aadc67676c473a4664c5281bc05df278d
RMD160 (goom-2k4-0-src.tar.gz) = 280c0db57f437b072a49ff80f5bf85d57892af8e
Size (goom-2k4-0-src.tar.gz) = 757058 bytes
SHA1 (patch-aa) = 44b8332db3e7b6ec15fcc7d94d68bd0b884c6e8a
SHA1 (patch-ab) = 7a703e75ad8d9895c28f6579ee80240f1c2d0cfb
SHA1 (patch-ac) = 341a075d8a2b41b522fe313ca13f5ca7c5476f6f

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ab,v 1.1 2005/10/31 15:33:19 tv Exp $
--- src/filters.c.orig 2005-02-07 08:46:41.000000000 -0500
+++ src/filters.c
@@ -18,7 +18,11 @@
#include <stdlib.h>
#include <math.h>
#include <stdio.h>
+#include <stdlib.h>
+
+#if HAVE_INTTYPES_H
#include <inttypes.h>
+#endif
#include "goom_filters.h"
#include "goom_graphic.h"

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ac,v 1.1 2005/10/31 15:33:19 tv Exp $
--- src/goom_core.c.orig 2005-02-07 08:46:41.000000000 -0500
+++ src/goom_core.c
@@ -11,7 +11,10 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
+
+#if HAVE_INTTYPES_H
#include <inttypes.h>
+#endif
#include "goom.h"
#include "goom_tools.h"