Move package to directory for new category "math".
This commit is contained in:
parent
fd16b7e9b1
commit
4eb432ce81
13 changed files with 5 additions and 116 deletions
|
@ -1,31 +0,0 @@
|
|||
# New ports collection makefile for: Numeric Python
|
||||
# Version required: 1.1
|
||||
# Date created: 18 March 1998
|
||||
# Whom: tsarna@endicor.com
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.1 1998/04/10 22:30:41 tron Exp $
|
||||
|
||||
DISTNAME= NumPy-11
|
||||
PKGNAME= py-Numeric-1.1
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= ftp://ftp-icf.llnl.gov/pub/python/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= tsarna@endicor.com
|
||||
|
||||
BUILD_DEPENDS= python:${PORTSDIR}/lang/python
|
||||
RUN_DEPENDS= python:${PORTSDIR}/lang/python
|
||||
|
||||
WRKSRC= ${WRKDIR}/LLNLDistribution/Numerical
|
||||
ALL_TARGET= default
|
||||
|
||||
.if ${MACHINE_ARCH} == "powerpc" || ${MACHINE_ARCH} == "mips" || ${MACHINE_ARCH} == "alpha"
|
||||
IGNORE="Needs dynamic loading"
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
(cd ${WRKSRC}/Lib ; \
|
||||
python -O ${PREFIX}/lib/python1.5/compileall.py . ; \
|
||||
${INSTALL_DATA} *.py *.pyc *.pyo ${PREFIX}/lib/python1.5/site-packages)
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1 +0,0 @@
|
|||
MD5 (NumPy-11.tgz) = c6ad8ba18ea6dd8836e6374bb2dd2a0d
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 1998/04/10 22:30:41 tron Exp $
|
||||
|
||||
Turn LLNL's compile script into a configure script :-)
|
||||
|
||||
-- tsarna@endicor.com, 18 March 1998
|
||||
|
||||
--- ../Tools/compile.py.orig Tue Mar 17 23:28:14 1998
|
||||
+++ ../Tools/compile.py Tue Mar 17 23:28:14 1998
|
||||
@@ -632,7 +632,7 @@
|
||||
|
||||
compileall.compile_dir(".")
|
||||
os.system("make -f Makefile.pre.in boot")
|
||||
- os.system("make")
|
||||
+# os.system("make")
|
||||
|
||||
if sys.platform == 'win32':
|
||||
swig_found = find_swig()
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 1998/04/10 22:30:41 tron Exp $
|
||||
|
||||
The trailing space after the shared line breaks makesetup due to a bug
|
||||
in NetBSD 1.3[.1] /bin/sh. It's fixed in current. See PR#4805 for
|
||||
details.
|
||||
|
||||
-- tsarna@endicor.com, 18 March 1998
|
||||
|
||||
--- Setup.orig Wed Mar 18 01:19:04 1998
|
||||
+++ Setup Wed Mar 18 01:19:04 1998
|
||||
@@ -1,6 +1,6 @@
|
||||
#This file is designed for building a dynamic extension.
|
||||
#See README for detailed build instructions.
|
||||
-*shared*
|
||||
+*shared*
|
||||
|
||||
# The array and ufunc object implementation
|
||||
#[VC50]cpp_options = cpp_options + ' /Tp '
|
|
@ -1 +0,0 @@
|
|||
Adds multidemensional numeric arrays to Python.
|
|
@ -1,3 +0,0 @@
|
|||
NumPy (Numeric Python) is a collection of extension modules to provide
|
||||
high-performance multidimensional numeric arrays to the Python
|
||||
programming language.
|
|
@ -1,36 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 1998/04/10 22:30:41 tron Exp $
|
||||
lib/python1.5/site-packages/_numpymodule.so
|
||||
lib/python1.5/site-packages/multiarraymodule.so
|
||||
lib/python1.5/site-packages/fast_umathmodule.so
|
||||
lib/python1.5/site-packages/umathmodule.so
|
||||
lib/python1.5/site-packages/fftpack.so
|
||||
lib/python1.5/site-packages/lapack_lite.so
|
||||
lib/python1.5/site-packages/ranlib.so
|
||||
lib/python1.5/site-packages/ArrayPrinter.py
|
||||
lib/python1.5/site-packages/ArrayPrinter.pyc
|
||||
lib/python1.5/site-packages/ArrayPrinter.pyo
|
||||
lib/python1.5/site-packages/FFT.py
|
||||
lib/python1.5/site-packages/FFT.pyc
|
||||
lib/python1.5/site-packages/FFT.pyo
|
||||
lib/python1.5/site-packages/LinearAlgebra.py
|
||||
lib/python1.5/site-packages/LinearAlgebra.pyc
|
||||
lib/python1.5/site-packages/LinearAlgebra.pyo
|
||||
lib/python1.5/site-packages/MLab.py
|
||||
lib/python1.5/site-packages/MLab.pyc
|
||||
lib/python1.5/site-packages/MLab.pyo
|
||||
lib/python1.5/site-packages/Matrix.py
|
||||
lib/python1.5/site-packages/Matrix.pyc
|
||||
lib/python1.5/site-packages/Matrix.pyo
|
||||
lib/python1.5/site-packages/Numeric.py
|
||||
lib/python1.5/site-packages/Numeric.pyc
|
||||
lib/python1.5/site-packages/Numeric.pyo
|
||||
lib/python1.5/site-packages/Precision.py
|
||||
lib/python1.5/site-packages/Precision.pyc
|
||||
lib/python1.5/site-packages/Precision.pyo
|
||||
lib/python1.5/site-packages/RandomArray.py
|
||||
lib/python1.5/site-packages/RandomArray.pyc
|
||||
lib/python1.5/site-packages/RandomArray.pyo
|
||||
lib/python1.5/site-packages/UserArray.py
|
||||
lib/python1.5/site-packages/UserArray.pyc
|
||||
lib/python1.5/site-packages/UserArray.pyo
|
||||
@dirrm lib/python1.5/site-packages
|
4
lang/py-Numeric/scripts/configure
vendored
4
lang/py-Numeric/scripts/configure
vendored
|
@ -1,4 +0,0 @@
|
|||
#!/bin/sh
|
||||
# $NetBSD: configure,v 1.1 1998/04/10 22:30:42 tron Exp $
|
||||
|
||||
(cd $WRKSRC; $PREFIX/bin/python ../Tools/compile.py)
|
|
@ -3,7 +3,7 @@
|
|||
# Date created: 18 March 1998
|
||||
# Whom: tsarna@endicor.com
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.1 1998/04/10 22:30:41 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.2 1998/04/12 21:54:37 tron Exp $
|
||||
|
||||
DISTNAME= NumPy-11
|
||||
PKGNAME= py-Numeric-1.1
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-aa,v 1.1 1998/04/10 22:30:41 tron Exp $
|
||||
$NetBSD: patch-aa,v 1.2 1998/04/12 21:56:05 tron Exp $
|
||||
|
||||
Turn LLNL's compile script into a configure script :-)
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ab,v 1.1 1998/04/10 22:30:41 tron Exp $
|
||||
$NetBSD: patch-ab,v 1.2 1998/04/12 21:56:05 tron Exp $
|
||||
|
||||
The trailing space after the shared line breaks makesetup due to a bug
|
||||
in NetBSD 1.3[.1] /bin/sh. It's fixed in current. See PR#4805 for
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 1998/04/10 22:30:41 tron Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 1998/04/12 21:56:05 tron Exp $
|
||||
lib/python1.5/site-packages/_numpymodule.so
|
||||
lib/python1.5/site-packages/multiarraymodule.so
|
||||
lib/python1.5/site-packages/fast_umathmodule.so
|
||||
|
|
2
math/py-Numeric/scripts/configure
vendored
2
math/py-Numeric/scripts/configure
vendored
|
@ -1,4 +1,4 @@
|
|||
#!/bin/sh
|
||||
# $NetBSD: configure,v 1.1 1998/04/10 22:30:42 tron Exp $
|
||||
# $NetBSD: configure,v 1.2 1998/04/12 21:56:05 tron Exp $
|
||||
|
||||
(cd $WRKSRC; $PREFIX/bin/python ../Tools/compile.py)
|
||||
|
|
Loading…
Reference in a new issue