misc/emacspeak: import emacspeak-59.0

Packaged for wip by adr.

Emacspeak is a speech interface that allows visually impaired users
to interact independently and efficiently with the computer. Audio
formatting --a technique pioneered by AsTeR-- and full support for
W3C's Aural CSS (ACSS) allows Emacspeak to produce rich aural
presentations of electronic information. By seamlessly blending
all aspects of the Internet such as Web-surfing and messaging,
Emacspeak speech-enables local and remote information via a consistent
and well-integrated user interface. Available free of cost on the
Internet, Emacspeak has dramatically changed how the author and
thousands of blind and visually impaired users around the world
interact with the personal computer and the Internet. A rich suite
of task-oriented tools provides efficient speech-enabled access to
the audio desktop and evolving semantic WWW. When combined with
Linux running on low-cost PC hardware, Emacspeak/Linux provides a
reliable, stable speech-friendly solution that opens up the Internet
to visually impaired users around the world.
This commit is contained in:
wiz 2024-03-13 05:48:35 +00:00
parent 183ea41e37
commit 4ec9fcc833
8 changed files with 1258 additions and 0 deletions

16
misc/emacspeak/DESCR Normal file
View File

@ -0,0 +1,16 @@
Emacspeak is a speech interface that allows visually impaired users
to interact independently and efficiently with the computer. Audio
formatting --a technique pioneered by AsTeR-- and full support for
W3C's Aural CSS (ACSS) allows Emacspeak to produce rich aural
presentations of electronic information. By seamlessly blending
all aspects of the Internet such as Web-surfing and messaging,
Emacspeak speech-enables local and remote information via a consistent
and well-integrated user interface. Available free of cost on the
Internet, Emacspeak has dramatically changed how the author and
thousands of blind and visually impaired users around the world
interact with the personal computer and the Internet. A rich suite
of task-oriented tools provides efficient speech-enabled access to
the audio desktop and evolving semantic WWW. When combined with
Linux running on low-cost PC hardware, Emacspeak/Linux provides a
reliable, stable speech-friendly solution that opens up the Internet
to visually impaired users around the world.

10
misc/emacspeak/MESSAGE Normal file
View File

@ -0,0 +1,10 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1 2024/03/13 05:48:35 wiz Exp $
Add (load-library "emacspeak-setup.el") at the beginning of your
.emacs to activate Emacspeak in every Emacs execution, or use the -l
option when executing Emacs.
If you can't hear the auditory icons and other sound effects, set the
Emacs variable emacspeak-play-program and the environment variable
EMACSPEAK_PLAY to the path of your audio player of choice.
===========================================================================

75
misc/emacspeak/Makefile Normal file
View File

@ -0,0 +1,75 @@
# $NetBSD: Makefile,v 1.1 2024/03/13 05:48:35 wiz Exp $
DISTNAME= emacspeak-59.0
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_GITHUB:=tvraman/}
GITHUB_PROJECT= emacspeak
GITHUB_RELEASE= 59
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://emacspeak.sourceforge.net/
COMMENT= Speech interface for emacs
LICENSE= gnu-gpl-v2
USE_TOOLS= gmake perl bash pax
REPLACE_PERL= etc/*
REPLACE_BASH= bash-utils/* etc/*
EMACS_VERSIONS_ACCEPTED= emacs29 emacs29nox
# More than shebang, cant' use REPLACE_INTERPRETER
SUBST_CLASSES+= fix-tclsh
SUBST_STAGE.fix-tclsh= pre-configure
SUBST_MESSAGE.fix-tclsh= Fixing tclsh path
SUBST_FILES.fix-tclsh= servers/*
SUBST_SED.fix-tclsh= -e 's,/usr/bin/tclsh,${PREFIX}/bin/tclsh,'
REPLACE_PYTHON+= etc/*streamtheworld.py
REPLACE_PYTHON+= servers/mac
# Fix sox path
SUBST_CLASSES+= fix-sox-path
SUBST_STAGE.fix-sox-path= pre-configure
SUBST_MESSAGE.fix-sox-path= Fixing sox path
SUBST_FILES.fix-sox-path= servers/tts-lib.tcl
SUBST_FILES.fix-sox-path+= lisp/emacspeak-sounds.el
SUBST_SED.fix-sox-path= -E -e 's,/usr/bin/(sox|play),${PREFIX}/bin/\1,'
USE_LANGUAGES+= c c++
BUILD_TARGET= all espeak
post-build:
cd ${WRKSRC} && \
for i in bash-utils/remote \
etc/COPYRIGHT \
etc/Makefile \
etc/forms/apache-clf.el \
etc/forms/messages.el \
etc/remote.txt \
media/welcome.ra \
xsl/README; do \
${CHMOD} 644 "$$i"; \
done; \
for i in servers/native-espeak/Makefile.orig \
lisp/emacspeak-bookshare.el.orig \
servers/tts-lib.tcl.orig; do \
rm "$$i"; \
done
INSTALLATION_DIRS= ${EMACS_LISPPREFIX}/emacspeak
do-install:
cd ${WRKSRC} && pax -rw * ${DESTDIR}${EMACS_LISPPREFIX}/emacspeak
.include "../../lang/tcl/buildlink3.mk"
.include "../../lang/tclx/buildlink3.mk"
.include "../../x11/tk/buildlink3.mk"
.include "../../audio/espeak-ng/buildlink3.mk"
.include "../../audio/sox/buildlink3.mk"
.include "../../editors/emacs/modules.mk"
.include "../../lang/python/tool.mk"
.include "../../lang/python/application.mk"
.include "../../mk/bsd.pkg.mk"

1086
misc/emacspeak/PLIST Normal file

File diff suppressed because it is too large Load Diff

8
misc/emacspeak/distinfo Normal file
View File

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1 2024/03/13 05:48:35 wiz Exp $
BLAKE2s (emacspeak-59.0.tar.bz2) = 1c82c51457e2b77215ae872def4fdc52318e0b701ac937a3c7bc0afb386341c5
SHA512 (emacspeak-59.0.tar.bz2) = 42dda7d09df43611081b9ddaadd23db09bd619439d6d9a9b034f8cf87a93f51d29dc6f878e2dd4434ac6f84dade1e6516b042378521f701c58eeaa5d9719592e
Size (emacspeak-59.0.tar.bz2) = 7984386 bytes
SHA1 (patch-lisp_emacspeak-bookshare.el) = 12778e71cc620d0ca7668b2c1f2cd204c05a4bd3
SHA1 (patch-servers_native-espeak_Makefile) = 12e8485b79f8c008ae83bc29ef094d29d2efdd85
SHA1 (patch-servers_tts-lib.tcl) = 5307ec48cb0d5d13afe8b0a21a2545cb7fda743a

View File

@ -0,0 +1,15 @@
$NetBSD: patch-lisp_emacspeak-bookshare.el,v 1.1 2024/03/13 05:48:36 wiz Exp $
* Fix references to the build directory.
--- lisp/emacspeak-bookshare.el.orig 2022-04-18 20:56:41.000000000 +0000
+++ lisp/emacspeak-bookshare.el
@@ -115,7 +115,7 @@ See http://developer.bookshare.org/docs
"Bookshare user Id.")
(defcustom emacspeak-bookshare-directory
- (eval-when-compile (expand-file-name "~/books/book-share"))
+ (file-name-as-directory "~/books/book-share")
"Customize this to the root of where books are organized."
:type 'directory
:group 'emacspeak-bookshare)

View File

@ -0,0 +1,15 @@
$NetBSD: patch-servers_native-espeak_Makefile,v 1.1 2024/03/13 05:48:36 wiz Exp $
* Fix tcl version.
--- servers/native-espeak/Makefile.orig 2022-04-18 20:56:41.000000000 +0000
+++ servers/native-espeak/Makefile
@@ -14,7 +14,7 @@ ifeq ($(shell uname -s), Darwin)
LIBS= -framework tcl -lespeak-ng
TTS=tclespeak.dylib
else
- TCL_VERSION = 8.6
+ TCL_VERSION = 86
TCL_INCLUDE= /usr/include/tcl$(TCL_VERSION)
LIBS= -ltcl$(TCL_VERSION) -lespeak-ng
TTS=tclespeak.so

View File

@ -0,0 +1,33 @@
$NetBSD: patch-servers_tts-lib.tcl,v 1.1 2024/03/13 05:48:36 wiz Exp $
* Use first EMACSPEAK_PLAY if set.
--- servers/tts-lib.tcl.orig 2024-01-29 07:35:28.692559948 +0000
+++ servers/tts-lib.tcl
@@ -356,17 +356,19 @@ proc tts_initialize {} {
set tts(punctuations) some
set queue(-1) ""
set backup(-1) ""
+
#play program
-
- if { [info exists ::env(PULSE_SERVER)] || [file exists /usr/bin/paplay]} {
- set tts(play) "/usr/bin/paplay"
-} else {
- set tts(play) "/usr/bin/aplay -q"
-}
#if env variable EMACSPEAK_PLAY is set, use it;
if {[info exists env(EMACSPEAK_PLAY)] } {
set tts(play) $env(EMACSPEAK_PLAY)
- }
+ } else {
+ if { [info exists ::env(PULSE_SERVER)] || [file exists /usr/bin/paplay]} {
+ set tts(play) "/usr/bin/paplay"
+ } else {
+ set tts(play) "/usr/bin/aplay -q"
+ }
+ }
+
#optional debuggin output
if {[info exists env(DTK_DEBUG)] } {
set tts(debug) 1