Fix various C++ issues.

This commit is contained in:
joerg 2012-05-04 16:27:59 +00:00
parent 51591ca87e
commit 4ee963698e
8 changed files with 131 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.63 2012/02/16 19:15:12 hans Exp $
$NetBSD: distinfo,v 1.64 2012/05/04 16:27:59 joerg Exp $
SHA1 (kdepim-3.5.10.tar.bz2) = 537da60fe3564ecc0ed2802e744fbf96386909a9
RMD160 (kdepim-3.5.10.tar.bz2) = 52a834dc8eb377d397404a16a09c8a59b568b305
@ -17,3 +17,10 @@ SHA1 (patch-as) = bfcde6d85ca844ebe4cff93ca0ed42deb2cefbff
SHA1 (patch-at) = 670b61b45eed92c854808991e6241f29bee47554
SHA1 (patch-configure) = c25992299b78b3c45f9f5f3dfcbd5f92a4df89ac
SHA1 (patch-kmail_editorwatcher.cpp) = e66a40ea73810c59d23f52f6953c09b85d4e1deb
SHA1 (patch-kmail_imapaccountbase.h) = 362d8445597c869b9ee8366a4b9a698773579512
SHA1 (patch-kmail_kmsystemtray.cpp) = 1d658e1e1ee3d17d0f38955e5399505d61fdb402
SHA1 (patch-kmail_networkaccount.h) = bac18ee4994dff91f86b3a29b57cd35c21f96cca
SHA1 (patch-korganizer_korgac_alarmdialog.cpp) = 5b85966c115fad9bbc3068d4eb5e5b0723188cab
SHA1 (patch-kpilot_lib_pluginfactory.h) = 3496e8b57e50a4781afd542f829b19ae911e5b93
SHA1 (patch-libkcal_listbase.h) = c012336ca7de42c2f135b5d866ba05b543be4576
SHA1 (patch-libkpimidentities_identity.h) = ea5eb566d0d174eec09ce4ee0e523c3a76e31357

View file

@ -0,0 +1,20 @@
$NetBSD: patch-kmail_imapaccountbase.h,v 1.1 2012/05/04 16:27:59 joerg Exp $
--- kmail/imapaccountbase.h.orig 2012-04-27 16:28:08.000000000 +0000
+++ kmail/imapaccountbase.h
@@ -32,7 +32,6 @@
#include <qguardedptr.h>
#include <kio/global.h>
-class AccountManager;
class KMFolder;
class KConfig/*Base*/;
class KMMessagePart;
@@ -50,6 +49,7 @@ namespace KPIM {
}
namespace KMail {
+ class AccountManager;
struct ACLListEntry;
struct QuotaInfo;
typedef QValueVector<KMail::ACLListEntry> ACLList;

View file

@ -0,0 +1,18 @@
$NetBSD: patch-kmail_kmsystemtray.cpp,v 1.1 2012/05/04 16:27:59 joerg Exp $
--- kmail/kmsystemtray.cpp.orig 2012-04-27 16:31:37.000000000 +0000
+++ kmail/kmsystemtray.cpp
@@ -464,10 +464,10 @@ void KMSystemTray::updateNewMessageNotif
void KMSystemTray::updateNewMessages()
{
- for ( QMap<QGuardedPtr<KMFolder>, bool>::Iterator it = mPendingUpdates.begin();
- it != mPendingUpdates.end(); ++it)
+ for ( QMap<QGuardedPtr<KMFolder>, bool>::Iterator it2 = mPendingUpdates.begin();
+ it2 != mPendingUpdates.end(); ++it2)
{
- KMFolder *fldr = it.key();
+ KMFolder *fldr = it2.key();
if ( !fldr ) // deleted folder
continue;

View file

@ -0,0 +1,20 @@
$NetBSD: patch-kmail_networkaccount.h,v 1.1 2012/05/04 16:27:59 joerg Exp $
--- kmail/networkaccount.h.orig 2012-04-27 16:26:50.000000000 +0000
+++ kmail/networkaccount.h
@@ -33,7 +33,6 @@
#include <qstring.h>
-class AccountManager;
class KConfig/*Base*/;
class KURL;
namespace KIO {
@@ -42,6 +41,7 @@ namespace KIO {
}
namespace KMail {
+ class AccountManager;
class NetworkAccount : public KMAccount {
Q_OBJECT

View file

@ -0,0 +1,17 @@
$NetBSD: patch-korganizer_korgac_alarmdialog.cpp,v 1.1 2012/05/04 16:27:59 joerg Exp $
--- korganizer/korgac/alarmdialog.cpp.orig 2012-04-27 16:49:30.000000000 +0000
+++ korganizer/korgac/alarmdialog.cpp
@@ -324,9 +324,9 @@ void AlarmDialog::eventNotification()
found = true;
item->mNotified = true;
Alarm::List alarms = item->mIncidence->alarms();
- Alarm::List::ConstIterator it;
- for ( it = alarms.begin(); it != alarms.end(); ++it ) {
- Alarm *alarm = *it;
+ Alarm::List::ConstIterator it2;
+ for ( it2 = alarms.begin(); it2 != alarms.end(); ++it2 ) {
+ Alarm *alarm = *it2;
// FIXME: Check whether this should be done for all multiple alarms
if (alarm->type() == Alarm::Procedure) {
// FIXME: Add a message box asking whether the procedure should really be executed

View file

@ -0,0 +1,21 @@
$NetBSD: patch-kpilot_lib_pluginfactory.h,v 1.1 2012/05/04 16:27:59 joerg Exp $
--- kpilot/lib/pluginfactory.h.orig 2012-04-27 15:41:25.000000000 +0000
+++ kpilot/lib/pluginfactory.h
@@ -31,15 +31,12 @@
#include <kdebug.h>
#include <klibloader.h>
+#include <kpilotlink.h>
#include "options.h"
/** @file Defines a template class for factories for KPilot's conduits. */
-class KPilotLink;
-
-
-
/** Template class that defines a conduit's factory. */
template <class Widget, class Action> class ConduitFactory : public KLibFactory

View file

@ -0,0 +1,13 @@
$NetBSD: patch-libkcal_listbase.h,v 1.1 2012/05/04 16:27:59 joerg Exp $
--- libkcal/listbase.h.orig 2012-04-27 15:32:46.000000000 +0000
+++ libkcal/listbase.h
@@ -67,7 +67,7 @@ class ListBase : public QValueList<T *>
bool removeRef( T *t )
{
- QValueListIterator<T *> it = find( t );
+ QValueListIterator<T *> it = this->find( t );
if ( it == QValueList<T*>::end() ) {
return false;
} else {

View file

@ -0,0 +1,14 @@
$NetBSD: patch-libkpimidentities_identity.h,v 1.1 2012/05/04 16:27:59 joerg Exp $
--- libkpimidentities/identity.h.orig 2012-04-27 17:36:37.000000000 +0000
+++ libkpimidentities/identity.h
@@ -19,6 +19,9 @@ class KProcess;
namespace KPIM {
class Identity;
class Signature;
+
+ QDataStream &operator<<( QDataStream & stream, const Signature & sig );
+ QDataStream &operator>>( QDataStream & stream, Signature & sig );
}
class KConfigBase;
class IdentityList;