Apply patch from Harry Waddell in PR 23289 to chill in gcc 2.95.3, to

fix a build error when using gcc 3.  Also bumps PKGREVISION.
This commit is contained in:
ben 2003-12-18 15:44:24 +00:00
parent de7122ee8e
commit 4f12f860b5
4 changed files with 21 additions and 4 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: CHANGES,v 1.4180 2003/12/18 15:12:34 adam Exp $
$NetBSD: CHANGES,v 1.4181 2003/12/18 15:44:24 ben Exp $
Changes to the packages collection and infrastructure in 2003:
@ -5234,3 +5234,4 @@ Changes to the packages collection and infrastructure in 2003:
Updated librsvg2 to 2.5.0 [adam 2003-12-18]
Updated eog2 to 2.5.1 [adam 2003-12-18]
Updated gimageview to 0.2.24nb4 [adam 2003-12-18]
Updated gcc to 2.95.3nb5 [ben 2003-12-18]

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.72 2003/08/09 10:59:08 seb Exp $
# $NetBSD: Makefile,v 1.73 2003/12/18 15:44:24 ben Exp $
DISTNAME= gcc-2.95.3
PKGREVISION= 4
PKGREVISION= 5
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU:=gcc/}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.21 2003/11/25 22:35:14 dmcmahill Exp $
$NetBSD: distinfo,v 1.22 2003/12/18 15:44:24 ben Exp $
SHA1 (gcc-2.95.3.tar.gz) = 535d27038d161c0e7c2662702e11a48aa97ef622
Size (gcc-2.95.3.tar.gz) = 12911721 bytes
@ -11,3 +11,4 @@ SHA1 (patch-ad) = 2fb8cda55220bd202a4b7948277d00f293718caf
SHA1 (patch-ae) = b9721d3e89a93736b926e1efcfb9d0fb4904277f
SHA1 (patch-af) = 72d27bfecb2633a1f184cfe9cc8b1194c0d57dfe
SHA1 (patch-ag) = bb4d84561d20d2379a71a442b8711b2c54cf4bf2
SHA1 (patch-ah) = 777b4c19c7d86007c69ec9b8c157c73294695241

15
lang/gcc/patches/patch-ah Normal file
View file

@ -0,0 +1,15 @@
$NetBSD: patch-ah,v 1.8 2003/12/18 15:44:24 ben Exp $
--- gcc/ch/loop.c.orig 1999-01-11 05:17:29.000000000 -0800
+++ gcc/ch/loop.c
@@ -318,8 +318,8 @@ the 'increment_temps' step must incremen
(associated with all iterators).
NOTE: Z.200, section 10.1 says that a block is ...
- "the actions statement list in a do action, including any
- loop counter and while control". This means that an exp-
+ ``the actions statement list in a do action, including any
+ loop counter and while control''. This means that an exp-
ression in a WHILE control can include references to the
loop counters created for the loop''s exclusive use.
Example: