Set X11 fonts more correctly.
Use X11BASE to set X11 fonts and add the TrueType directory used on solaris.
This commit is contained in:
parent
ecb150061f
commit
4f5b30f73e
6 changed files with 21 additions and 14 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.105 2019/09/05 08:07:25 nros Exp $
|
||||
# $NetBSD: Makefile,v 1.106 2019/09/10 16:17:13 nros Exp $
|
||||
|
||||
DISTNAME= texmaker-5.0.3
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= http://www.xm1math.net/texmaker/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -26,8 +27,11 @@ do-configure:
|
|||
|
||||
pre-configure:
|
||||
${CP} ${FILESDIR}/fxge_pkgsrcfonts.inc ${WRKSRC}/pdfium/core/fxge
|
||||
${CP} ${FILESDIR}/fxge_x11fonts.inc ${WRKSRC}/pdfium/core/fxge
|
||||
${CP} ${FILESDIR}/fgas_stdfontmgr_pkgsrcfonts.inc \
|
||||
${WRKSRC}/pdfium/xfa/fgas/font
|
||||
${CP} ${FILESDIR}/fgas_stdfontmgr_x11fonts.inc \
|
||||
${WRKSRC}/pdfium/xfa/fgas/font
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.14 2019/09/05 08:07:25 nros Exp $
|
||||
$NetBSD: distinfo,v 1.15 2019/09/10 16:17:13 nros Exp $
|
||||
|
||||
SHA1 (texmaker-5.0.3.tar.bz2) = 61900975f1d4cf420a6d2c309f9de875789f6089
|
||||
RMD160 (texmaker-5.0.3.tar.bz2) = 2e5c1eaccec0f461aa66e80a6bd8cce0b9a8ccc4
|
||||
|
@ -10,9 +10,9 @@ SHA1 (patch-latexhighlighter.h) = 7170f4001a8d383430ecf8bb1f95a6d1f262e6cc
|
|||
SHA1 (patch-pdfium_core_fxcodec_codec_fx__codec__png.cpp) = 0bac4d8e6a887af2b13e27fa4649f9e9c0996c81
|
||||
SHA1 (patch-pdfium_core_fxcrt_include_fx__system.h) = 6f435b5df9754c3f0056751ec17d9ac0a726d953
|
||||
SHA1 (patch-pdfium_core_fxge_apple_fx__mac__imp.cpp) = 32f75b09e3336206ccc317df2d2ae6448808b996
|
||||
SHA1 (patch-pdfium_core_fxge_ge_fx__ge__linux.cpp) = 12678056ff0d05e06eb42a13dc0a5b069f378874
|
||||
SHA1 (patch-pdfium_core_fxge_ge_fx__ge__linux.cpp) = 40470e35f0b5fb7ee4ec5c49d40752060486513e
|
||||
SHA1 (patch-pdfium_third__party_libopenjpeg20_opj__malloc.h) = aef984a63025c8d386f2230fbc8d438dc6e1a03e
|
||||
SHA1 (patch-pdfium_xfa_fgas_font_fgas__stdfontmgr.cpp) = e1c75bc0cfb3a606ca9ce826fc3cd5032abe334c
|
||||
SHA1 (patch-pdfium_xfa_fgas_font_fgas__stdfontmgr.cpp) = aae2d9aeccb631f429c38c6f7a45205dbed1bf6d
|
||||
SHA1 (patch-spellerdialog.h) = f98ca3305e8dd8ba1c65bb32e21d965f536094ed
|
||||
SHA1 (patch-texmaker.h) = b418f9b515acbe3960e78bf984ca9c7f8549359a
|
||||
SHA1 (patch-texmaker.pro) = 7f20deec767057ad4d3e6a0cda6fab483b6656c0
|
||||
|
|
3
editors/texmaker/files/fgas_stdfontmgr_x11fonts.inc
Normal file
3
editors/texmaker/files/fgas_stdfontmgr_x11fonts.inc
Normal file
|
@ -0,0 +1,3 @@
|
|||
// $NetBSD: fgas_stdfontmgr_x11fonts.inc,v 1.1 2019/09/10 16:17:13 nros Exp $
|
||||
"@X11BASE@/lib/X11/fonts/Type1","@X11BASE@/lib/X11/fonts/TTF",
|
||||
"@X11BASE@/lib/X11/fonts/TrueType",
|
4
editors/texmaker/files/fxge_x11fonts.inc
Normal file
4
editors/texmaker/files/fxge_x11fonts.inc
Normal file
|
@ -0,0 +1,4 @@
|
|||
// $NetBSD: fxge_x11fonts.inc,v 1.1 2019/09/10 16:17:13 nros Exp $
|
||||
pInfo->AddPath("@X11BASE@/lib/X11/fonts/Type1");
|
||||
pInfo->AddPath("@X11BASE@/lib/X11/fonts/TTF");
|
||||
pInfo->AddPath("@X11BASE@/lib/X11/fonts/TrueType");
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-pdfium_core_fxge_ge_fx__ge__linux.cpp,v 1.1 2019/09/05 08:07:25 nros Exp $
|
||||
$NetBSD: patch-pdfium_core_fxge_ge_fx__ge__linux.cpp,v 1.2 2019/09/10 16:17:13 nros Exp $
|
||||
* Add X11 and pkgsrc font paths
|
||||
--- pdfium/core/fxge/ge/fx_ge_linux.cpp.orig 2017-04-16 14:53:52.000000000 +0000
|
||||
+++ pdfium/core/fxge/ge/fx_ge_linux.cpp
|
||||
|
@ -7,14 +7,11 @@ $NetBSD: patch-pdfium_core_fxge_ge_fx__ge__linux.cpp,v 1.1 2019/09/05 08:07:25 n
|
|||
// Copyright 2014 PDFium Authors. All rights reserved.
|
||||
// Use of this source code is governed by a BSD-style license that can be
|
||||
// found in the LICENSE file.
|
||||
@@ -132,6 +133,11 @@ std::unique_ptr<IFX_SystemFontInfo> IFX_
|
||||
@@ -132,6 +133,8 @@ std::unique_ptr<IFX_SystemFontInfo> IFX_
|
||||
pInfo->AddPath("/usr/share/X11/fonts/Type1");
|
||||
pInfo->AddPath("/usr/share/X11/fonts/TTF");
|
||||
pInfo->AddPath("/usr/local/share/fonts");
|
||||
+ pInfo->AddPath("/usr/X11R7/lib/X11/fonts/Type1");
|
||||
+ pInfo->AddPath("/usr/X11R7/lib/X11/fonts/TTF");
|
||||
+ pInfo->AddPath("/usr/X11R6/lib/X11/fonts/Type1");
|
||||
+ pInfo->AddPath("/usr/X11R6/lib/X11/fonts/TTF");
|
||||
+#include "../fxge_x11fonts.inc"
|
||||
+#include "../fxge_pkgsrcfonts.inc"
|
||||
}
|
||||
return std::unique_ptr<IFX_SystemFontInfo>(pInfo);
|
||||
|
|
|
@ -1,13 +1,12 @@
|
|||
$NetBSD: patch-pdfium_xfa_fgas_font_fgas__stdfontmgr.cpp,v 1.1 2019/09/05 08:07:25 nros Exp $
|
||||
$NetBSD: patch-pdfium_xfa_fgas_font_fgas__stdfontmgr.cpp,v 1.2 2019/09/10 16:17:13 nros Exp $
|
||||
* add X11 and pkgsrc font paths
|
||||
--- pdfium/xfa/fgas/font/fgas_stdfontmgr.cpp.orig 2017-04-16 14:53:52.000000000 +0000
|
||||
+++ pdfium/xfa/fgas/font/fgas_stdfontmgr.cpp
|
||||
@@ -466,8 +466,12 @@ const FX_CHAR* g_FontFolders[] = {
|
||||
@@ -466,8 +466,11 @@ const FX_CHAR* g_FontFolders[] = {
|
||||
#if _FXM_PLATFORM_ == _FXM_PLATFORM_LINUX_
|
||||
"/usr/share/fonts", "/usr/share/X11/fonts/Type1",
|
||||
"/usr/share/X11/fonts/TTF", "/usr/local/share/fonts",
|
||||
+ "/usr/X11R7/lib/X11/fonts/Type1", "/usr/X11R7/lib/X11/fonts/TTF",
|
||||
+ "/usr/X11R6/lib/X11/fonts/Type1", "/usr/X11R6/lib/X11/fonts/TTF",
|
||||
+#include "fgas_stdfontmgr_x11fonts.inc"
|
||||
+#include "fgas_stdfontmgr_pkgsrcfonts.inc"
|
||||
#elif _FXM_PLATFORM_ == _FXM_PLATFORM_APPLE_
|
||||
"~/Library/Fonts", "/Library/Fonts", "/System/Library/Fonts",
|
||||
|
|
Loading…
Reference in a new issue