libidn2: update to 2.3.7.

* Noteworthy changes in release 2.3.7 (2024-01-27) [stable]

** Really include tests/standalone.sh in tarball.

* Noteworthy changes in release 2.3.6 (2024-01-27) [stable]

** Bump libtool version numbers to reflect API/ABI addition.

** Include tests/standalone.sh in tarball.

* Noteworthy changes in release 2.3.5 (2024-01-27) [stable]

** Declaration of future API/ABI backwards compatibility stability.
GNU libc dlopen libidn2 and use the name libidn2.so.0 for this.  We
believe that it will be too challenging to ever do hard ABI break that
for normal libraries is justified to remove deprecated APIs.  Thus we
decided that we will support the current ABI for a long time.  Of
course, if really convincing arguments for doing a ABI break appears
in the future we may re-consider, but take this as a declaration of
intent of will and that future ABI breaks should be discussed and
co-ordinated with the glibc team first.

** Add public APIs for raw Punycode encoding/decoding.
Normal applications rarely need this, but it cleans up the code and
allow for external testing of the APIs, and resolve
<https://gitlab.com/libidn/libidn2/-/issues/80> due to earlier use of
weak symbols for internal symbols _idn2_punycode_encode and
_idn2_punycode_decode.  We will support these internal symbols for
backwards compatibility.  This allows a clean migration path for code
that is still using the internal names.

** Bump required gettext version to 0.19.8 for musl-libc.
Reported by Helmut Grohne in
<https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=999510>.

** Un-deprecate idn2_to_ascii_4i and make it NUL terminate output.
The API idn2_to_ascii_4i was deprecated in version 2.1.1 released in
2019-02-08.  In that release, the API was also modified to not
NUL-terminate the output.  That is contrary to the old libidn2
behaviour, the behaviour of libidn's API idna_to_ascii_4i, and the API
documentation for the function.  Since we are not likely to ever break
backwards API/ABI compatibility in libidn2, and the deprecated gaurds
leads to some trouble (see report in
<https://gitlab.com/libidn/libidn2/-/merge_requests/93>) we decided to
un-deprecate this function, as supporting it is not costly and the
majority of code that cares about conformance has likely been
modified.  This will fix the error code and NUL termination report by
Yegor Bychin in <https://gitlab.com/libidn/libidn2/-/issues/100>.  We
still encourage you to use the replacement API/ABI idn2_to_ascii_4i2
instead, when appropriate.

** Compiler warning improvements.
As before, compiler warnings are enabled by default.  You may disable
them using ./configure --disable-gcc-warnings or turn them into fatal
errors using ./configure --enable-gcc-warnings=error to add -Werror
and sensible -Wno-error='s.  Based on gnulib's manywarnings, see
<https://www.gnu.org/software/gnulib//manual/html_node/manywarnings.html>.

** tests: Added script tests/standalone.sh suitable for integrators.
The main purpose is to test a system-installed libidn2 library and
idn2 tool, suitable for distributor checking (a'la Debian's
autopkgtest/debci).  It may also be used to test a newly built libidn2
outside the usual 'make check' infrastructure.  To check that your
system libidn2 library and idn2 tool is working, invoke the script
with `srcdir` as an environment variable indicating where it can be
find the source code for libidn2's tests/ directory (it will use the
directory name where the script is by default):

tests/standalone.sh

If your system libidn2 is too old to pass certain tests, disable them
using STANDALONE_DISABLE like this:

STANDALONE_DISABLE='*punycode*' tests/standalone.sh

See the script for more parameters.  If the libidn2 under testing is
too old and has known bugs, that should cause tests to fail, which is
intentional.

** Various minor build fixes and translation updates.

** API and ABI is backwards compatible with the previous version.
idn2_punycode_decode: ADD.
idn2_punycode_encode: ADD.
This commit is contained in:
wiz 2024-02-10 16:39:00 +00:00
parent 77a0661703
commit 4f63e494c0
5 changed files with 8 additions and 46 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.17 2023/11/07 13:19:47 nia Exp $
# $NetBSD: Makefile,v 1.18 2024/02/10 16:39:00 wiz Exp $
DISTNAME= libidn2-2.3.4
DISTNAME= libidn2-2.3.7
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU:=libidn/}

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.7 2022/10/30 11:17:47 wiz Exp $
@comment $NetBSD: PLIST,v 1.8 2024/02/10 16:39:00 wiz Exp $
bin/idn2
include/idn2.h
info/libidn2.info
@ -27,6 +27,7 @@ man/man3/idn2_to_unicode_lzlz.3
share/gtk-doc/html/libidn2/api-index-0.1.html
share/gtk-doc/html/libidn2/api-index-2.0.0.html
share/gtk-doc/html/libidn2/api-index-2.1.1.html
share/gtk-doc/html/libidn2/api-index-2.3.5.html
share/gtk-doc/html/libidn2/api-index-deprecated.html
share/gtk-doc/html/libidn2/api-index-full.html
share/gtk-doc/html/libidn2/home.png

View File

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.14 2023/06/11 00:41:07 schmonz Exp $
$NetBSD: distinfo,v 1.15 2024/02/10 16:39:00 wiz Exp $
BLAKE2s (libidn2-2.3.4.tar.gz) = 945e961371d041f46f684e2d9690c819c27accd1c34fbe0c885bd12ebc3b1e93
SHA512 (libidn2-2.3.4.tar.gz) = a6e90ccef56cfd0b37e3333ab3594bb3cec7ca42a138ca8c4f4ce142da208fa792f6c78ca00c01001c2bc02831abcbaf1cf9bcc346a5290fd7b30708f5a462f3
Size (libidn2-2.3.4.tar.gz) = 2083823 bytes
SHA1 (patch-config.h.in) = e816f95edf082f0dbaf924216ee53b9ed7afaf9f
SHA1 (patch-gl_m4_assert__h.m4) = 29e36c8b7604f266825759b2a18223b11ae446e8
BLAKE2s (libidn2-2.3.7.tar.gz) = 1d6c72799ebf230e86b4fcc6f4907aeced8a97d07ed30e2ffa97def50fcafe4d
SHA512 (libidn2-2.3.7.tar.gz) = eab5702bc0baed45492f8dde43a4d2ea3560ad80645e5f9e0cfa8d3b57bccd7fd782d04638e000ba07924a5d9f85e760095b55189188c4017b94705bef9b4a66
Size (libidn2-2.3.7.tar.gz) = 2155214 bytes

View File

@ -1,18 +0,0 @@
$NetBSD: patch-config.h.in,v 1.1 2023/06/11 00:41:07 schmonz Exp $
Borrow upstream gnulib commit 0814a293:
Make static_assert work on Solaris 11.4.
--- config.h.in.orig 2022-10-23 13:43:26.000000000 +0000
+++ config.h.in
@@ -1427,4 +1427,10 @@
&& __GNUG__ < 6 && __clang_major__ < 6)))
#include <assert.h>
#undef/**/assert
+ /* Solaris 11.4 <assert.h> defines static_assert as a macro with 2 arguments.
+ We need it also to be invocable with a single argument. */
+ #if defined __sun && (__STDC_VERSION__ - 0 >= 201112L) && !defined __cplusplus
+ #undef static_assert
+ #define static_assert _Static_assert
+ #endif
#endif

View File

@ -1,19 +0,0 @@
$NetBSD: patch-gl_m4_assert__h.m4,v 1.1 2023/06/11 00:41:07 schmonz Exp $
Borrow upstream gnulib commit 0814a293:
Make static_assert work on Solaris 11.4.
--- gl/m4/assert_h.m4.orig 2022-10-23 13:39:39.000000000 +0000
+++ gl/m4/assert_h.m4
@@ -57,5 +57,11 @@ AC_DEFUN([gl_ASSERT_H],
&& __GNUG__ < 6 && __clang_major__ < 6)))
#include <assert.h>
#undef/**/assert
+ /* Solaris 11.4 <assert.h> defines static_assert as a macro with 2 arguments.
+ We need it also to be invocable with a single argument. */
+ #if defined __sun && (__STDC_VERSION__ - 0 >= 201112L) && !defined __cplusplus
+ #undef static_assert
+ #define static_assert _Static_assert
+ #endif
#endif])
])