Update to pcb-20140316 and enable the gcode exporter.
Addresses pkg/49383 and pkg/46543 ======================================================================== Release Notes for PCB snapshot 20140316 ======================================================================== This release represents over 421 commits (mostly bugfixes and code refactoring) and as such this summary clearly is not complete. See the ChangeLog file for the complete list of changes. Features -------- - GTK gui uses GL now, including a pseudo-3D mode. - Brazilian translation added, others updated. - Many internationalization tweaks. - Mice with right-left scroll wheels now supported. - Major upgrades to the GCode exporter. - rat-thickness parameter can take a 'px' suffix - metric and imperial grids are now more independent. - photo exporter supports multiple color schemes. - gerbers can be output in metric. - There's now a difference between "found" (what the netlist wants) and "connected" (what the copper says). - PNG exporter has --fill-holes to omit the "drill helper" completely. - gerber drill files now 0.1mil resolution. - XY file is now IPC 7531 compliant. Bug Fixes --------- - Fix pan locking up pcb if you leave the window. - Many bugfixes related to the metric conversion, including the two autorouters. - ps alignment marks fixed. - route styles in *.pcb files may contain units. - able to select more parts by their mark when their mark is on-grid. - gtk route selector may now have nothing selected, if the board has custom route settings. - drc no longer hangs when some layers are skipped. - ps_bloat works again. - EPS header is more standards-compliant. - PS outlines are only drawn on copper layers, not mask layers. - cursor position and zoom are no longer written to the *.pcb file. - lines with different clearances aren't auto-merged. - pin names are drawn in the pinout window. - gerber aperture numbers won't increase between runs. - misc doc tweaks and fixes. Other ----- - Many tweaks to the source code to make it cleaner. - The top and bottom layers are now consistently called "top" and "bottom" instead of "solder" and "component" - *.pcb file version bumped to 20091103 to reflect coordinate units change. - gEDA/pcb project moved to geda-project.org
This commit is contained in:
parent
db97b6cac2
commit
4f8ab5d376
5 changed files with 27 additions and 31 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.80 2015/11/18 14:19:48 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.81 2016/01/22 21:56:36 dmcmahill Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pcb-20110918
|
||||
PKGREVISION= 19
|
||||
DISTNAME= pcb-20140316
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pcb/}
|
||||
|
||||
|
@ -30,7 +29,7 @@ CONFIGURE_ARGS+= --disable-update-mime-database
|
|||
USE_TOOLS+= bison gm4:run gmake intltool lex wish:run pkg-config
|
||||
USE_PKGLOCALEDIR= yes
|
||||
INFO_FILES= yes
|
||||
LDFLAGS+= -lstdc++ # direct link as required by ld v2.22
|
||||
LDFLAGS+= -lstdc++ -lm # direct link as required by ld v2.22
|
||||
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
|
@ -62,7 +61,7 @@ PKG_FAIL_REASON= Invalid options
|
|||
.include "../../sysutils/dbus/buildlink3.mk"
|
||||
.endif
|
||||
|
||||
EXPORTERS= bom gerber ps
|
||||
EXPORTERS= bom gcode gerber ps
|
||||
.if !empty(PKG_OPTIONS:Mpng)
|
||||
EXPORTERS+= png
|
||||
.include "../../graphics/gd/buildlink3.mk"
|
||||
|
|
|
@ -1,11 +1,10 @@
|
|||
@comment $NetBSD: PLIST,v 1.17 2011/12/09 12:42:09 dmcmahill Exp $
|
||||
@comment $NetBSD: PLIST,v 1.18 2016/01/22 21:56:36 dmcmahill Exp $
|
||||
bin/MergePCBPS
|
||||
bin/Merge_dimPCBPS
|
||||
bin/pcb
|
||||
include/gts.h
|
||||
info/pcb.info
|
||||
lib/libgts.a
|
||||
man/man1/pcb.1
|
||||
share/appdata/pcb.appdata.xml
|
||||
share/applications/pcb.desktop
|
||||
share/doc/pcb/examples/LED.net
|
||||
share/doc/pcb/examples/LED.pcb
|
||||
|
@ -58,6 +57,7 @@ share/icons/hicolor/scalable/mimetypes/application-x-pcb-layout.svg
|
|||
share/icons/hicolor/scalable/mimetypes/application-x-pcb-netlist.svg
|
||||
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/pcb.mo
|
||||
${PKGLOCALEDIR}/locale/nl/LC_MESSAGES/pcb.mo
|
||||
${PKGLOCALEDIR}/locale/pt_BR/LC_MESSAGES/pcb.mo
|
||||
${PKGLOCALEDIR}/locale/ru/LC_MESSAGES/pcb.mo
|
||||
share/mime/packages/pcb.xml
|
||||
share/mimelnk/application/x-excellon.desktop
|
||||
|
@ -437,6 +437,7 @@ share/pcb/pcblib-newlib/geda/DIP28M.fp
|
|||
share/pcb/pcblib-newlib/geda/DIP28N.fp
|
||||
share/pcb/pcblib-newlib/geda/DIP32.fp
|
||||
share/pcb/pcblib-newlib/geda/DIP36.fp
|
||||
share/pcb/pcblib-newlib/geda/DIP4.fp
|
||||
share/pcb/pcblib-newlib/geda/DIP40.fp
|
||||
share/pcb/pcblib-newlib/geda/DIP42.fp
|
||||
share/pcb/pcblib-newlib/geda/DIP44.fp
|
||||
|
@ -1175,3 +1176,4 @@ share/pcb/tools/Merge_dimPCBPS
|
|||
share/pcb/tools/apctools.zip
|
||||
share/pcb/tools/gerbertotk.c
|
||||
share/pcb/tools/pcb2ncap.tgz
|
||||
share/pcb/tools/pcbdiff
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.21 2015/11/03 00:21:18 agc Exp $
|
||||
$NetBSD: distinfo,v 1.22 2016/01/22 21:56:36 dmcmahill Exp $
|
||||
|
||||
SHA1 (pcb-20110918.tar.gz) = 53ca27797d4db65a068b56f157e3ea6c5c29051f
|
||||
RMD160 (pcb-20110918.tar.gz) = 1e176a03a7a61ac23b7abe532277415c87637c16
|
||||
SHA512 (pcb-20110918.tar.gz) = ca74a273f0e63b6497e50cab9f4553ccc2149a4ffa9081c409477392c245c38a144deb5b106da4c1b89be09a5eb8e268870b4fb5820d182c647abfb0c19c288d
|
||||
Size (pcb-20110918.tar.gz) = 4015128 bytes
|
||||
SHA1 (patch-aa) = 444de8ec535224bd2fbc6633d4e00ae5d970719a
|
||||
SHA1 (pcb-20140316.tar.gz) = ec714ff136d1817e500e1a9e654e786883b9501e
|
||||
RMD160 (pcb-20140316.tar.gz) = 70ef878227ad52c83ce4499373550e7a8d807dd4
|
||||
SHA512 (pcb-20140316.tar.gz) = 5b9a2704b4d3c95f03afad0fe8fb5414b2aa9d680e40bf77ad9b46a9d4e14ba740858092794a9ff6788f31ac19063b126d8ceed6316c0d9eaaaa574e6678c071
|
||||
Size (pcb-20140316.tar.gz) = 4210077 bytes
|
||||
SHA1 (patch-icon-theme-installer) = b3b183f2ab77c56e52d4cd96058a28bc7e2832bb
|
||||
SHA1 (patch-src_report.c) = 65226386159add0dcc556a296c16f8a25f4444ee
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.4 2011/12/09 12:42:10 dmcmahill Exp $
|
||||
|
||||
Add missing header file needed for setlocale() prototype as well as LC_ALL
|
||||
|
||||
--- src/main.c.orig 2011-09-17 21:29:29.000000000 +0000
|
||||
+++ src/main.c
|
||||
@@ -33,6 +33,10 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
+#ifdef HAVE_LOCALE_H
|
||||
+#include <locale.h>
|
||||
+#endif
|
||||
+
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_STRING_H
|
||||
#include <string.h>
|
12
cad/pcb/patches/patch-src_report.c
Normal file
12
cad/pcb/patches/patch-src_report.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
$Id: patch-src_report.c,v 1.1 2016/01/22 21:56:37 dmcmahill Exp $
|
||||
|
||||
--- src/report.c.orig 2014-03-10 23:09:51.000000000 -0400
|
||||
+++ src/report.c 2016-01-22 10:05:47.000000000 -0500
|
||||
@@ -32,4 +32,7 @@
|
||||
#endif
|
||||
|
||||
+#ifdef HAVE_LOCALE_H
|
||||
+#include <locale.h> /* setlocale() and LC_ALL */
|
||||
+#endif
|
||||
#include <math.h>
|
||||
|
Loading…
Reference in a new issue