Include <stdlib.h> not only NetBSD.

It already included unconditionally with other patches,
and fixes build failure on other platforms.
This commit is contained in:
obache 2010-12-30 09:02:51 +00:00
parent c35e88975a
commit 4fa19ac0f0
4 changed files with 15 additions and 21 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.7 2007/10/10 16:53:58 rillig Exp $
$NetBSD: distinfo,v 1.8 2010/12/30 09:02:51 obache Exp $
SHA1 (modemd-970221.tar.gz) = 104f8e596f711e349203b2da8c4f2ecf40d490c3
RMD160 (modemd-970221.tar.gz) = ade5d735e5fd07b91006cf1334a41a43dca7e3d9
@ -12,9 +12,9 @@ SHA1 (patch-af) = c438c7ddaa223ae5bdb5b4fd11c5d6304eec4008
SHA1 (patch-ag) = 8d93d4da055170a19336e127017dfe42501a0538
SHA1 (patch-ah) = 9294419cd64c3b5cc9ebadc3a4c135a0a969262d
SHA1 (patch-ai) = 8e81c1e522979f616f2f4aafd5dd65400a6330fa
SHA1 (patch-aj) = 5616eff4fa6bc17377d2a433bbbaf2ca83909b94
SHA1 (patch-ak) = 49e119497deb123a95e6b48a50829b2ffb00300d
SHA1 (patch-al) = 8f1d06be71aa3872975fa498fddf6b119c25755a
SHA1 (patch-aj) = 5b7fbd88bd080484edba7212027b02e1af713188
SHA1 (patch-ak) = 0d60a615020abad77dae56d783667e49112593e5
SHA1 (patch-al) = 0c24d9ea8ef1d5bc0dc56de7f2d07a7e39062693
SHA1 (patch-am) = d740f41abf89f760431f32ca7ffa25bf1b3bd4e1
SHA1 (patch-an) = 3369e7dc8db3f837bc4f71ec72e6f7882462c2a7
SHA1 (patch-ao) = 64271c0955600d1ad9bc7f4c74273a537d33f71c

View file

@ -1,14 +1,12 @@
$NetBSD: patch-aj,v 1.3 1999/11/15 14:25:09 rh Exp $
$NetBSD: patch-aj,v 1.4 2010/12/30 09:02:52 obache Exp $
--- common/mcap.c.orig Mon Nov 15 15:22:15 1999
+++ common/mcap.c Mon Nov 15 15:22:15 1999
@@ -48,6 +48,10 @@
--- common/mcap.c.orig 1997-02-21 23:05:16.000000000 +0000
+++ common/mcap.c
@@ -48,6 +48,8 @@ static char copyright[] =
#include "mcap.h"
static void enter_modemcap PROTO ((char *));
+#ifdef __NetBSD__
+#include "stdlib.h"
+#endif
+#include <stdlib.h>
+
static void parse_mcstring PROTO ((char *, struct modemcap *));
static void read_mcap PROTO ((void));

View file

@ -1,14 +1,12 @@
$NetBSD: patch-ak,v 1.4 2007/10/10 16:53:58 rillig Exp $
$NetBSD: patch-ak,v 1.5 2010/12/30 09:02:52 obache Exp $
--- common/atparse.c.orig 1996-04-30 07:02:36.000000000 +0000
+++ common/atparse.c 2007-10-10 16:29:50.000000000 +0000
@@ -45,6 +45,9 @@ static char copyright[] =
+++ common/atparse.c
@@ -45,6 +45,7 @@ static char copyright[] =
#include "cdefs.h"
#include "global.h"
#include <ctype.h>
+#ifdef __NetBSD__
+#include <stdlib.h>
+#endif
/* Convert a string of AT commands into a vector of pointers to individual
commands. */

View file

@ -1,14 +1,12 @@
$NetBSD: patch-al,v 1.4 2007/10/10 16:53:58 rillig Exp $
$NetBSD: patch-al,v 1.5 2010/12/30 09:02:52 obache Exp $
--- incoming/modemd.c.orig 1996-09-10 00:34:58.000000000 +0000
+++ incoming/modemd.c 2007-10-10 16:29:50.000000000 +0000
@@ -48,6 +48,9 @@ static char copyright[] =
+++ incoming/modemd.c
@@ -48,6 +48,7 @@ static char copyright[] =
#include <syslog.h>
#include <pwd.h>
#include <stdio.h>
+#ifdef __NetBSD__
+#include <stdlib.h>
+#endif
static char *ttyName;
static char progName [1024];