Fix handling of tcl and tk versions: don't demand exact version when
the version we have doesn't include the teeny version number. Possibly we should arrange to pass that in and require it exactly; I'm not sure exactly what the compatibility semantics of version numbers are supposed to be in tcl-land; but it's definitely wrong the way it has been. Fixes PR 50244 wherein tkined fails to run.
This commit is contained in:
parent
e7a9f06b90
commit
4fc755ec6e
2 changed files with 23 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.16 2015/11/04 00:35:39 agc Exp $
|
||||
$NetBSD: distinfo,v 1.17 2016/05/02 04:00:25 dholland Exp $
|
||||
|
||||
SHA1 (scotty-2.1.11.tar.gz) = 819011f908c57e4591d6f50e51677c01eb55dc13
|
||||
RMD160 (scotty-2.1.11.tar.gz) = 3b4d45f3db73f05b49a46017bf2ffed6d6464b00
|
||||
|
@ -6,6 +6,7 @@ SHA512 (scotty-2.1.11.tar.gz) = a75eb6bc54e183a8f6b5995122f35133b0f76a7a1061c177
|
|||
Size (scotty-2.1.11.tar.gz) = 1381059 bytes
|
||||
SHA1 (patch-snmp_tnmMibQuery.c) = 86f2cecac8a0766e7075836569d76671a3d15547
|
||||
SHA1 (patch-tkined_apps_ip__discover.tcl) = bf067f64474dc3ed6306caa468f29a040023e165
|
||||
SHA1 (patch-tkined_generic_tkiInit.c) = 8092655b067d6d03827d421eaa9027d96263b96e
|
||||
SHA1 (patch-tnm_gdmo_tnmGdmoTcl.c) = cc67acec2df2cc34a73b0319d452b7ee0aafc5cc
|
||||
SHA1 (patch-tnm_generic_tnm.h) = 781250970f5d6e1b0653175ce024d8310168f611
|
||||
SHA1 (patch-tnm_generic_tnmDns.c) = f6c3279b84c8cd23e46acfb94ffbff7b1e50a898
|
||||
|
|
21
net/tcl-scotty/patches/patch-tkined_generic_tkiInit.c
Normal file
21
net/tcl-scotty/patches/patch-tkined_generic_tkiInit.c
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-tkined_generic_tkiInit.c,v 1.1 2016/05/02 04:00:25 dholland Exp $
|
||||
|
||||
Don't demand exactly TCL_VERSION and TK_VERSION as these do not
|
||||
include the patchlevel (e.g. they're 8.6 instead of 8.6.5).
|
||||
|
||||
--- tkined/generic/tkiInit.c~ 1998-09-16 17:11:01.000000000 +0000
|
||||
+++ tkined/generic/tkiInit.c
|
||||
@@ -62,11 +62,11 @@ TkiInit(interp)
|
||||
|
||||
buffersize(1024);
|
||||
|
||||
- if (Tcl_PkgRequire(interp, "Tcl", TCL_VERSION, 1) == NULL) {
|
||||
+ if (Tcl_PkgRequire(interp, "Tcl", TCL_VERSION, 0) == NULL) {
|
||||
return TCL_ERROR;
|
||||
}
|
||||
|
||||
- if (Tcl_PkgRequire(interp, "Tk", TK_VERSION, 1) == NULL) {
|
||||
+ if (Tcl_PkgRequire(interp, "Tk", TK_VERSION, 0) == NULL) {
|
||||
return TCL_ERROR;
|
||||
}
|
||||
|
Loading…
Reference in a new issue