hexchat: Update to 2.14.3

Bug fix only update to a leaf package.

* fix various incorrect parsing of IRC messages relating to trailing parameters
* fix SASL negotiation combined with multi-line cap
* fix input box theming with Yaru theme
* python: Work around Python 3.7 regression causing crash on unload
* sysinfo: Add support for /etc/os-release
* sysinfo: Ignore irrelevant mounts when calculating storage size
This commit is contained in:
nia 2019-12-21 14:41:32 +00:00
parent 942cafd73b
commit 4fd5719a30
7 changed files with 14 additions and 121 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.40 2019/12/04 11:59:54 nia Exp $
# $NetBSD: Makefile,v 1.41 2019/12/21 14:41:32 nia Exp $
DISTNAME= hexchat-2.14.2
PKGREVISION= 3
DISTNAME= hexchat-2.14.3
CATEGORIES= chat
MASTER_SITES= https://dl.hexchat.net/hexchat/
EXTRACT_SUFX= .tar.xz

View file

@ -1,15 +1,11 @@
$NetBSD: distinfo,v 1.10 2019/12/04 11:57:05 nia Exp $
$NetBSD: distinfo,v 1.11 2019/12/21 14:41:32 nia Exp $
SHA1 (hexchat-2.14.2.tar.xz) = 650f6247cc68c022ba4fee09ebde578dc2ec1c33
RMD160 (hexchat-2.14.2.tar.xz) = a41067f7dd9b0eceaf2252aa7a8b8eca7dd228fd
SHA512 (hexchat-2.14.2.tar.xz) = 488799700e439a137ad469f618cb1abf75d1f1ebf223c750d658004ef7b2c728543a5a9ae4e6317d6447428dc59e12dded619346a5d8bba12c92dab653512fca
Size (hexchat-2.14.2.tar.xz) = 1288732 bytes
SHA1 (hexchat-2.14.3.tar.xz) = a219796d70023b675e5ea24af9f22beb9e855abb
RMD160 (hexchat-2.14.3.tar.xz) = ee9549bea0f8d221c39c3c6974d14415db358458
SHA512 (hexchat-2.14.3.tar.xz) = c265921f2cb02c5d273bcdbb20a44a5c9f38b0f8cbba4fd56b177b676fc5d1dfd05bf80fcfa3706c7981f712f2f6c9aaaf80bccf3be0f6d96068dd393f3a7cb5
Size (hexchat-2.14.3.tar.xz) = 1292072 bytes
SHA1 (patch-osx_launcher.sh) = 7493430921809182898aca2ebb8fd1f493dbd9d3
SHA1 (patch-plugins_sysinfo_meson.build) = 4f5309ddded3c23014711e1b3305ff6a1c5f62d6
SHA1 (patch-plugins_sysinfo_meson.build) = 277a131cde115d910696c69905fc4ed309a28466
SHA1 (patch-plugins_sysinfo_unix_parse.c) = 92b882b7573cfcfc280351353a7bdcb0a7940c06
SHA1 (patch-plugins_sysinfo_unix_pci.c) = db2d20261419bed6d6c4b716b4416d73b3386053
SHA1 (patch-plugins_sysinfo_unix_pci.h) = 018b74796143b26d6a1f9ad821f3889b74b09cc8
SHA1 (patch-src_common_meson.build) = 56f1376208c6ab198162d62ae990c8a6ed6c2b58
SHA1 (patch-src_common_modes.c) = aa9972dcd405600a850173cd0605f4df3dc464af
SHA1 (patch-src_common_proto-irc.c) = 93c92648a2781a21cd00e14e3dbc230c04ca1b50
SHA1 (patch-src_common_proto-irc.h) = c9153d74a7abd39d511b59288c9245052216ee09

View file

@ -1,22 +1,22 @@
$NetBSD: patch-plugins_sysinfo_meson.build,v 1.1 2018/03/17 11:56:15 tnn Exp $
$NetBSD: patch-plugins_sysinfo_meson.build,v 1.2 2019/12/21 14:41:32 nia Exp $
XXX this is incomplete
--- plugins/sysinfo/meson.build.orig 2018-03-14 02:27:13.000000000 +0000
--- plugins/sysinfo/meson.build.orig 2019-12-21 06:43:47.652401700 +0000
+++ plugins/sysinfo/meson.build
@@ -13,13 +13,13 @@ sysinfo_includes = []
sysinfo_cargs = []
system = host_machine.system()
-if system == 'linux' or system == 'darwin'
+if system == 'linux' or system == 'darwin' or system == 'netbsd'
-if system == 'linux' or system == 'gnu' or system.startswith('gnu/') or system == 'darwin'
+if system == 'linux' or system == 'gnu' or system.startswith('gnu/') or system == 'darwin' or system == 'netbsd':
sysinfo_includes += 'shared'
sysinfo_sources += [
'shared/df.c'
]
- if system == 'linux'
+ if system == 'linux' or system == 'netbsd'
- if system == 'linux' or system == 'gnu' or system.startswith('gnu/')
+ if system == 'linux' or system == 'gnu' or system.startswith('gnu/') or system == 'netbsd':
libpci = dependency('libpci', required: false, method: 'pkg-config')
if libpci.found()
sysinfo_deps += libpci

View file

@ -1,15 +0,0 @@
$NetBSD: patch-src_common_meson.build,v 1.1 2019/07/17 10:53:22 nia Exp $
Make generated headers an explicit dependency of targets using
hexchat_common to force the headers to be generated in time.
--- src/common/meson.build.orig 2018-08-29 21:13:25.000000000 +0000
+++ src/common/meson.build
@@ -109,6 +109,7 @@ hexchat_common = static_library('hexchat
)
hexchat_common_dep = declare_dependency(
+ sources: [textevents] + marshal,
link_with: hexchat_common,
include_directories: common_includes,
compile_args: common_cflags,

View file

@ -1,26 +0,0 @@
$NetBSD: patch-src_common_modes.c,v 1.1 2019/12/04 11:57:05 nia Exp $
Fixes a message parser bug.
https://github.com/hexchat/hexchat/commit/804f959a1d0c9bfe88166a7541af4371460b468b.patch
--- src/common/modes.c.orig 2018-08-29 21:13:25.000000000 +0000
+++ src/common/modes.c
@@ -735,6 +735,8 @@ handle_mode (server * serv, char *word[]
if (!(*word[i + offset]))
break;
num_args++;
+ if (word[i + offset][0] == ':')
+ break;
}
/* count the number of modes (without the -/+ chars */
@@ -765,7 +767,7 @@ handle_mode (server * serv, char *word[]
if ((all_modes_have_args || mode_has_arg (serv, sign, *modes)) && arg < (num_args + 1))
{
arg++;
- argstr = word[arg + offset];
+ argstr = STRIP_COLON(word, word_eol, arg+offset);
}
handle_single_mode (&mr, sign, *modes, nick, chan,
argstr, numeric_324 || prefs.hex_irc_raw_modes,

View file

@ -1,44 +0,0 @@
$NetBSD: patch-src_common_proto-irc.c,v 1.1 2019/12/04 11:57:05 nia Exp $
Fixes a message parser bug.
https://github.com/hexchat/hexchat/commit/804f959a1d0c9bfe88166a7541af4371460b468b.patch
--- src/common/proto-irc.c.orig 2018-08-29 21:13:25.000000000 +0000
+++ src/common/proto-irc.c
@@ -714,7 +714,7 @@ process_numeric (session * sess, int n,
break;
case 333:
- inbound_topictime (serv, word[4], word[5], atol (word[6]), tags_data);
+ inbound_topictime (serv, word[4], word[5], atol (STRIP_COLON(word, word_eol, 6)), tags_data);
break;
#if 0
@@ -726,7 +726,7 @@ process_numeric (session * sess, int n,
#endif
case 341: /* INVITE ACK */
- EMIT_SIGNAL_TIMESTAMP (XP_TE_UINVITE, sess, word[4], word[5],
+ EMIT_SIGNAL_TIMESTAMP (XP_TE_UINVITE, sess, word[4], STRIP_COLON(word, word_eol, 5),
serv->servername, NULL, 0, tags_data->timestamp);
break;
@@ -1142,7 +1142,7 @@ process_named_msg (session *sess, char *
{
case WORDL('A','C','C','O'):
- inbound_account (serv, nick, word[3], tags_data);
+ inbound_account (serv, nick, STRIP_COLON(word, word_eol, 3), tags_data);
return;
case WORDL('A', 'U', 'T', 'H'):
@@ -1150,7 +1150,7 @@ process_named_msg (session *sess, char *
return;
case WORDL('C', 'H', 'G', 'H'):
- inbound_user_info (sess, NULL, word[3], word[4], NULL, nick, NULL,
+ inbound_user_info (sess, NULL, word[3], STRIP_COLON(word, word_eol, 4), NULL, nick, NULL,
NULL, 0xff, tags_data);
return;

View file

@ -1,17 +0,0 @@
$NetBSD: patch-src_common_proto-irc.h,v 1.1 2019/12/04 11:57:05 nia Exp $
Fixes a message parser bug.
https://github.com/hexchat/hexchat/commit/804f959a1d0c9bfe88166a7541af4371460b468b.patch
--- src/common/proto-irc.h.orig 2018-08-29 21:13:25.000000000 +0000
+++ src/common/proto-irc.h
@@ -28,6 +28,8 @@
(time_t)0, /* timestamp */ \
}
+#define STRIP_COLON(word, word_eol, idx) (word)[(idx)][0] == ':' ? (word_eol)[(idx)]+1 : (word)[(idx)]
+
/* Message tag information that might be passed along with a server message
*
* See http://ircv3.atheme.org/specification/capability-negotiation-3.1