Fix C++ syntax
This commit is contained in:
parent
12c8e929bf
commit
4ff331d104
2 changed files with 33 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
||||||
$NetBSD: distinfo,v 1.27 2012/04/15 05:54:53 markd Exp $
|
$NetBSD: distinfo,v 1.28 2012/04/19 21:10:59 joerg Exp $
|
||||||
|
|
||||||
SHA1 (kdelibs-4.8.2.tar.xz) = f844ae0877880563361144d9577706064c3483e7
|
SHA1 (kdelibs-4.8.2.tar.xz) = f844ae0877880563361144d9577706064c3483e7
|
||||||
RMD160 (kdelibs-4.8.2.tar.xz) = 9c52ef42274f4ed5fd82a749ed7cf78f482c9c67
|
RMD160 (kdelibs-4.8.2.tar.xz) = 9c52ef42274f4ed5fd82a749ed7cf78f482c9c67
|
||||||
|
@ -17,3 +17,4 @@ SHA1 (patch-cmake_modules_FindTaglib.cmake) = be38479966da542343dd962c57f7e9d1be
|
||||||
SHA1 (patch-kdecore_localization_klocale_kde.cpp) = b8a513a0c51e65d7e604a88c1d0e3325be6ad688
|
SHA1 (patch-kdecore_localization_klocale_kde.cpp) = b8a513a0c51e65d7e604a88c1d0e3325be6ad688
|
||||||
SHA1 (patch-kdecore_util_kshareddatacache_p.h) = 6d064fe75fbecd489b0343960333864c717c0805
|
SHA1 (patch-kdecore_util_kshareddatacache_p.h) = 6d064fe75fbecd489b0343960333864c717c0805
|
||||||
SHA1 (patch-kjs_JSImmediate.h) = ecc761c7c82f711f41cf47d706c1c22d22c2980a
|
SHA1 (patch-kjs_JSImmediate.h) = ecc761c7c82f711f41cf47d706c1c22d22c2980a
|
||||||
|
SHA1 (patch-kjs_wtf_HashSet.h) = 5ffa5db540a72c95e94c4c16cc0fe521d1f2516a
|
||||||
|
|
31
x11/kdelibs4/patches/patch-kjs_wtf_HashSet.h
Normal file
31
x11/kdelibs4/patches/patch-kjs_wtf_HashSet.h
Normal file
|
@ -0,0 +1,31 @@
|
||||||
|
$NetBSD: patch-kjs_wtf_HashSet.h,v 1.1 2012/04/19 21:10:59 joerg Exp $
|
||||||
|
|
||||||
|
--- kjs/wtf/HashSet.h.orig 2012-04-19 16:21:41.000000000 +0000
|
||||||
|
+++ kjs/wtf/HashSet.h
|
||||||
|
@@ -181,7 +181,7 @@ namespace WTF {
|
||||||
|
inline HashSet<Value, HashFunctions, Traits>::find(const T& value)
|
||||||
|
{
|
||||||
|
typedef HashSetTranslatorAdapter<ValueType, ValueTraits, T, Translator> Adapter;
|
||||||
|
- return m_impl.find<T, Adapter>(value);
|
||||||
|
+ return m_impl.template find<T, Adapter>(value);
|
||||||
|
}
|
||||||
|
|
||||||
|
template<typename Value, typename HashFunctions, typename Traits>
|
||||||
|
@@ -190,7 +190,7 @@ namespace WTF {
|
||||||
|
inline HashSet<Value, HashFunctions, Traits>::find(const T& value) const
|
||||||
|
{
|
||||||
|
typedef HashSetTranslatorAdapter<ValueType, ValueTraits, T, Translator> Adapter;
|
||||||
|
- return m_impl.find<T, Adapter>(value);
|
||||||
|
+ return m_impl.template find<T, Adapter>(value);
|
||||||
|
}
|
||||||
|
|
||||||
|
template<typename Value, typename HashFunctions, typename Traits>
|
||||||
|
@@ -198,7 +198,7 @@ namespace WTF {
|
||||||
|
inline bool HashSet<Value, HashFunctions, Traits>::contains(const T& value) const
|
||||||
|
{
|
||||||
|
typedef HashSetTranslatorAdapter<ValueType, ValueTraits, T, Translator> Adapter;
|
||||||
|
- return m_impl.contains<T, Adapter>(value);
|
||||||
|
+ return m_impl.template contains<T, Adapter>(value);
|
||||||
|
}
|
||||||
|
|
||||||
|
template<typename T, typename U, typename V>
|
Loading…
Reference in a new issue