update to 3.4.1

Changes:
  New:
    - fixed some Linux build problems
    - fixed some Windows build problems
    - GL_EXT_texture_env_dot3 extension (Gareth Hughes)
  Bug fixes:
    - added RENDER_START/RENDER_FINISH macros for glCopyTexImage in DRI
    - various state-update code changes needed for DRI bugs
    - disabled pixel transfer ops in glColorTable commands, not needed
    - fixed bugs in glCopyConvolutionFilter1D/2D, glGetConvolutionFilter
    - updated sources and fixed compile problems in widgets-mesa/
    - GLX_PBUFFER enum value was wrong in glx.h
    - fixed a glColorMaterial lighting bug
    - fixed bad args to Read/WriteStencilSpan in h/w stencil clear function
    - glXCopySubBufferMESA() Y position was off by one
    - Error checking of glTexSubImage3D() was broken (bug 128775)
    - glPopAttrib() didn't restore all derived Mesa state correctly
    - Better glReadPixels accuracy for 16bpp color - fixes lots of OpenGL
      conformance problems at 16bpp.
    - clearing depth buffer with scissoring was broken, would segfault
    - OSMesaGetDepthBuffer() returned bad bytesPerValue value
    - fixed a line clipping bug (reported by Craig McDaniel)
    - fixed RGB color over/underflow bug for very tiny triangles
  Known problems:
    - NURBS or evaluator surfaces inside display lists don't always work
This commit is contained in:
drochner 2001-03-23 12:36:53 +00:00
parent 853ab99d94
commit 5000ff6534
11 changed files with 32 additions and 31 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.37 2001/02/16 15:22:15 wiz Exp $
# $NetBSD: Makefile,v 1.38 2001/03/23 12:36:53 drochner Exp $
#
DISTNAME= Mesa-3.4
DISTNAME= Mesa-3.4.1
CATEGORIES= graphics
MASTER_SITES= # empty
DISTFILES= # empty
@ -10,8 +10,8 @@ MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.ssec.wisc.edu/~brianp/Mesa.html
COMMENT= Graphics library meta package, similar to SGI's OpenGL
DEPENDS+= glu-3.4:../../graphics/glu
DEPENDS+= glut-3.4:../../graphics/glut
DEPENDS+= glu-3.4.1:../../graphics/glu
DEPENDS+= glut-3.4.1:../../graphics/glut
CONFLICTS= Mesa-glx-*
@ -19,7 +19,7 @@ CHECK_MESA= yes
.include "../../mk/bsd.prefs.mk"
.if ${HAVE_BUILTIN_MESA} == "NO"
DEPENDS+= MesaLib-3.4:../../graphics/MesaLib
DEPENDS+= MesaLib-3.4.1:../../graphics/MesaLib
.endif
USE_X11BASE= yes

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.5 2001/02/16 15:22:15 wiz Exp $
# $NetBSD: Makefile,v 1.6 2001/03/23 12:36:54 drochner Exp $
#
DISTNAME= MesaLib-3.4
DISTNAME= MesaLib-3.4.1
WRKSRC= ${WRKDIR}/${DISTNAME:S/Lib//}
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.mesa3d.org/mesa/ \
@ -16,6 +16,7 @@ CHECK_MESA= yes
USE_X11BASE= yes
USE_LIBTOOL= yes
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.2 2000/12/12 17:22:38 drochner Exp $
$NetBSD: md5,v 1.3 2001/03/23 12:36:54 drochner Exp $
MD5 (MesaLib-3.4.tar.bz2) = 6817ac3667aec85ab4c64ad8116867b7
SHA1 (MesaLib-3.4.1.tar.bz2) = d239335f11e5322d98a98aa699afb4fc5b995197

View file

@ -1,4 +1,4 @@
$NetBSD: patch-sum,v 1.2 2000/12/12 17:22:38 drochner Exp $
$NetBSD: patch-sum,v 1.3 2001/03/23 12:36:54 drochner Exp $
MD5 (patch-aa) = 95180ae89aa01383d0dd647ded6f6d6c
MD5 (patch-ab) = c514339a69a904add8a58e9c0a50e97c
SHA1 (patch-aa) = f8e311944bbd80bf3939196dbbe993f78b2f8c50
SHA1 (patch-ab) = 36ad59ccff1f99f9352c0fc6c9d8754f4ee01a5f

View file

@ -1,11 +1,11 @@
$NetBSD: patch-ab,v 1.2 2000/12/12 17:22:39 drochner Exp $
$NetBSD: patch-ab,v 1.3 2001/03/23 12:36:54 drochner Exp $
--- configure.orig Thu Nov 2 19:09:25 2000
+++ configure Sun Dec 10 23:49:29 2000
--- configure.orig Thu Feb 8 00:27:38 2001
+++ configure Mon Mar 12 16:13:43 2001
@@ -823,8 +823,8 @@
MESA_MAJOR=3
MESA_MINOR=4
MESA_TINY=0
MESA_TINY=1
-LIBGL_VERSION=1:2:0${MESA_MAJOR}0${MESA_MINOR}0${MESA_TINY}
-LIBGLU_VERSION=1:1:0${MESA_MAJOR}0${MESA_MINOR}0${MESA_TINY}
+LIBGL_VERSION=${MESA_MAJOR}:${MESA_MINOR}:${MESA_TINY}

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.5 2001/02/16 15:22:22 wiz Exp $
# $NetBSD: Makefile,v 1.6 2001/03/23 12:36:54 drochner Exp $
#
DISTNAME= MesaLib-3.4
DISTNAME= MesaLib-3.4.1
PKGNAME= ${DISTNAME:C/MesaLib/glu/}
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.mesa3d.org/mesa/ \

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.2 2000/12/12 17:22:39 drochner Exp $
$NetBSD: md5,v 1.3 2001/03/23 12:36:55 drochner Exp $
MD5 (MesaLib-3.4.tar.bz2) = 6817ac3667aec85ab4c64ad8116867b7
SHA1 (MesaLib-3.4.1.tar.bz2) = d239335f11e5322d98a98aa699afb4fc5b995197

View file

@ -1,3 +1,3 @@
$NetBSD: patch-sum,v 1.2 2000/12/12 17:22:39 drochner Exp $
$NetBSD: patch-sum,v 1.3 2001/03/23 12:36:55 drochner Exp $
MD5 (patch-aa) = 617155a88565f7059be8bd8e1880e2ba
SHA1 (patch-aa) = 36ad59ccff1f99f9352c0fc6c9d8754f4ee01a5f

View file

@ -1,11 +1,11 @@
$NetBSD: patch-aa,v 1.2 2000/12/12 17:22:39 drochner Exp $
$NetBSD: patch-aa,v 1.3 2001/03/23 12:36:55 drochner Exp $
--- configure.orig Thu Nov 2 19:09:25 2000
+++ configure Mon Dec 11 00:17:01 2000
--- configure.orig Thu Feb 8 00:27:38 2001
+++ configure Mon Mar 12 16:13:43 2001
@@ -823,8 +823,8 @@
MESA_MAJOR=3
MESA_MINOR=4
MESA_TINY=0
MESA_TINY=1
-LIBGL_VERSION=1:2:0${MESA_MAJOR}0${MESA_MINOR}0${MESA_TINY}
-LIBGLU_VERSION=1:1:0${MESA_MAJOR}0${MESA_MINOR}0${MESA_TINY}
+LIBGL_VERSION=${MESA_MAJOR}:${MESA_MINOR}:${MESA_TINY}

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.4 2001/02/16 15:22:22 wiz Exp $
# $NetBSD: Makefile,v 1.5 2001/03/23 12:36:55 drochner Exp $
#
DISTNAME= Mesa-3.4
DISTNAME= Mesa-3.4.1
PKGNAME= ${DISTNAME:S/Mesa/glut/}
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.mesa3d.org/mesa/ \

View file

@ -1,4 +1,4 @@
$NetBSD: md5,v 1.2 2000/12/12 17:22:40 drochner Exp $
$NetBSD: md5,v 1.3 2001/03/23 12:36:55 drochner Exp $
MD5 (MesaLib-3.4.tar.bz2) = 6817ac3667aec85ab4c64ad8116867b7
MD5 (MesaDemos-3.4.tar.bz2) = 27f7c8e143e2412e75ef7a3cd2313e0b
SHA1 (MesaLib-3.4.1.tar.bz2) = d239335f11e5322d98a98aa699afb4fc5b995197
SHA1 (MesaDemos-3.4.1.tar.bz2) = 2298901e36e887c0979e7d5e08fcb1f63784d97b