Pull in unistd.h for getopt.

This commit is contained in:
joerg 2015-12-11 23:32:22 +00:00
parent d30cfe87d4
commit 5002890293
2 changed files with 14 additions and 6 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.7 2015/11/03 22:50:33 agc Exp $
$NetBSD: distinfo,v 1.8 2015/12/11 23:32:22 joerg Exp $
SHA1 (cint-5.15.174/cint5.15.tar.gz) = 7061acb210dafb86413536dc91e0aa24e9ef3ee9
RMD160 (cint-5.15.174/cint5.15.tar.gz) = 4d403e150fc290feba38785b385f282a28d15dcd
@ -16,5 +16,5 @@ SHA1 (patch-ai) = 9ccb89fb804af6b728edf46b84dddc7f8e7f1572
SHA1 (patch-aj) = 032e81af2ed1b2740696abe03109d7caeda7b510
SHA1 (patch-ak) = d42e9b51f5dde832d51d2dbda141b7b9824cfc13
SHA1 (patch-al) = bff446f0f1670919be05443f01e95d66f247cdfd
SHA1 (patch-am) = 2702bc344bf937b45c8138339cf6d35214bb096f
SHA1 (patch-am) = d58f529527d51b021c34616a4ac6703d53c71db2
SHA1 (patch-an) = 0233b78422396f6a1081589b76bda4c3ec19fa0e

View file

@ -1,8 +1,16 @@
$NetBSD: patch-am,v 1.1 2008/09/05 05:27:31 dholland Exp $
$NetBSD: patch-am,v 1.2 2015/12/11 23:32:22 joerg Exp $
--- tool/ifdef/ifdef.cxx~ 2005-05-06 04:49:09.000000000 -0400
+++ tool/ifdef/ifdef.cxx 2008-09-05 00:32:03.000000000 -0400
@@ -62,7 +62,7 @@ extern "C" {
--- tool/ifdef/ifdef.cxx.orig 2005-05-06 08:49:09.000000000 +0000
+++ tool/ifdef/ifdef.cxx
@@ -13,6 +13,7 @@
#include <stdlib.h>
#include <string.h>
#include <ctype.h>
+#include <unistd.h>
#include <string>
#include <map>
#ifndef __hpux
@@ -62,7 +63,7 @@ extern "C" {
char *G__calc(char*);
char *G__getexpr(char*);
char *G__getandor(char*);