Changes 3.4.11:
* cachemgr.cgi: memory leak in request parser * Fix typo on commStartSslClose * Fix SQUID_CC_REQUIRE_ARGUMENT autoconf macro * Bug 3760: squidclient ignores --disable-ipv6 * Bug 3664: ssl_crtd fails to build on OpenSolaris/OpenIndiana/Solaris 11 * Bug 3754: configure doesnt detect IPFilter 5.1.2 system headers * Bug 4164: SEGFAULT when %W formating code used in errorpages * Deleting first fs left psstate->servers pointing to uninitialized memory * Maintenance: check release notes on packaging * Bug 4057: Avoid on-exit crashes when adaptation is enabled.
This commit is contained in:
parent
f0674f198a
commit
50244501b2
3 changed files with 15 additions and 15 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.39 2014/12/10 10:18:36 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.40 2015/01/16 11:41:11 adam Exp $
|
||||
|
||||
DISTNAME= squid-3.4.10
|
||||
DISTNAME= squid-3.4.11
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.squid-cache.org/Versions/v3/${PKGVERSION_NOREV:R}/ \
|
||||
ftp://ftp.squid-cache.org/pub/squid/ \
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: distinfo,v 1.26 2014/12/10 10:18:36 adam Exp $
|
||||
$NetBSD: distinfo,v 1.27 2015/01/16 11:41:11 adam Exp $
|
||||
|
||||
SHA1 (squid-3.4.10.tar.xz) = 52fb374fd6293978f8002ae994353fbe75d28a98
|
||||
RMD160 (squid-3.4.10.tar.xz) = c021ecc35484ce042a7c480efa4fd1cc7ab99286
|
||||
Size (squid-3.4.10.tar.xz) = 2161192 bytes
|
||||
SHA1 (squid-3.4.11.tar.xz) = 7de0949714cda4d3f19073aa846f00768a6f841b
|
||||
RMD160 (squid-3.4.11.tar.xz) = f8d643d4cecdee382d90152afd50cf0db121328c
|
||||
Size (squid-3.4.11.tar.xz) = 2162148 bytes
|
||||
SHA1 (patch-errors_Makefile.in) = afbac822ac84d5e1734d55fc625e949ae0b85289
|
||||
SHA1 (patch-helpers_basic_auth_MSNT_Makefile.in) = 74a0379d3ec0c2601dbb62b16df889bf4edcaedf
|
||||
SHA1 (patch-src_Makefile.in) = 130e223568a07c474b30a8fa3678c60f8b487c3e
|
||||
SHA1 (patch-src_SquidNew.cc) = eef6e72e168cf7f40518fab13dc2f55ed0268db9
|
||||
SHA1 (patch-src_base_TidyPointer.h) = 93428d26bb2479fc845764a324658eaacd26588e
|
||||
SHA1 (patch-src_ip_Intercept.cc) = 8a8640d5f7eef217b2536646513eb872c67a7ffc
|
||||
SHA1 (patch-src_ip_Intercept.cc) = 75dcd6ffc36ab7cd165469fe5f679ce56187cf4f
|
||||
SHA1 (patch-src_store.cc) = 055d98a59103b02a51876a5c8ffed9514954beb4
|
||||
SHA1 (patch-tools_Makefile.in) = 3a7678c63a11a35fabef091a3b18e63859f0796f
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-src_ip_Intercept.cc,v 1.2 2013/04/27 17:51:24 tron Exp $
|
||||
$NetBSD: patch-src_ip_Intercept.cc,v 1.3 2015/01/16 11:41:11 adam Exp $
|
||||
|
||||
Avoid conflict with IP Fitler's debug().
|
||||
|
||||
--- src/ip/Intercept.cc.orig 2013-04-27 04:34:48.000000000 +0100
|
||||
+++ src/ip/Intercept.cc 2013-04-27 18:40:24.000000000 +0100
|
||||
@@ -38,6 +38,10 @@
|
||||
--- src/ip/Intercept.cc.orig 2015-01-13 11:53:17.000000000 +0000
|
||||
+++ src/ip/Intercept.cc
|
||||
@@ -42,6 +42,10 @@
|
||||
|
||||
#if IPF_TRANSPARENT
|
||||
|
||||
|
@ -12,10 +12,10 @@ Avoid conflict with IP Fitler's debug().
|
|||
+#undef debug // XXX: IP Filter might declare debug().
|
||||
+#endif
|
||||
+
|
||||
#if HAVE_SYS_IOCTL_H
|
||||
#include <sys/ioctl.h>
|
||||
#if !defined(IPFILTER_VERSION)
|
||||
#define IPFILTER_VERSION 5000004
|
||||
#endif
|
||||
@@ -75,6 +79,10 @@
|
||||
@@ -92,6 +96,10 @@
|
||||
#include <errno.h>
|
||||
#endif
|
||||
|
||||
|
|
Loading…
Reference in a new issue