Fix build for SunOS modular x11 (PR#36132)

This commit is contained in:
tez 2009-10-19 21:47:22 +00:00
parent 3397c2b076
commit 504e90fb80
3 changed files with 16 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.60 2009/06/30 00:42:01 joerg Exp $
# $NetBSD: Makefile,v 1.61 2009/10/19 21:47:22 tez Exp $
PKGVER= 2.3.1
DISTNAME= openmotif-${PKGVER}
@ -55,6 +55,8 @@ SUBST_SED.man_rename+= -e 's: Shell.3: XShell.3:g'
.if ${OPSYS} == "NetBSD"
CONFIGURE_ENV+= ac_cv_func_setpgrp_void=no
.endif
CONFIGURE_ARGS+= --enable-xft
CFLAGS.SunOS+= -D_POSIX_PTHREAD_SEMANTICS
.if !empty(USE_CROSS_COMPILE:M[yY][eE][sS])
MAKE_FLAGS+= CROSS_COMPILING=yes CC_FOR_BUILD=${NATIVE_CC:Q} \

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.26 2008/07/14 23:01:32 christos Exp $
$NetBSD: distinfo,v 1.27 2009/10/19 21:47:22 tez Exp $
SHA1 (openmotif-2.3.1.tar.gz) = 7132493712111e6846deda241137f28a957b5878
RMD160 (openmotif-2.3.1.tar.gz) = 8fe6f41a8b75636d9211d34cae96d47a7ed10ade
@ -16,3 +16,4 @@ SHA1 (patch-bc) = 3e02a245bb4d442b30200d6da2725ef84986d52e
SHA1 (patch-bj) = 87abfdc6593d3b4ba3c7a76c84c54522ad7a044b
SHA1 (patch-bl) = 905bec86af6d8d139faa2ca185adf3e8b58c1dea
SHA1 (patch-bm) = 0e1aaf8b9a474a43e1382caa09b2ac9050f3505c
SHA1 (patch-bn) = c794756e1d113dd8d77054837764052b2696214c

View file

@ -0,0 +1,11 @@
--- lib/Xm/XmIm.c.orig Tue Dec 16 11:40:22 2008
+++ lib/Xm/XmIm.c Tue Dec 16 11:43:36 2008
@@ -79,7 +79,7 @@
work quite right/or is poorly documented and i cant get it to
work.
*/
-#if defined(sun)
+#if defined(sun) && !defined(XlibSpecificationRelease)
typedef Bool (*XICProc)( XIC, XPointer, XPointer);
#endif