chat/ejabberd: Update to 18.03.
Admin - Avoid logging IP addresses in mod_register when it's not desired - Command 'reload-config' allows to reload certificates - Get rid of 'fs' package dependency - Improve log message when module startup has failed - mod_muc_admin: New command get_room_affiliation - prosody2ejabberd: Report meaningful error when luerl is not available Configure - Accept atoms in api_permission command lists and commands with numbers in them - Validate additional listen opts: inet, inet6, backlog - Remove 'iqdisc' option - New option –enable-group=xxx - New option 'negotiation_timeout' - New option 'new_sql_schema' - New option 'validate_stream' - ejabberd_service: New option 'global_routes' for - mod_avatar: New 'rate_limit' option - mod_block_strangers: New 'access' option - mod_block_strangers: New 'captcha' option - mod_pubsub: New option 'force_node_config' Miscelanea - Simplify ejabberd_sup code - New gen_mod mod_options/1 callback to provide known options and defaults - Replace ?MYLANG with connection's language wherever possible - sql/*: Add username to peer indexes - cyrsasl: Simplify code for splitting auth string in cyrsasl - ejabberd_auth: Cache 'isuser' queries to external auth program - ejabberd_web_admin: Hardcode required ACL rules - mod_admin_extra: Command check_password_hash supports all hash methods - mod_admin_extra: Fix srg_get_info command with @all@ and @online@ - mod_avatar: Fulfill all requirements of XEP-0398 v0.2.0 - mod_avatar: Improve validation of 'convert' option - mod_block_strangers: Bounce groupchat to bare JID - mod_block_strangers: Fix a typo in call to create_captcha() - mod_caps: Only store CAPS if contact is subscribed - mod_carboncopy: Copy outgoing MUC PMs - mod_mam: Really run use_cache/1 and cache_nodes/1 callbacks - mod_pubsub: Remove items of unregistered user - mod_push_keepalive: Preserve timeout on resumption - mod_shared_roster: Try to fix ejabberd_c2s:process_info: got unexpected info - mod_shared_roster_ldap: Fix processing of ldap_memberattr_format_re option - mod_stream_mgmt: Abort connection on count error - mod_stream_mgmt: Clean up on timed out resumption
This commit is contained in:
parent
a6a6f733a5
commit
505a9dca83
5 changed files with 50 additions and 44 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.82 2018/01/16 12:28:56 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.83 2018/03/28 21:51:09 fhajny Exp $
|
||||
|
||||
DISTNAME= ejabberd-18.01
|
||||
DISTNAME= ejabberd-18.03
|
||||
CATEGORIES= chat
|
||||
MASTER_SITES= https://www.process-one.net/downloads/ejabberd/${PKGVERSION_NOREV}/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -10,28 +10,27 @@ HOMEPAGE= https://www.ejabberd.im/
|
|||
COMMENT= Free and Open Source distributed fault-tolerant Jabber server
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
DEPENDS+= erlang-cache_tab>=1.0.12:../../devel/erlang-cache_tab
|
||||
DEPENDS+= erlang-epam>=1.0.3:../../security/erlang-epam
|
||||
DEPENDS+= erlang-cache_tab>=1.0.13:../../devel/erlang-cache_tab
|
||||
DEPENDS+= erlang-epam>=1.0.4:../../security/erlang-epam
|
||||
DEPENDS+= erlang-eredis>=1.0.8.20150910:../../databases/erlang-eredis
|
||||
DEPENDS+= erlang-eimp>=1.0.2:../../graphics/erlang-eimp
|
||||
DEPENDS+= erlang-esip>=1.0.21:../../net/erlang-esip
|
||||
DEPENDS+= erlang-ezlib>=1.0.3:../../devel/erlang-ezlib
|
||||
DEPENDS+= erlang-fast_tls>=1.0.20:../../security/erlang-fast_tls
|
||||
DEPENDS+= erlang-fast_xml>=1.1.28:../../textproc/erlang-fast_xml
|
||||
DEPENDS+= erlang-fast_yaml>=1.0.12:../../textproc/erlang-fast_yaml
|
||||
DEPENDS+= erlang-fs>=2.12.0:../../devel/erlang-fs
|
||||
DEPENDS+= erlang-iconv>=1.0.6:../../converters/erlang-iconv
|
||||
DEPENDS+= erlang-eimp>=1.0.3:../../graphics/erlang-eimp
|
||||
DEPENDS+= erlang-esip>=1.0.22:../../net/erlang-esip
|
||||
DEPENDS+= erlang-ezlib>=1.0.4:../../devel/erlang-ezlib
|
||||
DEPENDS+= erlang-fast_tls>=1.0.21:../../security/erlang-fast_tls
|
||||
DEPENDS+= erlang-fast_xml>=1.1.29:../../textproc/erlang-fast_xml
|
||||
DEPENDS+= erlang-fast_yaml>=1.0.13:../../textproc/erlang-fast_yaml
|
||||
DEPENDS+= erlang-iconv>=1.0.7:../../converters/erlang-iconv
|
||||
DEPENDS+= erlang-jiffy>=0.14.8:../../textproc/erlang-jiffy
|
||||
DEPENDS+= erlang-jose>=1.8.4:../../security/erlang-jose
|
||||
DEPENDS+= erlang-lager>=3.4.2.:../../sysutils/erlang-lager
|
||||
DEPENDS+= erlang-luerl>=0.2:../../lang/erlang-luerl
|
||||
DEPENDS+= erlang-p1_mysql>=1.0.4:../../databases/erlang-p1_mysql
|
||||
DEPENDS+= erlang-luerl>=0.3:../../lang/erlang-luerl
|
||||
DEPENDS+= erlang-p1_mysql>=1.0.5:../../databases/erlang-p1_mysql
|
||||
DEPENDS+= erlang-p1_oauth2>=0.6.2:../../security/erlang-p1_oauth2
|
||||
DEPENDS+= erlang-p1_pgsql>=1.1.4:../../databases/erlang-p1_pgsql
|
||||
DEPENDS+= erlang-p1_utils>=1.0.10:../../misc/erlang-p1_utils
|
||||
DEPENDS+= erlang-stringprep>=1.0.10:../../textproc/erlang-stringprep
|
||||
DEPENDS+= erlang-stun>=1.0.20:../../net/erlang-stun
|
||||
DEPENDS+= erlang-xmpp>=1.1.19:../../net/erlang-xmpp
|
||||
DEPENDS+= erlang-p1_pgsql>=1.1.5:../../databases/erlang-p1_pgsql
|
||||
DEPENDS+= erlang-p1_utils>=1.0.11:../../misc/erlang-p1_utils
|
||||
DEPENDS+= erlang-stringprep>=1.0.11:../../textproc/erlang-stringprep
|
||||
DEPENDS+= erlang-stun>=1.0.21:../../net/erlang-stun
|
||||
DEPENDS+= erlang-xmpp>=1.1.20:../../net/erlang-xmpp
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GCC_RUNTIME= yes
|
||||
|
@ -39,14 +38,17 @@ USE_TOOLS+= bash:run gmake patch
|
|||
|
||||
CONFIGURE_ARGS+= --disable-debug
|
||||
CONFIGURE_ARGS+= --enable-system-deps
|
||||
CONFIGURE_ARGS+= --enable-graphics
|
||||
CONFIGURE_ARGS+= --enable-iconv
|
||||
CONFIGURE_ARGS+= --enable-mysql
|
||||
CONFIGURE_ARGS+= --enable-odbc
|
||||
CONFIGURE_ARGS+= --enable-pam
|
||||
CONFIGURE_ARGS+= --enable-pgsql
|
||||
CONFIGURE_ARGS+= --enable-redis
|
||||
CONFIGURE_ARGS+= --enable-sip
|
||||
CONFIGURE_ARGS+= --enable-stun
|
||||
CONFIGURE_ARGS+= --enable-zlib
|
||||
CONFIGURE_ARGS+= --enable-user=${EJABBERD_USER}
|
||||
CONFIGURE_ARGS+= --enable-group=${EJABBERD_GROUP}
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFBASEDIR}
|
||||
|
||||
MAKE_ENV+= USE_GLOBAL_DEPS=true
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.51 2018/01/03 22:51:30 fhajny Exp $
|
||||
@comment $NetBSD: PLIST,v 1.52 2018/03/28 21:51:09 fhajny Exp $
|
||||
lib/${PKGNAME}/COPYING
|
||||
lib/${PKGNAME}/ebin/ELDAPv3.beam
|
||||
lib/${PKGNAME}/ebin/XmppAddr.beam
|
||||
|
@ -36,7 +36,6 @@ lib/${PKGNAME}/ebin/ejabberd_commands.beam
|
|||
lib/${PKGNAME}/ebin/ejabberd_commands_doc.beam
|
||||
lib/${PKGNAME}/ebin/ejabberd_config.beam
|
||||
lib/${PKGNAME}/ebin/ejabberd_ctl.beam
|
||||
lib/${PKGNAME}/ebin/ejabberd_db_modules.beam
|
||||
lib/${PKGNAME}/ebin/ejabberd_hooks.beam
|
||||
lib/${PKGNAME}/ebin/ejabberd_http.beam
|
||||
lib/${PKGNAME}/ebin/ejabberd_http_ws.beam
|
||||
|
@ -50,7 +49,6 @@ lib/${PKGNAME}/ebin/ejabberd_oauth.beam
|
|||
lib/${PKGNAME}/ebin/ejabberd_oauth_mnesia.beam
|
||||
lib/${PKGNAME}/ebin/ejabberd_oauth_rest.beam
|
||||
lib/${PKGNAME}/ebin/ejabberd_oauth_sql.beam
|
||||
lib/${PKGNAME}/ebin/ejabberd_options.beam
|
||||
lib/${PKGNAME}/ebin/ejabberd_piefxis.beam
|
||||
lib/${PKGNAME}/ebin/ejabberd_pkix.beam
|
||||
lib/${PKGNAME}/ebin/ejabberd_rdbms.beam
|
||||
|
@ -335,8 +333,8 @@ lib/${PKGNAME}/priv/msgs/uk.msg
|
|||
lib/${PKGNAME}/priv/msgs/vi.msg
|
||||
lib/${PKGNAME}/priv/msgs/wa.msg
|
||||
lib/${PKGNAME}/priv/msgs/zh.msg
|
||||
lib/${PKGNAME}/priv/sql/lite.sql
|
||||
lib/${PKGNAME}/priv/sql/lite.new.sql
|
||||
lib/${PKGNAME}/priv/sql/lite.sql
|
||||
lib/${PKGNAME}/priv/sql/mssql.sql
|
||||
lib/${PKGNAME}/priv/sql/mysql.new.sql
|
||||
lib/${PKGNAME}/priv/sql/mysql.sql
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.55 2018/01/16 12:28:56 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.56 2018/03/28 21:51:09 fhajny Exp $
|
||||
|
||||
SHA1 (ejabberd-18.01.tgz) = a95d243845cd44d487bb5131a3cf94e334da68e5
|
||||
RMD160 (ejabberd-18.01.tgz) = c4df350ba3fd41c4103039cd1a363b0943625d52
|
||||
SHA512 (ejabberd-18.01.tgz) = 7b54410be6b5b20147d94209758ae2b9e265229cd0770c86b479255598b2ba85578e309f009b076dda37b0cfef9517d5554ca7070ef670ae12fefc51fc1deb6e
|
||||
Size (ejabberd-18.01.tgz) = 1863311 bytes
|
||||
SHA1 (patch-aa) = 1210ab42871db158fff7311d5552ca916cf30a39
|
||||
SHA1 (ejabberd-18.03.tgz) = 27557bab45027823147972a254ba3521a94572d0
|
||||
RMD160 (ejabberd-18.03.tgz) = b72d4dc86c03fcd2a708e18a6d7e5b821c1f95b7
|
||||
SHA512 (ejabberd-18.03.tgz) = 49a25e4a0ba27975eb4e998be3323bc8de8814808e41fbba46baf37035219c1ee6c907c0f22dd5b926af426287252b56e87c3ff9d93a8815816323c2fc5d16b4
|
||||
Size (ejabberd-18.03.tgz) = 1864193 bytes
|
||||
SHA1 (patch-aa) = b36ab8e2a189e07dc09186fdea0599d99294e0e5
|
||||
SHA1 (patch-ad) = de437722779c823a68f576ec587f5bc3a05e6fbc
|
||||
SHA1 (patch-ae) = d8d1ca7072f35a5652673cf461860e0f585ecd5b
|
||||
SHA1 (patch-configure) = 8cf03f571ef13ed825b445e0f1664d387895b8fe
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: options.mk,v 1.5 2017/04/13 19:04:53 fhajny Exp $
|
||||
# $NetBSD: options.mk,v 1.6 2018/03/28 21:51:09 fhajny Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.ejabberd
|
||||
PKG_SUPPORTED_OPTIONS= sqlite
|
||||
|
@ -10,5 +10,5 @@ PKG_SUGGESTED_OPTIONS= #
|
|||
# Add SQLite 3 support
|
||||
#
|
||||
.if !empty(PKG_OPTIONS:Msqlite)
|
||||
DEPENDS+= erlang-sqlite3>=1.1.5:../../databases/erlang-sqlite3
|
||||
DEPENDS+= erlang-sqlite3>=1.1.6:../../databases/erlang-sqlite3
|
||||
.endif
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.14 2018/01/03 22:51:30 fhajny Exp $
|
||||
$NetBSD: patch-aa,v 1.15 2018/03/28 21:51:09 fhajny Exp $
|
||||
|
||||
Fix locations; don't mess with ownership.
|
||||
|
||||
--- Makefile.in.orig 2017-12-28 18:37:19.000000000 +0000
|
||||
--- Makefile.in.orig 2018-03-23 13:48:17.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -9,7 +9,7 @@ exec_prefix = @exec_prefix@
|
||||
DESTDIR =
|
||||
|
@ -22,7 +22,7 @@ Fix locations; don't mess with ownership.
|
|||
|
||||
# /share/doc/ejabberd
|
||||
PACKAGE_TARNAME = @PACKAGE_TARNAME@
|
||||
@@ -59,16 +59,16 @@ JSDIR = $(PRIVDIR)/js
|
||||
@@ -59,37 +59,24 @@ JSDIR = $(PRIVDIR)/js
|
||||
SQLDIR = $(PRIVDIR)/sql
|
||||
|
||||
# /var/lib/ejabberd/
|
||||
|
@ -41,19 +41,25 @@ Fix locations; don't mess with ownership.
|
|||
+LOGDIR = $(DESTDIR)@EJABBERD_LOGDIR@
|
||||
|
||||
INSTALLUSER=@INSTALLUSER@
|
||||
# if no user was enabled, don't set privileges or ownership
|
||||
@@ -79,10 +79,10 @@ ifeq ($(INSTALLUSER),)
|
||||
-# if no user was enabled, don't set privileges or ownership
|
||||
-ifeq ($(INSTALLUSER),)
|
||||
O_USER=
|
||||
G_USER=
|
||||
CHOWN_COMMAND=echo
|
||||
CHOWN_OUTPUT=/dev/null
|
||||
INIT_USER=root
|
||||
else
|
||||
-else
|
||||
- O_USER=-o $(INSTALLUSER)
|
||||
- G_USER=-g $(INSTALLUSER)
|
||||
- CHOWN_COMMAND=chown
|
||||
- CHOWN_OUTPUT=&1
|
||||
+ O_USER=
|
||||
+ G_USER=
|
||||
+ CHOWN_COMMAND=echo
|
||||
+ CHOWN_OUTPUT=/dev/null
|
||||
INIT_USER=$(INSTALLUSER)
|
||||
endif
|
||||
- INIT_USER=$(INSTALLUSER)
|
||||
-endif
|
||||
-# if no group was enabled, don't set privileges or ownership
|
||||
INSTALLGROUP=@INSTALLGROUP@
|
||||
-ifneq ($(INSTALLGROUP),)
|
||||
- G_USER=-g $(INSTALLGROUP)
|
||||
-endif
|
||||
|
||||
all: deps src
|
||||
|
||||
|
|
Loading…
Reference in a new issue