Include endian.h instead of sys/endian.h on Linux.

This commit is contained in:
minskim 2004-07-05 14:41:31 +00:00
parent 1a6c06ddb7
commit 509e1a5cf8
2 changed files with 10 additions and 6 deletions

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.2 2004/06/27 20:28:53 kristerw Exp $
$NetBSD: distinfo,v 1.3 2004/07/05 14:41:31 minskim Exp $
SHA1 (p7zip_0.80.tar.bz2) = c87cda0a8a2cd1300272d71f4cd371db7ebb4b79
Size (p7zip_0.80.tar.bz2) = 921896 bytes
SHA1 (patch-aa) = f6a15b99f25a8ba631c45df94cfe4f7aff26bc8b
SHA1 (patch-aa) = 943f6149b1a9ae8bd75e94e940976e1f8f21136e
SHA1 (patch-ab) = e438472f1eb6886dcaee0147ca5f9a2604a9abb1
SHA1 (patch-ac) = 61dff04aca7b0c69ba8f12af40a4c27815a0bef2
SHA1 (patch-ad) = 34197da6654226155b26bcea083801d241f348d4

View file

@ -1,14 +1,18 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/06/25 13:56:12 wiz Exp $
$NetBSD: patch-aa,v 1.2 2004/07/05 14:41:31 minskim Exp $
--- 7zip/Crypto/AES/aesopt.h.orig 2004-06-13 19:06:36.000000000 +0200
--- 7zip/Crypto/AES/aesopt.h.orig 2004-06-13 12:06:36.000000000 -0500
+++ 7zip/Crypto/AES/aesopt.h
@@ -166,8 +166,7 @@
@@ -166,8 +166,11 @@
// #if defined(__GNUC__) || defined(__GNU_LIBRARY__)
#if (defined(__GNUC__) || defined(__GNU_LIBRARY__)) && !defined(WIN32) && !defined(__CYGWIN__)
-# include <endian.h>
-# include <byteswap.h>
+# include <sys/endian.h>
+# ifdef __linux__
+# include <endian.h>
+# else
+# include <sys/endian.h>
+# endif
#elif defined(__CRYPTLIB__)
# if defined( INC_ALL )
# include "crypt.h"