Bypass a troff check in configure to stop introducing an unneeded
g-prefix on SunOS, brings PLIST consistency across operating systems.
This commit is contained in:
parent
87fbd7709d
commit
50c811fa3f
4 changed files with 48 additions and 36 deletions
|
@ -1,8 +1,8 @@
|
||||||
# $NetBSD: Makefile,v 1.63 2012/03/31 20:17:13 hans Exp $
|
# $NetBSD: Makefile,v 1.64 2012/05/31 09:24:53 fhajny Exp $
|
||||||
#
|
#
|
||||||
|
|
||||||
DISTNAME= groff-1.20.1
|
DISTNAME= groff-1.20.1
|
||||||
PKGREVISION= 5
|
PKGREVISION= 6
|
||||||
CATEGORIES= textproc
|
CATEGORIES= textproc
|
||||||
MASTER_SITES= ${MASTER_SITE_GNU:=groff/}
|
MASTER_SITES= ${MASTER_SITE_GNU:=groff/}
|
||||||
|
|
||||||
|
@ -44,13 +44,6 @@ PLIST_SRC+= PLIST
|
||||||
|
|
||||||
.include "../../mk/bsd.prefs.mk"
|
.include "../../mk/bsd.prefs.mk"
|
||||||
|
|
||||||
.if ${OPSYS} == "SunOS"
|
|
||||||
PLIST_SUBST+= GNU_PREFIX="g"
|
|
||||||
|
|
||||||
.else
|
|
||||||
PLIST_SUBST+= GNU_PREFIX=""
|
|
||||||
.endif
|
|
||||||
|
|
||||||
BUILD_DEFS+= PAPERSIZE
|
BUILD_DEFS+= PAPERSIZE
|
||||||
.if defined(PAPERSIZE)
|
.if defined(PAPERSIZE)
|
||||||
CONFIGURE_ENV+= PAGE=${PAPERSIZE:Q}
|
CONFIGURE_ENV+= PAGE=${PAPERSIZE:Q}
|
||||||
|
|
|
@ -1,11 +1,11 @@
|
||||||
@comment $NetBSD: PLIST,v 1.21 2010/02/04 12:49:03 tnn Exp $
|
@comment $NetBSD: PLIST,v 1.22 2012/05/31 09:24:53 fhajny Exp $
|
||||||
bin/addftinfo
|
bin/addftinfo
|
||||||
bin/afmtodit
|
bin/afmtodit
|
||||||
bin/${GNU_PREFIX}eqn
|
bin/eqn
|
||||||
bin/eqn2graph
|
bin/eqn2graph
|
||||||
bin/gdiffmk
|
bin/gdiffmk
|
||||||
bin/grap2graph
|
bin/grap2graph
|
||||||
bin/${GNU_PREFIX}grn
|
bin/grn
|
||||||
bin/grodvi
|
bin/grodvi
|
||||||
bin/groff
|
bin/groff
|
||||||
bin/groffer
|
bin/groffer
|
||||||
|
@ -15,30 +15,30 @@ bin/grolj4
|
||||||
bin/grops
|
bin/grops
|
||||||
bin/grotty
|
bin/grotty
|
||||||
bin/hpftodit
|
bin/hpftodit
|
||||||
bin/${GNU_PREFIX}indxbib
|
bin/indxbib
|
||||||
bin/lkbib
|
bin/lkbib
|
||||||
bin/${GNU_PREFIX}lookbib
|
bin/lookbib
|
||||||
bin/mmroff
|
bin/mmroff
|
||||||
bin/${GNU_PREFIX}neqn
|
bin/neqn
|
||||||
bin/${GNU_PREFIX}nroff
|
bin/nroff
|
||||||
bin/pdfroff
|
bin/pdfroff
|
||||||
bin/pfbtops
|
bin/pfbtops
|
||||||
bin/${GNU_PREFIX}pic
|
bin/pic
|
||||||
bin/pic2graph
|
bin/pic2graph
|
||||||
bin/post-grohtml
|
bin/post-grohtml
|
||||||
bin/pre-grohtml
|
bin/pre-grohtml
|
||||||
bin/preconv
|
bin/preconv
|
||||||
bin/${GNU_PREFIX}refer
|
bin/refer
|
||||||
bin/roff2dvi
|
bin/roff2dvi
|
||||||
bin/roff2html
|
bin/roff2html
|
||||||
bin/roff2pdf
|
bin/roff2pdf
|
||||||
bin/roff2ps
|
bin/roff2ps
|
||||||
bin/roff2text
|
bin/roff2text
|
||||||
bin/roff2x
|
bin/roff2x
|
||||||
bin/${GNU_PREFIX}soelim
|
bin/soelim
|
||||||
bin/${GNU_PREFIX}tbl
|
bin/tbl
|
||||||
bin/tfmtodit
|
bin/tfmtodit
|
||||||
bin/${GNU_PREFIX}troff
|
bin/troff
|
||||||
info/groff.info
|
info/groff.info
|
||||||
lib/groff/groffer/func.pl
|
lib/groff/groffer/func.pl
|
||||||
lib/groff/groffer/man.pl
|
lib/groff/groffer/man.pl
|
||||||
|
@ -48,11 +48,11 @@ lib/groff/groffer/version.sh
|
||||||
man/man1/addftinfo.1
|
man/man1/addftinfo.1
|
||||||
man/man1/afmtodit.1
|
man/man1/afmtodit.1
|
||||||
man/man1/chem.1
|
man/man1/chem.1
|
||||||
man/man1/${GNU_PREFIX}eqn.1
|
man/man1/eqn.1
|
||||||
man/man1/eqn2graph.1
|
man/man1/eqn2graph.1
|
||||||
man/man1/gdiffmk.1
|
man/man1/gdiffmk.1
|
||||||
man/man1/grap2graph.1
|
man/man1/grap2graph.1
|
||||||
man/man1/${GNU_PREFIX}grn.1
|
man/man1/grn.1
|
||||||
man/man1/grodvi.1
|
man/man1/grodvi.1
|
||||||
man/man1/groff.1
|
man/man1/groff.1
|
||||||
man/man1/groffer.1
|
man/man1/groffer.1
|
||||||
|
@ -63,28 +63,28 @@ man/man1/grolj4.1
|
||||||
man/man1/grops.1
|
man/man1/grops.1
|
||||||
man/man1/grotty.1
|
man/man1/grotty.1
|
||||||
man/man1/hpftodit.1
|
man/man1/hpftodit.1
|
||||||
man/man1/${GNU_PREFIX}indxbib.1
|
man/man1/indxbib.1
|
||||||
man/man1/lkbib.1
|
man/man1/lkbib.1
|
||||||
man/man1/${GNU_PREFIX}lookbib.1
|
man/man1/lookbib.1
|
||||||
man/man1/mmroff.1
|
man/man1/mmroff.1
|
||||||
man/man1/${GNU_PREFIX}neqn.1
|
man/man1/neqn.1
|
||||||
man/man1/${GNU_PREFIX}nroff.1
|
man/man1/nroff.1
|
||||||
man/man1/pdfroff.1
|
man/man1/pdfroff.1
|
||||||
man/man1/pfbtops.1
|
man/man1/pfbtops.1
|
||||||
man/man1/${GNU_PREFIX}pic.1
|
man/man1/pic.1
|
||||||
man/man1/pic2graph.1
|
man/man1/pic2graph.1
|
||||||
man/man1/preconv.1
|
man/man1/preconv.1
|
||||||
man/man1/${GNU_PREFIX}refer.1
|
man/man1/refer.1
|
||||||
man/man1/roff2dvi.1
|
man/man1/roff2dvi.1
|
||||||
man/man1/roff2html.1
|
man/man1/roff2html.1
|
||||||
man/man1/roff2pdf.1
|
man/man1/roff2pdf.1
|
||||||
man/man1/roff2ps.1
|
man/man1/roff2ps.1
|
||||||
man/man1/roff2text.1
|
man/man1/roff2text.1
|
||||||
man/man1/roff2x.1
|
man/man1/roff2x.1
|
||||||
man/man1/${GNU_PREFIX}soelim.1
|
man/man1/soelim.1
|
||||||
man/man1/${GNU_PREFIX}tbl.1
|
man/man1/tbl.1
|
||||||
man/man1/tfmtodit.1
|
man/man1/tfmtodit.1
|
||||||
man/man1/${GNU_PREFIX}troff.1
|
man/man1/troff.1
|
||||||
man/man5/groff_font.5
|
man/man5/groff_font.5
|
||||||
man/man5/groff_out.5
|
man/man5/groff_out.5
|
||||||
man/man5/groff_tmac.5
|
man/man5/groff_tmac.5
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
$NetBSD: distinfo,v 1.16 2011/07/27 16:33:25 tez Exp $
|
$NetBSD: distinfo,v 1.17 2012/05/31 09:24:53 fhajny Exp $
|
||||||
|
|
||||||
SHA1 (groff-1.20.1.tar.gz) = 3066587d73df73c2bda235034f4515cf52d22549
|
SHA1 (groff-1.20.1.tar.gz) = 3066587d73df73c2bda235034f4515cf52d22549
|
||||||
RMD160 (groff-1.20.1.tar.gz) = ec311727206d183fb04f1b4bd01c1284142fdb52
|
RMD160 (groff-1.20.1.tar.gz) = ec311727206d183fb04f1b4bd01c1284142fdb52
|
||||||
|
@ -8,7 +8,7 @@ SHA1 (patch-ab) = 35f8a7f724ab13bedda8ad8bc54bcbede37f12c7
|
||||||
SHA1 (patch-ac) = 7c29e3ca0c0a2e5389ff436ff5c15c9a0a4d7581
|
SHA1 (patch-ac) = 7c29e3ca0c0a2e5389ff436ff5c15c9a0a4d7581
|
||||||
SHA1 (patch-ae) = 777b9b4d5f39da5acf8d79616ae9d42025772fc5
|
SHA1 (patch-ae) = 777b9b4d5f39da5acf8d79616ae9d42025772fc5
|
||||||
SHA1 (patch-config.guess) = 212dccdaed0d96c5d3c7fb126caeba3c3c20f006
|
SHA1 (patch-config.guess) = 212dccdaed0d96c5d3c7fb126caeba3c3c20f006
|
||||||
SHA1 (patch-configure) = 55900f2d427729fe913fe27abbbaec8b728949a7
|
SHA1 (patch-configure) = f27e51ba29331fb351015c2216928940a3148dd3
|
||||||
SHA1 (patch-contrib_eqn2graph_eqn2graph.sh) = 88b8f06f29448dabed66922cc494412662b15431
|
SHA1 (patch-contrib_eqn2graph_eqn2graph.sh) = 88b8f06f29448dabed66922cc494412662b15431
|
||||||
SHA1 (patch-contrib_gdiffmk_tests_runtests.in) = 791c07909912a8ff0c98f6846f14de1fbc0fb7b0
|
SHA1 (patch-contrib_gdiffmk_tests_runtests.in) = 791c07909912a8ff0c98f6846f14de1fbc0fb7b0
|
||||||
SHA1 (patch-contrib_grap2graph_grap2graph.sh) = 5b5a5ac958edc8d4f5e828b57198178bda8bb970
|
SHA1 (patch-contrib_grap2graph_grap2graph.sh) = 5b5a5ac958edc8d4f5e828b57198178bda8bb970
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
$NetBSD: patch-configure,v 1.1 2011/07/19 21:09:38 tez Exp $
|
$NetBSD: patch-configure,v 1.2 2012/05/31 09:24:53 fhajny Exp $
|
||||||
|
|
||||||
Fix many temporary file handling issues, including in pdfroff
|
Fix many temporary file handling issues, including in pdfroff
|
||||||
(resolves CVE-2009-5044 / SA44999)
|
(resolves CVE-2009-5044 / SA44999)
|
||||||
|
@ -9,7 +9,26 @@ that changes a `makeinfo' is too old warning into a fatal error.
|
||||||
|
|
||||||
--- configure.orig 2009-01-09 14:25:52.000000000 +0000
|
--- configure.orig 2009-01-09 14:25:52.000000000 +0000
|
||||||
+++ configure
|
+++ configure
|
||||||
@@ -12937,33 +12937,12 @@ if $ac_need_defaults; then
|
@@ -11598,18 +11598,6 @@ _ACEOF
|
||||||
|
{ $as_echo "$as_me:$LINENO: result: $PAGE" >&5
|
||||||
|
$as_echo "$PAGE" >&6; }
|
||||||
|
|
||||||
|
-{ $as_echo "$as_me:$LINENO: checking for existing troff installation" >&5
|
||||||
|
-$as_echo_n "checking for existing troff installation... " >&6; }
|
||||||
|
- if test "x`(echo .tm '|n(.g' | tr '|' '\\\\' | troff -z -i 2>&1) 2>/dev/null`" = x0; then
|
||||||
|
- { $as_echo "$as_me:$LINENO: result: yes" >&5
|
||||||
|
-$as_echo "yes" >&6; }
|
||||||
|
- g=g
|
||||||
|
- else
|
||||||
|
- { $as_echo "$as_me:$LINENO: result: no" >&5
|
||||||
|
-$as_echo "no" >&6; }
|
||||||
|
- g=
|
||||||
|
- fi
|
||||||
|
-
|
||||||
|
{ $as_echo "$as_me:$LINENO: checking for prefix of system macro packages" >&5
|
||||||
|
$as_echo_n "checking for prefix of system macro packages... " >&6; }
|
||||||
|
sys_tmac_prefix=
|
||||||
|
@@ -12937,33 +12925,12 @@ if $ac_need_defaults; then
|
||||||
test "${CONFIG_HEADERS+set}" = set || CONFIG_HEADERS=$config_headers
|
test "${CONFIG_HEADERS+set}" = set || CONFIG_HEADERS=$config_headers
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue