Update to 2.4.0.

Changes:

        * Layout of the main window can be changed using Layout[123] options.
          Switching between layouts is done using the 'l' key and now TAB is
          used to switch between the playlist and the directory menu. For
          example, you can configure the layout to see both the playlist and a
          directory content.
        * Support for WMA, RealAudio, MP4 and AAC file using FFmpeg.
        * UTF-8 support.
        * Selecting themes at runtime - T command (this does not change the
          config file).
        * Executing external commands, like 'cp %f /mnt/usb_drive' where %f is
          substituted with the path to the currently selected file.
        * Tags are cached at the server side and read in a separate thread.
          The interface is not locked until the tags are read. Size of the
          cache can be adjusted using TagsCacheSize. The cache is saved at exit
          and loaded at startup.
        * Moving items up and down: u and j commands.
        * Workaround for encoding of ID3v1 tags. New options: UseRCC - to use
          librcc for ID3v1 reencoding (Initial patch by Alexey Gladkov),
          ID3v1TagsEncoding - assumed encoding for ID3v1 tags.
        * Added UseCursorSelection option (default: no) to display cursor on
          the selected file. This is useful with braille displays.
        * Added SetXtermTitle option (disable/enable setting xterm title).
        * Added m4a and aac to the list of extensions supported by ffmpeg.
        * Pressing n when nothing is played starts playing from the first item
          on the playlist.
        * Added FollowPlayedFile option: menu follows the currently played file
          so that it is scrolled if the file is outside the visible part
          (default to yes).
        * Numbering items in the playlist. Can be turned off using
          PlaylistNumbering.
        * New themes: moca_theme (Nicola Vitale), red_theme (yyz), and
          darkdot_theme (David Lazar).
        * Added a command for adding a URL to the playlist using entry (CTRL-u).
        * A and --append can add files from playlists.
        * Interface show the playlist after startup if something from the
          playlist is played (CanStartInPlaylist option).
        * Commands: --append, --clear, --play work now as expected even if there
          is no client running.
        * Use full paths instead of just file names for displaying on the
          playlist.
        * Internet streams can be paused.
        * Ogg plugin name was changed to vorbis.
This commit is contained in:
xtraeme 2006-02-12 18:35:55 +00:00
parent 0498f414a1
commit 50ce515b47
5 changed files with 22 additions and 35 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.4 2006/02/05 23:08:12 joerg Exp $
# $NetBSD: Makefile,v 1.5 2006/02/12 18:35:55 xtraeme Exp $
DISTNAME= moc-2.3.2
PKGREVISION= 3
DISTNAME= moc-2.4.0
CATEGORIES= audio
MASTER_SITES= ftp://ftp.daper.net/pub/soft/moc/stable/
EXTRACT_SUFX= .tar.bz2
@ -14,6 +13,7 @@ GNU_CONFIGURE= yes
USE_PKGLOCALEDIR= yes
USE_LIBTOOL= yes
USE_NCURSES= yes
USE_TOOLS+= pkg-config
# We require ncurses because with curses arrow key navigation is buggy
CONFIGURE_ARGS+= --with-ncurses

View file

@ -1,8 +1,8 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/09/26 23:17:32 xtraeme Exp $
@comment $NetBSD: PLIST,v 1.2 2006/02/12 18:35:55 xtraeme Exp $
bin/mocp
${FLAC}lib/moc/decoder_plugins/libflac_decoder.la
lib/moc/decoder_plugins/libmp3_decoder.la
${VORBIS}lib/moc/decoder_plugins/libogg_decoder.la
${VORBIS}lib/moc/decoder_plugins/libvorbis_decoder.la
${SNDFILE}lib/moc/decoder_plugins/libsndfile_formats_decoder.la
${SPEEX}lib/moc/decoder_plugins/libspeex_decoder.la
man/man1/mocp.1
@ -11,9 +11,12 @@ share/doc/moc/THANKS
share/doc/moc/config.example
share/doc/moc/keymap.example
share/moc/themes/black_theme
share/moc/themes/darkdot_theme
share/moc/themes/example_theme
share/moc/themes/green_theme
share/moc/themes/moca_theme
share/moc/themes/nightly_theme
share/moc/themes/red_theme
share/moc/themes/transparent-background
share/moc/themes/yellow_red_theme
@dirrm share/moc/themes

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.3 2005/12/05 20:49:48 rillig Exp $
$NetBSD: distinfo,v 1.4 2006/02/12 18:35:55 xtraeme Exp $
SHA1 (moc-2.3.2.tar.bz2) = ca1a331ea9ea3699d76d4771416587190a814516
RMD160 (moc-2.3.2.tar.bz2) = 1da768dbb625bbeedd960eb7c09c0113eeba7482
Size (moc-2.3.2.tar.bz2) = 406058 bytes
SHA1 (patch-aa) = 3538c7632571a394a4749065ceb5db09b32e24ae
SHA1 (moc-2.4.0.tar.bz2) = 4741fd9098af8b1c375b5232ba460da2077a5cb8
RMD160 (moc-2.4.0.tar.bz2) = 084411d527bbeabd7caaae5acf8a3391a2d07f8f
Size (moc-2.4.0.tar.bz2) = 419792 bytes

View file

@ -1,8 +1,8 @@
# $NetBSD: options.mk,v 1.1.1.1 2005/09/26 23:17:32 xtraeme Exp $
# $NetBSD: options.mk,v 1.2 2006/02/12 18:35:55 xtraeme Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.moc
PKG_SUPPORTED_OPTIONS= sndfile flac vorbis speex curl
PKG_SUGGESTED_OPTIONS= vorbis curl sndfile
PKG_SUPPORTED_OPTIONS= sndfile flac vorbis speex curl samplerate
PKG_SUGGESTED_OPTIONS= sndfile flac vorbis curl
.include "../../mk/bsd.options.mk"
@ -48,3 +48,10 @@ CONFIGURE_ARGS+= --with-curl
.else
CONFIGURE_ARGS+= --without-curl
.endif
.if !empty(PKG_OPTIONS:Msamplerate)
CONFIGURE_ARGS+= --with-samplerate
. include "../../audio/libsamplerate/buildlink3.mk"
.else
CONFIGURE_ARGS+= --without-samplerate
.endif

View file

@ -1,22 +0,0 @@
$NetBSD: patch-aa,v 1.2 2005/12/05 20:49:48 rillig Exp $
--- player.c.orig 2005-09-09 08:20:13.000000000 +0000
+++ player.c
@@ -355,7 +355,7 @@ static void show_tags (const struct file
static void update_tags (const struct decoder *f, void *decoder_data,
struct io_stream *s)
{
- char *stream_title;
+ char *stream_title = NULL;
int tags_changed = 0;
struct file_tags *new_tags;
@@ -378,6 +378,8 @@ static void update_tags (const struct de
show_tags (curr_tags);
tags_changed = 1;
}
+ else if (stream_title)
+ free (stream_title);
if (tags_changed)
tags_change ();