Update to 2.6.0. From the changelog:

Added support for STARTTLS, similar to the way SMTP AUTH is implemented -- if
    a server certificate is available, spamdyke takes care of the TLS.  If not
    but qmail supports TLS, spamdyke passes it through.
  Changed the read() and write() calls to the network to use macros named
    NETWORK_READ() and NETWORK_WRITE() that are replaced by TLS routines when
    TLS support has been compiled in.
  Changed the smtp_filter() return codes to use a mask/flag system because the
    possible permutations of PASS/INTERCEPT/QUIT with ADD/REMOVE/CAPTURE AUTH
    and ADD/REMOVE/CAPTURE TLS and CHILD QUIT/CONTINUE were getting too complex.
  Fixed search_file() to match a file entry where the search text matches the
    entry completely but the entry has wildcard markers at the start and/or end.
  Added TLS support to tests/sendrecv so TLS can be tested from scripts.
  Fixed numerous small bugs in tests/sendrecv that were causing inaccurate test
    results (false positives and false negatives).
  Updated all of the test scripts to make renumbering them easier.
  Added a new test script to exercise a small whitelist wildcard bug I found.
  Added 10 new test scripts to exercise the new TLS features.
  Changed process_command_line() and usage() to print a brief usage message if
    no parameters are given.
  Changed process_command_line() and usage() to print a brief error message if
    a bad parameter is given.
  Changed process_command_line() and usage() to print the full usage message if
    -h or --help is given.
  Changed process_command_line() and usage() to print the version header if -v
    or --version is given.
  Renamed test_smtpauth_crammd5, test_smtpauth_login and test_smtpauth_plain to
    smtpauth_crammd5, smtpauth_login and smtpauth_plain, respectively.
  Moved smtpauth_crammd5, smtpauth_login and smtpauth_plain from the utils
    folder to tests/smtpauth, since they're only used by the test scripts
    anyway.
  Added alternate command line options for people who spell "gray" with an "e".
    They do the same thing.
  Updated the documentation.
This commit is contained in:
schmonz 2007-05-30 05:58:10 +00:00
parent a86d0c4241
commit 50d9979579
6 changed files with 41 additions and 25 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.4 2007/05/07 19:43:43 schmonz Exp $
# $NetBSD: Makefile,v 1.5 2007/05/30 05:58:10 schmonz Exp $
#
DISTNAME= spamdyke-2.5.0
DISTNAME= spamdyke-2.6.0
CATEGORIES= mail
MASTER_SITES= ${HOMEPAGE}releases/
EXTRACT_SUFX= .tgz
@ -11,7 +11,6 @@ HOMEPAGE= http://freesoftware.silence.org/spamdyke/
COMMENT= Monitors and intercept incoming SMTP connections to qmail
BUILD_DIRS= ${PKGBASE} utils
BUILD_TARGET= bsd
SUBST_CLASSES+= paths
SUBST_FILES.paths= ${PKGBASE}/spamdyke.c
@ -20,6 +19,8 @@ SUBST_STAGE.paths= do-configure
INSTALLATION_DIRS= bin share/doc/${PKGBASE}
.include "options.mk"
do-install:
cd ${WRKSRC}/${PKGBASE}; \
for f in spamdyke; do \

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.3 2007/05/07 19:43:45 schmonz Exp $
$NetBSD: distinfo,v 1.4 2007/05/30 05:58:10 schmonz Exp $
SHA1 (spamdyke-2.5.0.tgz) = 3f10ed0b68685460098e74a6a79f46cb41a3af26
RMD160 (spamdyke-2.5.0.tgz) = afdfee18de2cc59af2e4934e85836dd7782eec35
Size (spamdyke-2.5.0.tgz) = 89150 bytes
SHA1 (patch-aa) = e11c9ae13da56742acbfd02aff8bfd2ebc99b146
SHA1 (patch-ab) = be3c21036ca5347f730fc1969c423d849cf9d64f
SHA1 (patch-ac) = bc49c93a517631bc3af5125b93dc5528623f5a9c
SHA1 (spamdyke-2.6.0.tgz) = 1dd4f50c42f31575d087efd70836421a7c9e7acf
RMD160 (spamdyke-2.6.0.tgz) = 38ea92003e5602c02969f9925f883216e7296bdd
Size (spamdyke-2.6.0.tgz) = 109459 bytes
SHA1 (patch-aa) = 34f349594339f4a2df360249a7696dfbaab03ab7
SHA1 (patch-ab) = e92e9ed2265debd1bf3607d83c3645a37acb4ffe
SHA1 (patch-ac) = 063c5c98d553f3e173b8c87c7ca24661264bb4cc

15
mail/spamdyke/options.mk Normal file
View file

@ -0,0 +1,15 @@
# $NetBSD: options.mk,v 1.1 2007/05/30 05:58:10 schmonz Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.spamdyke
PKG_SUPPORTED_OPTIONS= tls
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Mtls)
. include "../../security/openssl/buildlink3.mk"
MAKE_ENV+= CFLAGS_TLS="-DTLS"
MAKE_ENV+= LFLAGS_TLS="-lssl -lcrypto"
.else
MAKE_ENV+= CFLAGS_TLS=""
MAKE_ENV+= LFLAGS_TLS=""
.endif

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.3 2007/05/07 19:43:45 schmonz Exp $
$NetBSD: patch-aa,v 1.4 2007/05/30 05:58:11 schmonz Exp $
--- spamdyke/spamdyke.h.orig 2007-05-04 18:18:03.000000000 -0400
--- spamdyke/spamdyke.h.orig 2007-05-24 22:26:48.000000000 -0400
+++ spamdyke/spamdyke.h
@@ -22,7 +22,7 @@
@@ -32,7 +32,7 @@
#define STRLEN(X) (sizeof(X) - 1)

View file

@ -1,16 +1,16 @@
$NetBSD: patch-ab,v 1.2 2007/05/07 19:43:52 schmonz Exp $
$NetBSD: patch-ab,v 1.3 2007/05/30 05:58:11 schmonz Exp $
--- spamdyke/Makefile.orig 2007-05-04 18:22:40.000000000 -0400
--- spamdyke/Makefile.orig 2007-05-24 18:55:10.000000000 -0400
+++ spamdyke/Makefile
@@ -1,8 +1,10 @@
@@ -1,8 +1,8 @@
#CFLAGS := -Wall -g -funsigned-char
-CFLAGS := -Wall -O2 -funsigned-char
+CFLAGS += -Wall -O2 -funsigned-char
LFLAGS := -lresolv
OFILES := spamdyke.o command_line.o dns.o environment.o usage.o search_fs.o exec.o base64.o
-CFLAGS_TLS := -DTLS
-LFLAGS_TLS := -lssl -lcrypto
+CFLAGS_TLS ?= -DTLS
+LFLAGS_TLS ?= -lssl -lcrypto
OFILES := spamdyke.o command_line.o dns.o environment.o usage.o search_fs.o exec.o base64.o tls.o
+all: spamdyke
+
spamdyke: $(OFILES)
@echo -----------------------------------------
@echo NOTE: To compile on *BSD, run "make bsd".
all:

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ac,v 1.2 2007/05/07 19:43:52 schmonz Exp $
$NetBSD: patch-ac,v 1.3 2007/05/30 05:58:11 schmonz Exp $
--- utils/Makefile.orig 2007-05-04 10:28:13.000000000 -0400
--- utils/Makefile.orig 2007-05-25 10:37:47.000000000 -0400
+++ utils/Makefile
@@ -1,5 +1,5 @@
#CFLAGS := -Wall -g -funsigned-char -I../spamdyke
@ -8,4 +8,4 @@ $NetBSD: patch-ac,v 1.2 2007/05/07 19:43:52 schmonz Exp $
+CFLAGS += -Wall -O2 -funsigned-char -I../spamdyke
LFLAGS := -lresolv
all: domain2path domainsplit dnstxt dnsptr dnsmx test_smtpauth_plain test_smtpauth_login test_smtpauth_crammd5
all: domain2path domainsplit dnstxt dnsptr dnsmx