net/synergy1.2: Fix regression on DragonFly

The previous changeset, "Fix issues with new GCC" overwrote the existing
patch-ab which dealt with pre-existing alloca definitions.  Incorporate
the old patch-ab into the current patch-ab to fix regression.
This commit is contained in:
marino 2012-08-08 13:42:42 +00:00
parent 336dce041b
commit 50e41292c1
2 changed files with 13 additions and 4 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.4 2011/11/22 20:07:20 joerg Exp $
$NetBSD: distinfo,v 1.5 2012/08/08 13:42:42 marino Exp $
SHA1 (synergy-1.2.7.tar.gz) = 5964460892fd9e9cb55c5bfe4e781f2bc08d0b76
RMD160 (synergy-1.2.7.tar.gz) = 6bdbe5adbc13c2f49afcb99ccaa20b96a12c2bcf
Size (synergy-1.2.7.tar.gz) = 707319 bytes
SHA1 (patch-aa) = 5a48140c7622195a716eededae2d1ee0f6fa4e85
SHA1 (patch-ab) = 011deedba1d2a793ff4add4196c8a10708e864f5
SHA1 (patch-ab) = 24f611bc942b6c0dac8e3d398150e5a8bb44ebd6
SHA1 (patch-lib-arch-CArchDaemonUnix.cpp) = 1d11d87f9a388ba68403ff74d4fcd5fa180a919e
SHA1 (patch-lib_arch_CMultibyte.cpp) = 66cc7cd1e327a1bfd519cb003835914221cbb369
SHA1 (patch-lib_base_CStringUtil.cpp) = 8f803bcab5a37bd4bf5a918fe3333338bd7d22c2

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ab,v 1.2 2011/11/22 20:07:20 joerg Exp $
$NetBSD: patch-ab,v 1.3 2012/08/08 13:42:42 marino Exp $
--- lib/arch/CArchNetworkBSD.cpp.orig 2011-11-22 19:34:07.000000000 +0000
--- lib/arch/CArchNetworkBSD.cpp.orig 2005-07-28 01:50:02.000000000 +0000
+++ lib/arch/CArchNetworkBSD.cpp
@@ -28,6 +28,7 @@
#include <fcntl.h>
@ -10,3 +10,12 @@ $NetBSD: patch-ab,v 1.2 2011/11/22 20:07:20 joerg Exp $
#if HAVE_POLL
# include <poll.h>
@@ -50,6 +51,8 @@
#if HAVE_ALLOCA_H
# define freea(x_)
#else
+# undef alloca
+# undef freea
# define alloca(x_) malloc(x_)
# define freea(x_) free(x_)
#endif