A program to download pictures from some Fujifilm digital cameras,

like the DS-7, MX-500 and MX-700, using the serial link.  It can
also "press the shutter", upload images to the camera, or delete
images from the camera.
This commit is contained in:
hubertf 1999-11-23 04:22:13 +00:00
parent 1a957f6370
commit 50ec168598
7 changed files with 54 additions and 0 deletions

View file

@ -0,0 +1,24 @@
# $NetBSD: Makefile,v 1.1.1.1 1999/11/23 04:22:13 hubertf Exp $
#
DISTNAME= fujiplay
PKGNAME= fujiplay-1.33
CATEGORIES= graphics
MASTER_SITES= http://topo.math.u-psud.fr/~bousch/
EXTRACT_SUFX= .tgz
MAINTAINER= hubertf@netbsd.org
HOMEPAGE= http://topo.math.u-psud.fr/~bousch/fujiplay.html
NO_WRKSUBDIR= yes
DIST_SUBDIR= fujiplay-1.33
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fujiplay ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/yycc2ppm ${PREFIX}/bin
${INSTALL_MAN_DIR} ${PREFIX}/share/doc/fujiplay
${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/fujiplay
${INSTALL_MAN} ${WRKSRC}/fujiplay.lsm ${PREFIX}/share/doc/fujiplay
${INSTALL_MAN} ${WRKSRC}/mx700-commands.html ${PREFIX}/share/doc/fujiplay
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 1999/11/23 04:22:13 hubertf Exp $
MD5 (fujiplay-1.33/fujiplay.tgz) = b5702d555813853ff63918ed285c4cdd

View file

@ -0,0 +1,3 @@
$NetBSD: patch-sum,v 1.1.1.1 1999/11/23 04:22:13 hubertf Exp $
MD5 (patch-aa) = e34ea6f281172bdb35d67235960cc7a3

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 1999/11/23 04:22:13 hubertf Exp $
--- fujiplay.c.orig Tue Nov 23 04:55:05 1999
+++ fujiplay.c Tue Nov 23 04:58:42 1999
@@ -35,7 +35,7 @@
#define B115200 EXTB
#endif
-#define DEFAULT_DEVICE "/dev/fujifilm"
+#define DEFAULT_DEVICE "/dev/tty00"
#define TMP_PIC_FILE ".dsc_temp"
struct pict_info {

View file

@ -0,0 +1 @@
Download pictures from some Fujifilm digital cameras

View file

@ -0,0 +1,4 @@
A program to download pictures from some Fujifilm digital cameras,
like the DS-7, MX-500 and MX-700, using the serial link. It can
also "press the shutter", upload images to the camera, or delete
images from the camera.

View file

@ -0,0 +1,6 @@
@comment $NetBSD: PLIST,v 1.1.1.1 1999/11/23 04:22:13 hubertf Exp $
bin/fujiplay
bin/yycc2ppm
share/doc/fujiplay/README
share/doc/fujiplay/fujiplay.lsm
share/doc/fujiplay/mx700-commands.html