Updated to 0.8.4
- MASTER_SITES changed - HOMEPAGE changed - added LICENSE - added gmake to USE_TOOLS - added USE_LANGUAGES+= c c++
This commit is contained in:
parent
6adb808897
commit
513d63b44b
5 changed files with 40 additions and 38 deletions
|
@ -1,20 +1,22 @@
|
|||
# $NetBSD: Makefile,v 1.4 2009/08/26 19:57:21 sno Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2009/11/26 19:51:14 imil Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libcompizconfig-0.6.0
|
||||
PKGREVISION= 1
|
||||
PKGVER= 0.8.4
|
||||
DISTNAME= libcompizconfig-${PKGVER}
|
||||
CATEGORIES= devel gnome
|
||||
MASTER_SITES= http://releases.compiz-fusion.org/0.6.0/
|
||||
MASTER_SITES= http://releases.compiz.org/${PKGVER}/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.compiz-fusion.org/
|
||||
HOMEPAGE= http://compiz.org/
|
||||
COMMENT= Configuration backend for compiz
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config perl intltool
|
||||
USE_TOOLS+= pkg-config perl intltool gmake
|
||||
USE_LANGUAGES+= c c++
|
||||
|
||||
PKG_SYSCONFSUBDIR?= compizconfig
|
||||
EGDIR= ${PREFIX}/share/examples/compizconfig
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2009/06/14 17:48:51 joerg Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2009/11/26 19:51:14 imil Exp $
|
||||
include/compizconfig/ccs-backend.h
|
||||
include/compizconfig/ccs.h
|
||||
lib/compiz/libccp.la
|
||||
lib/compizconfig/backends/libini.la
|
||||
lib/libcompizconfig.la
|
||||
lib/pkgconfig/libcompizconfig.pc
|
||||
share/compizconfig/global.xml
|
||||
share/compiz/ccp.xml
|
||||
share/examples/compizconfig/config
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2008/05/12 10:38:01 jmcneill Exp $
|
||||
$NetBSD: distinfo,v 1.2 2009/11/26 19:51:14 imil Exp $
|
||||
|
||||
SHA1 (libcompizconfig-0.6.0.tar.gz) = c7b1e9c113de5efcea6d4d24fa2c18dd2b5b69ab
|
||||
RMD160 (libcompizconfig-0.6.0.tar.gz) = 415ce28c18fdd8f85ca3e6b3aa68ec485ea98cca
|
||||
Size (libcompizconfig-0.6.0.tar.gz) = 430209 bytes
|
||||
SHA1 (patch-aa) = 04ce01b4ca33a1358998bd11a0b56e3f44870192
|
||||
SHA1 (patch-ab) = d23fe219edb631cd3d959a2b23a706b5829e643e
|
||||
SHA1 (libcompizconfig-0.8.4.tar.gz) = d0c1c7e233dfec6da069e6a9eed6a9a1c56498f4
|
||||
RMD160 (libcompizconfig-0.8.4.tar.gz) = 210393bde3b44a8427040c43e12a009f80cede59
|
||||
Size (libcompizconfig-0.8.4.tar.gz) = 403652 bytes
|
||||
SHA1 (patch-aa) = c12936ee46eddf4418fd5d7ccf720ffc9a423f50
|
||||
SHA1 (patch-ab) = b69b60e3c77262526bb01192b1a5f4d719368003
|
||||
|
|
|
@ -1,15 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2008/05/12 10:38:01 jmcneill Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2009/11/26 19:51:14 imil Exp $
|
||||
|
||||
--- src/main.c.orig 2008-05-12 06:16:43.000000000 -0400
|
||||
+++ src/main.c
|
||||
@@ -38,6 +38,10 @@
|
||||
#include "ccs-private.h"
|
||||
#include "iniparser.h"
|
||||
--- config/Makefile.in.orig 2009-11-26 11:26:00.000000000 +0000
|
||||
+++ config/Makefile.in
|
||||
@@ -204,7 +204,7 @@ target_alias = @target_alias@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-globalconfigdir = $(sysconfdir)/compizconfig
|
||||
+globalconfigdir = ${prefix}/share/examples/compizconfig
|
||||
globalconfig_DATA = \
|
||||
config
|
||||
|
||||
+#ifndef RTLD_NODELETE
|
||||
+#define RTLD_NODELETE 0
|
||||
+#endif
|
||||
+
|
||||
Bool basicMetadata = FALSE;
|
||||
|
||||
void
|
||||
|
|
|
@ -1,13 +1,15 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2008/05/12 10:38:01 jmcneill Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2009/11/26 19:51:14 imil Exp $
|
||||
|
||||
--- config/Makefile.in.orig 2008-05-12 06:21:33.000000000 -0400
|
||||
+++ config/Makefile.in 2008-05-12 06:26:00.000000000 -0400
|
||||
@@ -214,7 +214,7 @@
|
||||
target_alias = @target_alias@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-globalconfigdir = $(sysconfdir)/compizconfig
|
||||
+globalconfigdir = ${prefix}/share/examples/compizconfig
|
||||
globalconfig_DATA = \
|
||||
config
|
||||
--- src/main.c.orig 2009-11-26 11:24:46.000000000 +0000
|
||||
+++ src/main.c
|
||||
@@ -38,6 +38,10 @@
|
||||
#include "ccs-private.h"
|
||||
#include "iniparser.h"
|
||||
|
||||
+#ifndef RTLD_NODELETE
|
||||
+#define RTLD_NODELETE 0
|
||||
+#endif
|
||||
+
|
||||
Bool basicMetadata = FALSE;
|
||||
|
||||
void
|
||||
|
|
Loading…
Reference in a new issue