Let users install packages from OctaveForge:
provide path to GNU make which is assumed there.
This commit is contained in:
parent
eb3010d35d
commit
517199494b
3 changed files with 27 additions and 4 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.104 2012/10/03 21:56:36 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.105 2012/10/27 13:01:35 asau Exp $
|
||||
|
||||
DISTNAME= octave-${OCTAVE_VER}
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= $(MASTER_SITE_GNU:=octave/) \
|
||||
ftp://ftp.octave.org/pub/octave/ \
|
||||
|
@ -24,7 +24,7 @@ BROKEN= Internal compiler error occurs on arm32 (even with gcc-2.95.3)
|
|||
|
||||
USE_GNU_READLINE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= autoconf gsed gmake makeinfo perl pkg-config bison
|
||||
USE_TOOLS+= autoconf gsed gmake:run makeinfo perl pkg-config bison
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
GCC_REQD+= 3.0
|
||||
|
@ -71,6 +71,12 @@ SUBST_MESSAGE.unwrapping= Unwrapping wrapper scripts.
|
|||
SUBST_FILES.unwrapping= src/mkoctfile
|
||||
SUBST_SED.unwrapping= -e 's:$(DESTDIR)::g' -e 's:$(BUILDLINK_DIR)/lib:$(PREFIX)/lib:g'
|
||||
|
||||
SUBST_CLASSES+= fix-make
|
||||
SUBST_STAGE.fix-make= post-patch
|
||||
SUBST_MESSAGE.fix-make= Fixing path to gmake.
|
||||
SUBST_FILES.fix-make= scripts/pkg/pkg.m
|
||||
SUBST_SED.fix-make= -e 's:@GMAKE@:$(GMAKE):g'
|
||||
|
||||
post-extract:
|
||||
find ${WRKSRC}/doc -type f -name '*.info*' -print | xargs rm -f
|
||||
mkdir ${WRKSRC}/src/pic
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.34 2012/09/13 23:39:14 asau Exp $
|
||||
$NetBSD: distinfo,v 1.35 2012/10/27 13:01:35 asau Exp $
|
||||
|
||||
SHA1 (octave-3.6.3.tar.bz2) = e8bd0c0b33ab9714ddb524f2258546c3536f0628
|
||||
RMD160 (octave-3.6.3.tar.bz2) = 1b0f75da1efc77cef0698a7affe56a477430cc1f
|
||||
|
@ -7,4 +7,5 @@ SHA1 (patch-fflush-fpos_t.c) = 24ed7f95f8431b59bc5ee0dfb0e6624b8029f512
|
|||
SHA1 (patch-fseeko-fpos_t.c) = ca846a014f9adfd47f7bbcf6557bf26a53f4a8e9
|
||||
SHA1 (patch-libgnu_string.in.h) = 4af39b76faa3ac90454a9d664919b7a6cd45fa9d
|
||||
SHA1 (patch-liboctave_oct-time.cc) = 40c21f509b6c95942e6ba43c52494d1d707ed515
|
||||
SHA1 (patch-scripts_pkg_pkg.m) = e6fa838e3910d52164d7cb3ca084c748cd68abb9
|
||||
SHA1 (patch-src_oct-conf.h.in) = d3fa5166db289fbd9eba355911341e891fb6d822
|
||||
|
|
16
math/octave/patches/patch-scripts_pkg_pkg.m
Normal file
16
math/octave/patches/patch-scripts_pkg_pkg.m
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-scripts_pkg_pkg.m,v 1.1 2012/10/27 13:01:35 asau Exp $
|
||||
|
||||
Provide path to GNU make, since this is what assumed here.
|
||||
|
||||
--- scripts/pkg/pkg.m.orig 2012-03-09 21:20:48.000000000 +0000
|
||||
+++ scripts/pkg/pkg.m
|
||||
@@ -1379,7 +1379,8 @@ function configure_make (desc, packdir,
|
||||
|
||||
## Make.
|
||||
if (exist (fullfile (src, "Makefile"), "file"))
|
||||
- [status, output] = shell (cstrcat (scenv, "make -C '", src, "'"));
|
||||
+ make = "@GMAKE@"
|
||||
+ [status, output] = shell (cstrcat (scenv, make, " -C '", src, "'"));
|
||||
if (status != 0)
|
||||
rm_rf (desc.dir);
|
||||
error ("'make' returned the following error: %s", output);
|
Loading…
Reference in a new issue