xentools{42,45,46,48}: don't force SSP. fixes build.

xentools42: avoid %m in printf, use strerror instead. bump PKGREVISION.
I still can't build it due to other new warnings (it uses -Werror)
This commit is contained in:
maya 2017-07-24 11:37:49 +00:00
parent 3f80f489d9
commit 5179bc504b
6 changed files with 37 additions and 15 deletions

View file

@ -1,11 +1,11 @@
# $NetBSD: Makefile,v 1.58 2017/07/11 14:19:21 jaapb Exp $
# $NetBSD: Makefile,v 1.59 2017/07/24 11:37:49 maya Exp $
VERSION= 4.2.5
VERSION_IPXE= 1.0.0
DISTNAME= xen-${VERSION}
PKGNAME= xentools42-${VERSION}
PKGREVISION= 22
PKGREVISION= 23
CATEGORIES= sysutils
MASTER_SITES= https://downloads.xenproject.org/release/xen/${VERSION}/
@ -33,9 +33,9 @@ PKG_SYSCONFSUBDIR= xen
ONLY_FOR_PLATFORM= Linux-2.6*-i386 Linux-2.6*-x86_64
ONLY_FOR_PLATFORM+= NetBSD-[5-9].*-x86_64 NetBSD-[5-9].*-i386
PKGSRC_USE_SSP= no
CONFLICTS+= libxen-[0-9]*
CONFLICTS+= xentools20-[0-9]*
CONFLICTS+= xentools3-[0-9]*
CONFLICTS+= xenstoretools-[0-9]*
XENTOP= ${WRKDIR}/xen-${VERSION}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.32 2017/07/01 00:40:30 kamil Exp $
$NetBSD: distinfo,v 1.33 2017/07/24 11:37:49 maya Exp $
SHA1 (ipxe-git-v1.0.0.tar.gz) = da052c8de5f3485fe0253c19cf52ed6d72528485
RMD160 (ipxe-git-v1.0.0.tar.gz) = dcd9b6eaafa1ce05c1ebf2a15f2f73ad7a8c5547
@ -46,6 +46,7 @@ SHA1 (patch-XSA-199) = e34c7557a1df7131000f5e408e89d3aaa4b10189
SHA1 (patch-blktap_drivers_Makefile) = c6be57154a403a64e3d6bc22d6bd833fe33fc9af
SHA1 (patch-blktap_lib_blktaplib.h) = 571e35081df24785ae67133b04d2b0ff016a0ded
SHA1 (patch-configure) = 11df58a8e1cd6bcc319db0aff508367e59592cba
SHA1 (patch-console_daemon_utils.c) = 362966402e4925a37b400e324e59af738b65cafc
SHA1 (patch-examples_Makefile) = ee02f973416ca4ffda5381cd7a4ddb3b43579621
SHA1 (patch-examples_xend-config.sxp) = 1c3423b6eead47f09768d571a65891caed12aa99
SHA1 (patch-firmware_etherboot_Makefile) = 9928566768b20d9400d8df379c09b30ba60b2575

View file

@ -0,0 +1,22 @@
$NetBSD: patch-console_daemon_utils.c,v 1.1 2017/07/24 11:37:49 maya Exp $
Avoid GNU extension %m in printf
--- console/daemon/utils.c.orig 2014-09-02 06:22:57.000000000 +0000
+++ console/daemon/utils.c
@@ -113,13 +113,13 @@ bool xen_setup(void)
xs = xs_daemon_open();
if (xs == NULL) {
dolog(LOG_ERR,
- "Failed to contact xenstore (%m). Is it running?");
+ "Failed to contact xenstore (%s). Is it running?", strerror(errno));
goto out;
}
xc = xc_interface_open(0,0,0);
if (!xc) {
- dolog(LOG_ERR, "Failed to contact hypervisor (%m)");
+ dolog(LOG_ERR, "Failed to contact hypervisor (%s)", strerror(errno));
goto out;
}

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.48 2017/07/11 14:19:21 jaapb Exp $
# $NetBSD: Makefile,v 1.49 2017/07/24 11:37:49 maya Exp $
VERSION= 4.5.5
PKGREVISION= 5
@ -30,9 +30,9 @@ PKG_SYSCONFSUBDIR= xen
ONLY_FOR_PLATFORM= Linux-2.6*-x86_64
ONLY_FOR_PLATFORM+= NetBSD-[5-9].*-x86_64
PKGSRC_USE_SSP= no
CONFLICTS+= libxen-[0-9]*
CONFLICTS+= xentools20-[0-9]*
CONFLICTS+= xentools3-[0-9]*
CONFLICTS+= xenstoretools-[0-9]*
XENTOP= ${WRKDIR}/xen-${VERSION}

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.17 2017/07/11 14:19:21 jaapb Exp $
# $NetBSD: Makefile,v 1.18 2017/07/24 11:37:50 maya Exp $
#
# VERSION is set in version.mk as it is shared with other packages
.include "version.mk"
@ -30,9 +30,9 @@ PKG_SYSCONFSUBDIR= xen
ONLY_FOR_PLATFORM= Linux-2.6*-x86_64
ONLY_FOR_PLATFORM+= NetBSD-[5-9].*-x86_64
PKGSRC_USE_SSP= no
CONFLICTS+= libxen-[0-9]*
CONFLICTS+= xentools20-[0-9]*
CONFLICTS+= xentools3-[0-9]*
CONFLICTS+= xenstoretools-[0-9]*
XENTOP= ${WRKDIR}/xen-${VERSION}

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.4 2017/07/11 14:19:21 jaapb Exp $
# $NetBSD: Makefile,v 1.5 2017/07/24 11:37:50 maya Exp $
#
VERSION= 4.8.0
VERSION_IPXE= 827dd1bfee67daa683935ce65316f7e0f057fe1c
@ -17,7 +17,6 @@ DIST_SUBDIR= xen48
DISTNAME= xen-${VERSION}
PKGNAME= xentools48-${VERSION}
PKGREVISION= 1
#PKGREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= https://downloads.xenproject.org/release/xen/${VERSION}/
@ -71,9 +70,9 @@ PKG_SYSCONFSUBDIR= xen
ONLY_FOR_PLATFORM= Linux-2.6*-x86_64
ONLY_FOR_PLATFORM+= NetBSD-[5-9].*-x86_64
PKGSRC_USE_SSP= no
CONFLICTS+= libxen-[0-9]*
CONFLICTS+= xentools20-[0-9]*
CONFLICTS+= xentools3-[0-9]*
CONFLICTS+= xenstoretools-[0-9]*
CHECK_PORTABILITY_SKIP= tools/examples/* \