Bump to 1.0nb1: Fix bug in handling of masquerading.

Original patch by Simas Mockevicius <symka@vejas.lt>
This commit is contained in:
hubertf 2003-10-07 19:35:34 +00:00
parent d2e5585bad
commit 51a52b7184
3 changed files with 19 additions and 11 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.6 2003/07/17 22:51:28 grant Exp $
# $NetBSD: Makefile,v 1.7 2003/10/07 19:35:34 hubertf Exp $
#
DISTNAME= nidentd-1.0
PKGREVISION= 1
CATEGORIES= net sysutils
MASTER_SITES= ftp://ftp.tgr.lubin.edu.pl/pub/NetBSD/nidentd/
EXTRACT_SUFX= .tgz

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.3 2002/05/05 23:51:27 hubertf Exp $
$NetBSD: distinfo,v 1.4 2003/10/07 19:35:34 hubertf Exp $
SHA1 (nidentd-1.0.tgz) = 5ad5f5f27514a9b647f00bdd8f132203c29987be
Size (nidentd-1.0.tgz) = 1831 bytes
SHA1 (patch-aa) = 3fed5dab21289532f36f44d2eb4594f241eb0130
SHA1 (patch-aa) = af6041e9ce57c86fe09d085bcf6349cf1d3939ac

View file

@ -1,17 +1,24 @@
$NetBSD: patch-aa,v 1.3 2002/05/05 23:51:28 hubertf Exp $
$NetBSD: patch-aa,v 1.4 2003/10/07 19:35:34 hubertf Exp $
--- nidentd.orig Mon May 6 00:37:54 2002
--- nidentd.orig Sat May 4 14:53:01 2002
+++ nidentd
@@ -1,9 +1,9 @@
#!/bin/sh
@@ -2,8 +2,8 @@
-v_lsof="/usr/pkg/sbin/lsof -P -n -Di"
+v_lsof="@LOCALBASE@/sbin/lsof -P -n -Di"
v_lsof="/usr/pkg/sbin/lsof -P -n -Di"
v_ipnat="/usr/sbin/ipnat -l"
-v_nat_conf="/usr/local/etc/nidentd.nat"
-v_fake_conf="/usr/local/etc/nidentd.fake"
+v_nat_conf="@LOCALBASE@/etc/nidentd.nat"
+v_fake_conf="@LOCALBASE@/etc/nidentd.fake"
+v_nat_conf="/usr/pkg/etc/nidentd.nat"
+v_fake_conf="/usr/pkg/etc/nidentd.fake"
# Protocol independent
@@ -40,7 +40,7 @@ if [ -n $qlport ] && [ -n $qrport ] && [
if [ $qlport -eq $lport ] && [ $qrport -eq $rport ]
then
masqip=`$v_ipnat -l | grep -e "MAP" -e " $qlport " -e " $qrport" | awk '{ print $2 }' | tr -c -d '.1234567890'`
- hostn=`grep ^$masqip $v_nat_conf | awk -F: '{ print $2 }'`
+ hostn=`grep ^"$masqip:" $v_nat_conf | awk -F: '{ print $2 }'`
if [ $hostn ]
then
printf "$qlport , $qrport : USERID : UNIX : $hostn\r\n"