miniupnpc: Hack around build failure on NetBSD

sed 's/\(.*MINIUPNPC_API_VERSION\s\+\)[0-9]\+/\117/' < miniupnpc.h.bak > miniupnpc.h
sed: 1: "s/\(.*MINIUPNPC_API_VER ...": RE error: trailing backslash (\)

I held back on updating this package because of exactly this error...
This commit is contained in:
nia 2021-06-10 16:45:22 +00:00
parent 6a4fb3e9c9
commit 51a6451110
2 changed files with 15 additions and 5 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.6 2021/06/04 18:57:46 adam Exp $
$NetBSD: distinfo,v 1.7 2021/06/10 16:45:22 nia Exp $
SHA1 (miniupnpc-2.2.2.tar.gz) = a8e4415d99a9bee9321cb5fc30ac1d048d602af5
RMD160 (miniupnpc-2.2.2.tar.gz) = 8818a5a5c607618cceaa11780287c25f4e2101fa
SHA512 (miniupnpc-2.2.2.tar.gz) = d322ae2a99faf01bee52f50a40d4bc2150c67a2f7e15b6078fe92faf2aecfe7ce10bd98cef3d94a77f6f7d1f7d8451cf4cdbf6fe11c9e7c1854ee066300b0116
Size (miniupnpc-2.2.2.tar.gz) = 100008 bytes
SHA1 (patch-Makefile) = 646f3747de66e8451667411ad605877e61fd6c32
SHA1 (patch-Makefile) = ff725105ef51547e586f705d47cdc4eb2cf52e51
SHA1 (patch-minissdpc.c) = 183fcebe7a94acb596db6ef03ee7663532808108
SHA1 (patch-miniwget.c) = 6bf80bc09af904c10a9ad1dc226115070860cf11
SHA1 (patch-upnpc.c) = 65a0f801de3ce41aa74a143c112e0dbd4a972dcb

View file

@ -1,9 +1,10 @@
$NetBSD: patch-Makefile,v 1.3 2018/10/03 22:27:05 nia Exp $
$NetBSD: patch-Makefile,v 1.4 2021/06/10 16:45:22 nia Exp $
Do not pick pkgsrc libtool on Darwin.
Use correct installation dirs.
Avoid non-portable sed in updateversion.
--- Makefile.orig 2018-04-06 10:53:30.000000000 +0000
--- Makefile.orig 2020-11-27 18:25:02.000000000 +0000
+++ Makefile
@@ -15,7 +15,7 @@ VERSION = $(shell cat VERSION)
@ -14,7 +15,7 @@ Use correct installation dirs.
endif
ifneq (, $(findstring linux, $(OS)))
JARSUFFIX=linux
@@ -149,7 +149,7 @@ endif
@@ -155,7 +155,7 @@ endif
INSTALLDIRINC = $(INSTALLPREFIX)/include/miniupnpc
INSTALLDIRLIB = $(INSTALLPREFIX)/$(LIBDIR)
INSTALLDIRBIN = $(INSTALLPREFIX)/bin
@ -23,3 +24,12 @@ Use correct installation dirs.
PKGCONFIGDIR = $(INSTALLDIRLIB)/pkgconfig
FILESTOINSTALL = $(LIBRARY) $(EXECUTABLES)
@@ -242,7 +242,7 @@ updateversion: miniupnpc.h
cp miniupnpc.h miniupnpc.h.bak
sed 's/\(.*MINIUPNPC_API_VERSION\s\+\)[0-9]\+/\1$(APIVERSION)/' < miniupnpc.h.bak > miniupnpc.h
-install: updateversion $(FILESTOINSTALL)
+install: $(FILESTOINSTALL)
$(INSTALL) -d $(DESTDIR)$(INSTALLDIRINC)
$(INSTALL) -m 644 $(HEADERS) $(DESTDIR)$(INSTALLDIRINC)
$(INSTALL) -d $(DESTDIR)$(INSTALLDIRLIB)