Fix broken build with gcc4 (and maybe not just with gcc4...)
Add missing dependence on freetype2. PKGREVISION++
This commit is contained in:
parent
af5551f80f
commit
51ec3cdb2c
7 changed files with 88 additions and 3 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.9 2006/06/12 16:28:08 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.10 2008/07/27 20:14:14 dholland Exp $
|
||||
#
|
||||
|
||||
DISTNAME= exult-1.2
|
||||
PKGREVISION= 5
|
||||
PKGREVISION= 6
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=exult/}
|
||||
|
||||
|
@ -18,4 +18,5 @@ GNU_CONFIGURE= yes
|
|||
|
||||
.include "../../devel/SDL/buildlink3.mk"
|
||||
.include "../../audio/SDL_mixer/buildlink3.mk"
|
||||
.include "../../graphics/freetype2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,7 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.2 2005/02/23 23:11:56 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2008/07/27 20:14:14 dholland Exp $
|
||||
|
||||
SHA1 (exult-1.2.tar.gz) = 81f9d3d428c80990b8e970a4dee5c85a7236dace
|
||||
RMD160 (exult-1.2.tar.gz) = 339231edf84507f05115ab3189875cb15be9c04f
|
||||
Size (exult-1.2.tar.gz) = 1722259 bytes
|
||||
SHA1 (patch-aa) = 2acecb0c4e2da2769559d9603a08930c30b38c72
|
||||
SHA1 (patch-ab) = 039fd49b570ad5796a43d86fb679b517c4149f13
|
||||
SHA1 (patch-ac) = f6a1c4961e62cd99f9f355d14631457d5d2b5458
|
||||
SHA1 (patch-ad) = 6836603f98ec3d8893de27259a82ed2da7d7e9fb
|
||||
SHA1 (patch-ae) = 3b863379cef2948ff92e9971ffbc37d6b1b0276f
|
||||
SHA1 (patch-af) = 43b2369d9dff1fc1aa387c174b3fe7c3e467c2e8
|
||||
SHA1 (patch-ag) = 2c8b385bb2346f0e7d11bd8e721a901ec361bb61
|
||||
|
|
22
games/exult/patches/patch-ac
Normal file
22
games/exult/patches/patch-ac
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ac,v 1.1 2008/07/27 20:14:14 dholland Exp $
|
||||
|
||||
--- hash_utils.h~ 2003-08-31 13:32:24.000000000 -0400
|
||||
+++ hash_utils.h 2008-07-27 13:37:43.000000000 -0400
|
||||
@@ -26,7 +26,7 @@
|
||||
#else
|
||||
#if HAVE_EXT_HASH_MAP
|
||||
# include <ext/hash_map>
|
||||
-# if (defined(__GNUC__) && (__GNUC__ == 3) && ( __GNUC_MINOR__ > 0))
|
||||
+# if (defined(__GNUC__) && ((__GNUC__ == 3) && ( __GNUC_MINOR__ > 0)) || __GNUC__ > 3)
|
||||
using __gnu_cxx::hash_map;
|
||||
# else
|
||||
using std::hash_map;
|
||||
@@ -44,7 +44,7 @@
|
||||
#else
|
||||
#if HAVE_EXT_HASH_SET
|
||||
# include <ext/hash_set>
|
||||
-# if (defined(__GNUC__) && (__GNUC__ == 3) && ( __GNUC_MINOR__ > 0))
|
||||
+# if (defined(__GNUC__) && ((__GNUC__ == 3) && ( __GNUC_MINOR__ > 0)) || __GNUC__ > 3)
|
||||
using __gnu_cxx::hash_set;
|
||||
# else
|
||||
using std::hash_set;
|
17
games/exult/patches/patch-ad
Normal file
17
games/exult/patches/patch-ad
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-ad,v 1.1 2008/07/27 20:14:14 dholland Exp $
|
||||
|
||||
--- mouse.h.orig 2003-08-31 13:32:24.000000000 -0400
|
||||
+++ mouse.h 2008-07-27 13:58:11.000000000 -0400
|
||||
@@ -33,7 +33,11 @@
|
||||
class Mouse
|
||||
{
|
||||
protected:
|
||||
- Shape_file pointers; // Pointers from 'pointers.shp'.
|
||||
+ Shape_file pointers;
|
||||
+#if __GNUC__ == 4 && __GNUC_MINOR__ == 1
|
||||
+ /* I have no idea why this is needed. */
|
||||
+ class
|
||||
+#endif
|
||||
Game_window *gwin; // Where to draw.
|
||||
Image_window8 *iwin; // From gwin.
|
||||
Image_buffer *backup; // Stores image below mouse shape.
|
13
games/exult/patches/patch-ae
Normal file
13
games/exult/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.1 2008/07/27 20:14:14 dholland Exp $
|
||||
|
||||
--- audio/midi_drivers/fmopldrv.h~ 2002-08-06 14:10:31.000000000 -0400
|
||||
+++ audio/midi_drivers/fmopldrv.h 2008-07-27 14:03:16.000000000 -0400
|
||||
@@ -76,7 +76,7 @@
|
||||
/* output a packed midi command to the midi stream
|
||||
* valid only if mode is MO_SIMPLE
|
||||
*/
|
||||
- void OplDriver::send(uint32 b);
|
||||
+ void send(uint32 b);
|
||||
|
||||
/* retrieve a string representation of an error code */
|
||||
static const char *get_error_name(int error_code);
|
13
games/exult/patches/patch-af
Normal file
13
games/exult/patches/patch-af
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-af,v 1.1 2008/07/27 20:14:14 dholland Exp $
|
||||
|
||||
--- usecode/ucxt/include/ucfunc.h~ 2003-08-31 13:32:28.000000000 -0400
|
||||
+++ usecode/ucxt/include/ucfunc.h 2008-07-27 14:07:35.000000000 -0400
|
||||
@@ -206,7 +206,7 @@
|
||||
bool output_list(std::ostream &o, unsigned int funcno, const UCOptions &options);
|
||||
|
||||
bool output_ucs(std::ostream &o, const FuncMap &funcmap, const std::map<unsigned int, std::string> &intrinsics, const UCOptions &options);
|
||||
- std::ostream &UCFunc::output_ucs_funcname(std::ostream &o, const FuncMap &funcmap);
|
||||
+ std::ostream &output_ucs_funcname(std::ostream &o, const FuncMap &funcmap);
|
||||
std::ostream &output_ucs_funcname(std::ostream &o, const FuncMap &funcmap,
|
||||
unsigned int funcid,
|
||||
unsigned int numargs, bool return_var);
|
14
games/exult/patches/patch-ag
Normal file
14
games/exult/patches/patch-ag
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ag,v 1.1 2008/07/27 20:14:14 dholland Exp $
|
||||
|
||||
--- usecode/useval.cc~ 2004-05-23 01:07:11.000000000 -0400
|
||||
+++ usecode/useval.cc 2008-07-27 14:20:59.000000000 -0400
|
||||
@@ -464,7 +464,8 @@
|
||||
if (buflen < 5)
|
||||
return -1;
|
||||
*ptr++ = type;
|
||||
- Write4(ptr, (int)value.ptr);
|
||||
+ /* this may truncate the pointer! */
|
||||
+ Write4(ptr, (int32_t)(intptr_t)value.ptr);
|
||||
break;
|
||||
case string_type:
|
||||
{
|
Loading…
Reference in a new issue